Subject: [Rfc-markdown] 1.2.8: BCP14 boilerplate

From: Carsten Bormann <[email-masked]>
Date: Fri, 19 Jan 2018 11:08:51 +0100

After having been asked for the third time, I have added a simple way to include BCP 14 (RFC2119) boilerplate:

{{::boilerplate bcp14}

(Picking up the existing ::include syntax, but just with named boilerplate items predefined by the tool.)

Is there any other frequently used boilerplate (that is not already inserted by XML2RFC) that should be added here?

Other changes in 1.2.8:

— Now requires at least Ruby 2.0 (which will be five years old in a month).  This allows us to benefit from the most recent fixes in the upstream kramdown parser for markdown.

— The workaround for bad certificate stores is now less aggressive.  So you should receive a message only when your certificate store is indeed lacking.  Please check that your environment is still covered if you do need the workaround…

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 19 Jan 2018 16:36:37 +0100

> {{::boilerplate bcp14}

Oops, this message escaped me with a superfluous brace…  Make that:

{::boilerplate bcp14}

I also failed to say that this is about the kramdown-rfc2629 tool, and that, as usual, you can update to the current version with

	gem update kramdown-rfc2629

(or simply `gem update` to update all rubygems.)

Grüße, Carsten

(This is what I get from having joined a W3C teleconference at 08:00)