Subject: Re: [Rfc-markdown] [Tools-discuss] IEEE in bibxml2 vs. bibxml6

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 8 May 2019 11:29:24 -0400

Carsten,

The version of kramdown at https://xml2rfc.tools.ietf.org/experimental.html
seems to still be using bibxml2 rather than bibxml6 for IEEE references.
For example, I used {{?IEEE.802.1QCD_2015}} and got the error message:

.refcache/reference.IEEE.802.1QCD_2015.xml: fetching
*** 404 Not Found while fetching
https://xml2rfc.tools.ietf.org/public/rfc/bibxml2/reference.IEEE.802.1QCD_2015.xml
*** No such file or directory @ rb_sysopen -
.refcache/reference.IEEE.802.1QCD_2015.xml for ${fn}

The reference is in bibxml6, see
https://xml2rfc.tools.ietf.org/public/rfc/bibxml6/reference.IEEE.802.1QCD_2015.xml
.

Thanks,
Andy

On Wed, Feb 27, 2019 at 9:53 AM Carsten Bormann <[email-masked]> wrote:

> Kramdown-rfc2629 version 1.2.11 now searches bibxml6 for IEEE.* references
> such as:
>
>   IEEE.754.1985:
>
> There should be no user-visible change for IEEE.* references that already
> worked.
> But new ones should now be working: those that have been added to bibxml6,
> but not to bibxml2.  See for yourself:
>
> http://xml2rfc.tools.ietf.org/public/rfc/bibxml6/
>
> As always, update via
>
>         gem update kramdown-rfc2629
>
> (add a sudo if needed on your platform), or simply `gem update` to update
> all rubygems.
>
> Grüße, Carsten
>
> > On Feb 27, 2019, at 14:45, Henrik Levkowetz <[email-masked]>
> wrote:
> >
> >
> > On 2019-02-27 14:38, Carsten Bormann wrote:
> >> On Feb 27, 2019, at 14:34, Henrik Levkowetz <[email-masked]>
> wrote:
> >>>
> >>> For now, I'll happily copy the bibxml2 IEEE entries to bibxml6.
> >>>
> >>> Shall I do so?
> >>
> >> Please do, assuming there are no conflicts.
> >> Then I’ll switch to bibxml6 for IEEE.* references in the next version
> of kramdown-rfc.
> >
> > Ok, done.
> >
> > Best,
> >       Henrik
> >
>
> _______________________________________________
> Rfc-markdown mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rfc-markdown
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 8 May 2019 17:50:05 +0200

On May 8, 2019, at 17:29, Andrew G. Malis <[email-masked]> wrote:
> 
> The version of kramdown at https://xml2rfc.tools.ietf.org/experimental.html seems to still be using bibxml2 rather than bibxml6 for IEEE references. For example, I used {{?IEEE.802.1QCD_2015}} and got the error message:

Right, that says:
  <!-- generated by https://github.com/cabo/kramdown-rfc2629 version 1.2.10 -->

Hi Henrik, can you do a `gem update`?

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 8 May 2019 18:04:08 +0200

Hi Carsten,

> Hi Henrik, can you do a `gem update`?

Done!

	Henrik

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 8 May 2019 12:30:48 -0400

Henrik,

Thanks!

Cheers,
Andy

On Wed, May 8, 2019 at 12:04 PM Henrik Levkowetz <[email-masked]>
wrote:

> >> The version of kramdown at
> https://xml2rfc.tools.ietf.org/experimental.html seems to still be using
> bibxml2 rather than bibxml6 for IEEE references. For example, I used
> {{?IEEE.802.1QCD_2015}} and got the error message:
> >
> > Right, that says: