Subject: Re: [Rfc-markdown] [Tools-discuss] Reference to NIST document

From: Carsten Bormann <[email-masked]>
Date: Sat, 19 Jun 2021 18:40:05 +0200

… and if you really want to use the undocumented and slightly broken bibxml-nist-new, for now please run these two commands once (in your draft directory):

wget https://xml2rfc.tools.ietf.org/public/rfc/bibxml-nist-new/reference.NIST.SP.800-56Ar3.xml
sed -i.bak 1d reference.NIST.SP.800-56Ar3.xml

(get a local copy of the .xml and remove the xml declaration), and add...

--- informative

{::include reference.NIST.SP.800-56Ar3.xml}

... before your

--- back

I don’t want to automate anything like this until, later this year, the bibxml services have been renovated.

Grüße, Carsten

> On 2021-06-19, at 18:09, Carsten Bormann <[email-masked]> wrote:
> 
>> On 2021-06-19, at 17:59, Carsten Bormann <[email-masked]> wrote:
>> 
>>  NIST.SP.800-56a: DOI.10.6028/NIST.SP.800-56a
> 
> … or, since you asked about 10.6028/NIST.SP.800-56Ar2 …
> 
> informative:
>   NIST.SP.800-56Ar2: DOI.10.6028/NIST.SP.800-56Ar2
> 
> ➔
>   [NIST.SP.800-56Ar2]
>              Barker, E., Chen, L., Roginsky, A., and M. Smid,
>              "Recommendation for Pair-Wise Key Establishment Schemes
>              Using Discrete Logarithm Cryptography", National Institute
>              of Standards and Technology report,
>              DOI 10.6028/nist.sp.800-56ar2, May 2013,
>              <https://doi.org/10.6028/nist.sp.800-56ar2>.
> 
> Grüße, Carsten
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 19 Jun 2021 21:49:16 +0200

> On 2021-06-19, at 21:44, Michael Richardson <[email-masked]> wrote:
> 
> 
> Carsten Bormann <[email-masked]> wrote:
>> The NIST reference collections are really dusty at this point.
>> Kramdown-rfc does not do shopping around, so a NIST.* reference triggers lookup in bibxml2.
> 
>> I’m lazy and usually use DOIs for NIST references.
> 
>> Putting...
> 
>> informative:
> Is "NIST." an kramdown thing?

Kramdown-rfc recognizes NIST.* labels and tries to look them up in bibxml2.

However, the syntax above uses a DOI reference and then renames that, so the above magic is not applied.

> I recognize the DOI as being an alias, but I didn't know I could put a / in there.

Both / and _ should work; since the point of the rename is to get to choose an anchor of one’s liking (and so it doesn’t matter that “/“ cannot be in an anchor), I just copied the / from the original DOI.

> Is anything special done with a DOI?

If it looks like DOI.*, it will be looked up for you from doi.org, so you don’t need to supply your own reference.  doi.org info can be a bit sketchy, though, so better check, and use kramdown-rfc’s doilit tool plus some hand editing if you don’t like the result.

https://github.com/cabo/kramdown-rfc2629/wiki/Pitfalls#reference-anchors

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Sat, 19 Jun 2021 17:36:23 -0400

> If it looks like DOI.*, it will be looked up for you from doi.org, so
    > you don’t need to supply your own reference.  doi.org info can be a bit
    > sketchy, though, so better check, and use kramdown-rfc’s doilit tool
    > plus some hand editing if you don’t like the result.

    > https://github.com/cabo/kramdown-rfc2629/wiki/Pitfalls#reference-anchors

Given that DOIs seem to be on the rise, this is a really useful thing, and I
think it deserves some more awareness :-)

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide