Subject: Re: [Rfc-markdown] [Tools-discuss] [irsg] [EXTERNAL] Question about Codimd for w.g. minutes

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 13:13:50 +0200

On 2021-07-30, at 02:39, Bob Hinden <[email-masked]> wrote:
> 
> I hope we can make sure that the common tools like Codimd and the Datatracker do compatible things.   

I have been informed by a friendly HedgeDoc maintainer (HedgeDoc = independent open-source version of CodiMD) that this is easy to achieve [0].  Just insert

---
breaks: false
...

at the start of the CodiMD document and all will be standard(*).

(This also can be set system-wide, but that might break existing documents written without this.)

I’d stick with the CodiMD default `breaks: true`, though, as this is nicer for note-taking; see [1] for the discussion that led to this being the default for hedgedoc.  This is where the de-gfm tool that is now in kramdown-rfc will come in handy.  Or let CodiMD do the HTML conversion, but then there is no standard markdown to put into repos etc.

Grüße, Carsten

[0]: https://demo.hedgedoc.org/s/yaml-metadata#breaks

(*) note that the docs say

---
breaks: false
---

(probably because it’s more pleasingly symmetrical) but that is not standard YAML, so I recommend the three-dot version (which is also the one accepted in kramdown-rfc documents.).

[1]: https://community.hedgedoc.org/t/should-we-change-the-hedgedoc-default-for-breaks-from-true-to-false/298
Beautiful “vote” in there!

---

From: David Mehren <[email-masked]>
Date: Fri, 30 Jul 2021 13:48:51 +0200

Hi everyone, another HedgeDoc maintainer here.

Am 30.07.21 um 13:13 schrieb Carsten Bormann:
> I have been informed by a friendly HedgeDoc maintainer (HedgeDoc = independent open-source version of CodiMD) that this is easy to achieve [0].
HedgeDoc is actually the same project that released CodiMD 1.6 (which is 
the version currently deployed at codimd.ietf.org). We renamed to reduce 
confusion with the project that we forked from. More details can be 
found on our history page at [1].
> (This also can be set system-wide, but that might break existing documents written without this.)
There currently is no system-wide setting that would override existing 
notes. An administrator can set the default content for *new* notes, as 
outlined in [2]. This may actually be the solution for your instance?

I would recommend to upgrade the instance at codimd.ietf.org to HedgeDoc 
1.8.2, as previous releases have multiple security vulnerabilities (see 
[3]).

Best regards
David

[1] https://hedgedoc.org/history/
[2] https://github.com/hedgedoc/hedgedoc/issues/59#issuecomment-489188611
[3] https://github.com/hedgedoc/hedgedoc/security/advisories?state=published