Subject: [Rfc-markdown] Markdown for presentations

From: Benson Muite <[email-masked]>
Date: Thu, 22 Jul 2021 09:49:48 +0300

One of the hackathon templates uses Markdown:
https://github.com/IETF-Hackathon/ietf111-project-presentations
As the format is very user friendly, it may be something that is useful 
to consider when creating and modifying markdown related RFCs

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 22 Jul 2021 15:45:52 +0200

On 2021-07-22, at 08:49, Benson Muite <[email-masked]> wrote:
> As the format is very user friendly, it may be something that is useful to consider when creating and modifying markdown related RFCs

Nice.  I started doing something like this in the mid-1980s (before markdown was invented :-), based on troff and a lex-based [101 lines of code] textile-like markup language, inspired by the outliners of the day), and I have been convinced since that this is the right way to create slides for my lectures.

There also have been various HTML-based slide presenters.  In the mid-2000s s5.html was popular; today reveal.js seems to be leading the mindshare in javascript packages for putting up HTML-based slides.

remark [1] [2], as used by the hackathon template, enables the use of markdown inside such an HTML-based deck; the JavaScript slide presenter inside an HTML shell essentially interprets that pasted-in markdown.

Today, many markdown-based tools also include a slide mode.
For instance the markdown-based collaborative editor Hedgedoc (née hackmd and then for a while CodiMD) has a slide mode; this is directly accessible on IETF’s codimd.ietf.org as well.

I personally use a paid Mac-only tool called Deckset (which I cannot recommend to IETFers, but only because of “the illusion of vendor support” [RFC0873]).  It does serve me well, and the markdown ports back and forth great between code, slides, and I-Ds.

The slide deck aspect (new slide, incremental builds, footers, styles) of markdown isn’t really written down, so everyone has their own little markdown extensions, e.g., [3], but these are similar enough and slide decks are usually small enough that a little hand conversion doesn’t hurt too much.

Grüße, Carsten

[1]: https://github.com/gnab/remark
[2]: https://remarkjs.com/
[RFC0873]: Padlipsky, M., "Illusion of vendor support", RFC 873, DOI 10.17487/RFC0873, September 1982, <https://www.rfc-editor.org/info/rfc873>.
[3]: https://github.com/gnab/remark/wiki/Markdown

---

From: Benson Muite <[email-masked]>
Date: Sat, 24 Jul 2021 10:21:06 +0300

> There also have been various HTML-based slide presenters.  In the mid-2000s s5.html was popular; today reveal.js seems to be leading the mindshare in javascript packages for putting up HTML-based s…
This is a nice package, though maybe heavier than what is needed when 
using a Git powered workflow. It has good design choices.
> remark [1] [2], as used by the hackathon template, enables the use of markdown inside such an HTML-based deck; the JavaScript slide presenter inside an HTML shell essentially interprets that pasted…
My only worry is that some knowledge of HTML is required to use remark.
> For instance the markdown-based collaborative editor Hedgedoc (née hackmd and then for a while CodiMD) has a slide mode; this is directly accessible on IETF’s codimd.ietf.org as well.
This is nice, seems to use revealjs. Does not require knowledge of Git.
> I personally use a paid Mac-only tool called Deckset (which I cannot recommend to IETFers, but only because of “the illusion of vendor support” [RFC0873]).  It does serve me well, and the markdown…
Nice to see that people are building other tools based on this.
> The slide deck aspect (new slide, incremental builds, footers, styles) of markdown isn’t really written down, so everyone has their own little markdown extensions, e.g., [3], but these are similar…
Markdown slides do enable a very nice separation of concerns between the 
content and the template. Modifying a parser is ok for those with 
technical backgrounds/interest. There will be an audience of people, not 
all of whom have high technical backgrounds/interest, who want to make 
their presentation decks available to their presenters while they speak. 
  Making it easy to create portable Markdown presentation content might 
be helpful. PDF is not so great for online viewing and sharing, for 
example for IETF presentations:
https://datatracker.ietf.org/meeting/110/proceedings
Having a consistent format would also enable better data tracking of 
IETF presentation content.