Subject: Re: [Rfc-markdown] revising RFC8366 -- upgrade it for me?

From: Michael Richardson <[email-masked]>
Date: Sun, 04 Jul 2021 17:55:54 -0400

Carsten has just given me a Markdown version of RFC8366.

I'm not sure if it's kdrfc or xml2rfc or...
but the datatracker.ietf.org/doc/html/rfcXXXX seems to be used rather than
rfc-editor.org/info/rfcXXXX.   Is this a conscious choice somewhere?

https://www.ietf.org/rfcdiff?url1=rfc8366&url2=https://www.sandelman.ca/tmp/draft-richardson-anima-rfc8366bis.txt

(look at the normative references.  I don't know how to encode that I want
html wdiff in the URL for rfcdiff, but that version is more obvious)

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Jul 2021 00:17:46 +0200

On 2021-07-04, at 23:55, Michael Richardson <[email-masked]> wrote:
> Signed PGP part

The choice of URL prefix for target URIs in RFC and I-D references is a parameter to xml2rfc [1].

Kdrfc calls xml2rfc with default parameters here, which seem to yield what you are seeing, probably a bug:

              <https://www.ietf.org/archive/id/draft-...
              <https://www.rfc-editor.org/info/rfc...

I could put in some parameter mangling, as Martin Thomson did for I-D-template (which calls xml2rfc by itself, with these parameters:)

XML2RFC_RFC_BASE_URL := https://datatracker.ietf.org/doc/html/
XML2RFC_ID_BASE_URL := https://datatracker.ietf.org/doc/html/
xml2rfc ?= xml2rfc -q -s 'Setting consensus="true" for IETF STD document' --rfc-base-url $(XML2RFC_RFC_BASE_URL) --id-base-url $(XML2RFC_ID_BASE_URL)

None of these is “right”.
Which ones do you want?

Grüße, Carsten

[1]: https://xml2rfc.tools.ietf.org/xml2rfc-doc.html#name-html-format-options-2

---

From: Michael Richardson <[email-masked]>
Date: Sun, 04 Jul 2021 19:11:59 -0400

> parameter to xml2rfc [1].

ah, okay.

    > what you are seeing, probably a bug:

I guess I thought that kdrfc was inlining everything when stand_alone.
I guess that doesn't include the URL itself.

    > I could put in some parameter mangling, as Martin Thomson did for
    > I-D-template (which calls xml2rfc by itself, with these parameters:)

I'm trying to "upgrade" to pure MT makefile, so maybe it doesn't put
in the same --rfc-base-url for kramdown as it does for xml.

    > None of these is “right”.

I thought that the consensus was that we needed to link to
rfc-editor.org/info in order to make sure that people go there, and can see
errata, etc.