Subject: [Rfced-future] Creation/dissolution

From: Michael StJohns <[email-masked]>
Date: Thu, 26 Aug 2021 17:33:49 -0400

Here's a cut.  Somewhat legalistic, but provides the basis for fixing a 
problem if it exists.  Note that this is an all or nothing - this 
doesn't give the IAB/IESG/LLC the ability to direct changes the RFC  
outside of the RSAB/RSWG process, but allows them to kill that process 
if necessary.

## Dissolution of the RSAB and RSWG

By mutual agreement of the IAB, the IETF and the IETF LLC Board, and 
with the consensus of the community, this document creates the RSAB, 
RSWG and the Editorial series within the IETF framework. To provide for 
the possibility that the needs of the community may change over time, or 
are not being satisfied by the system and organization described herein, 
the IAB, the IETF and the IETF LLC Board when acting collectively with 
the consensus of the community reserve the authority to disestablish 
either or both of the RSAB and RSWG and to redirect the authorities and 
responsibilities assigned to those groups as necessary.

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 27 Aug 2021 08:38:10 +1000

> On 27 Aug 2021, at 7:33 am, Michael StJohns <[email-masked]> wrote:
> 
> Here's a cut.  Somewhat legalistic, but provides the basis for fixing a problem if it exists.  Note that this is an all or nothing - this doesn't give the IAB/IESG/LLC the ability to direct changes the RFC  outside of the RSAB/RSWG process, but allows them to kill that process if necessary.
> 
> By mutual agreement of the IAB, the IETF and the IETF LLC Board, and with the consensus of the community, this document creates the RSAB, RSWG and the Editorial series within the IETF framework. To provide for the possibility that the needs of the community may change over time, or are not being satisfied by the system and organization described herein, the IAB, the IETF and the IETF LLC Board when acting collectively with the consensus of the community reserve the authority to disestablish either or both of the RSAB and RSWG and to redirect the authorities and responsibilities assigned to those groups as necessary.

I'm concerned that this might cause unnecessary strife if it ever actually needs to be used; saying that the IETF rather than the IESG is problematic because the only way to get an IETF position on something is to issue an RFC. Likewise, measuring the 'consensus of the community' has proven controversial, given the amorphous nature of the community in question.

I'd suggest something like:

This document creates the RSAB, RSWG and Editorial Series by mutual agreement of the IAB, the IESG and the IETF LLC Board, reflecting community consensus as established in the RFC Editor Future Development Program. Change to the Editorial Series are managed through the process defined here. Changes to the responsibilities and authorities of the RSAB and RSWG (including dissolution) require mutual agreement of the IAB, IESG and IETF LLC Board, well as a community consensus established in a manner defined by the IAB.

... where 'a manner defined by the IAB' is open to other suggestions -- we just need to define who holds the ball for scoping rfced-future2 if the need arises.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: IETF Executive Director <[email-masked]>
Date: Fri, 27 Aug 2021 10:49:03 +1200

> On 27/08/2021, at 9:33 AM, Michael StJohns <[email-masked]> wrote:
> 

I would be cautious about giving the LLC a role here that is anything other than advising on the financial/operational feasibility of any such plan.

Jay

> 
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 27 Aug 2021 11:01:28 +1200

> ... where 'a manner defined by the IAB' is open to other suggestions -- we just need to define who holds the ball for scoping rfced-future2 if the need arises.

Agreed, but this omits the IRTF and the Independent Series and that isn't OK.

Also - I take your point about IESG v IETF, but I think the IESG must obtain IETF input for something this important. So "IESG after consulting the IETF" or something like that.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 27 Aug 2021 11:03:29 +1200

> I would be cautious about giving the LLC a role here that is anything other than advising on the financial/operational feasibility of any such plan.

Good point. That may need an extra sentence.

   Brian

---

From: Michael StJohns <[email-masked]>
Date: Thu, 26 Aug 2021 19:34:15 -0400

> Good point. That may need an extra sentence.

Nope.   This is not about advising, its about agreeing.   In the 
creation phase, the LLC has to agree to pay related costs of this 
transition, and there probably will be some.  In the dissolution phase, 
there will be costs rehoming things and the LLC will have to agree with 
those costs.   Given that I think the LLC needs to be an approving body 
for both dissolution and creation.

---

From: Michael StJohns <[email-masked]>
Date: Thu, 26 Aug 2021 19:35:47 -0400

> Also - I take your point about IESG v IETF, but I think the IESG must obtain IETF input for something this important. So "IESG after consulting the IETF" or something like that.

I actually meant IESG vice IETF.  And community stands in for what I 
think you mean by IETF above.

Mike

---

From: Michael StJohns <[email-masked]>
Date: Thu, 26 Aug 2021 19:50:04 -0400

On 8/26/2021 7:35 PM, Michael StJohns wrote:
>> Also - I take your point about IESG v IETF, but I think the IESG must 
>> obtain IETF input for something this important. So "IESG after 
>> consulting the IETF" or something like that.
>
Drat -

Also, do you mean to give the ISE and Colin veto over the creation or 
dissolution of the process?  Mutual agreement means unanimous agreement 
in this case, not a vote of 2 to 1 or 3-2.

Neither the ISE nor the IRTF chair are selected by the community, but by 
the IAB.   While their needs and issues will be considered in the RSWG 
and RSAB, it's pretty clear that the IAB holds the reins for both of 
those positions and it's unclear why the IAB should get three votes here.

Later, Mike

ps - alternately, a 2/3 vote of every Nomcom selected participant (e.g. 
IETF chair, ADs, IAB members, LLC board, IETF Trust - am I forgetting 
one?) might be an alternative to the mutual agreement of the various boards.

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 27 Aug 2021 09:55:56 +1000

Mike,

> On 27 Aug 2021, at 9:50 am, Michael StJohns <[email-masked]> wrote:
> 
> Neither the ISE nor the IRTF chair are selected by the community, but by the IAB.   While their needs and issues will be considered in the RSWG and RSAB, it's pretty clear that the IAB holds the reins for both of those positions and it's unclear why the IAB should get three votes here.

I'm having trouble interpreting this comment -- if the IAB were a single company, country or other interest, I could see where you're coming from, but they're selected from the community, by the community,  as a whole. They, in turn, select the IRTF Chair and ISE from the community, based upon community input; presumably, both of those people are respected by the community and act independently of the IAB. So I think it's a long stretch to see this as the IAB getting three votes -- and even if you view it that way, what kind of bias is being introduced?

Cheers,

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 26 Aug 2021 16:59:05 -0700

I'm a little unclear on what problem is being solved for here.

Taking a step back, suppose that the RSAWG and RSAB jointly agreed on some
restructuring of the
process (e.g., dissolving the RSAWG and reverting control to the IAB),
would they be able to do so
without this mechanism?

-Ekr

---

From: Michael StJohns <[email-masked]>
Date: Thu, 26 Aug 2021 20:10:33 -0400

On 8/26/2021 7:59 PM, Eric Rescorla wrote:
> Taking a step back, suppose that the RSAWG and RSAB jointly agreed on 
> some restructuring of the

I don't see how.  The authority we're delegating is over the RFC series 
process, not the meta process that created them.

>
> -Ekr
>
>
> On Thu, Aug 26, 2021 at 4:50 PM Michael StJohns 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     >> Agreed, but this omits the IRTF and the Independent Series and
>     that
>     >> isn't OK.
>     >>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.iab.org/mailman/listinfo/rfced-future>
>

---

From: Michael StJohns <[email-masked]>
Date: Thu, 26 Aug 2021 20:16:15 -0400

> I'm having trouble interpreting this comment -- if the IAB were a single company, country or other interest, I could see where you're coming from, but they're selected from the community, by the co…

I don't doubt that either of these folk are respected by the community, 
nor that they effectively act independently of the IAB - currently.   
But in the final analysis, they are not appointed by the community 
regardless of how much input the IAB gets on them.

It's not a matter of bias in the current instance, but as both the ISE 
and the IRTF chair serve at the pleasure of the IAB, if both of them 
disagreed with the other three bodies, the IAB could simply replace them 
with more tractable members.  That's a capability of the way those two 
people are appointed, and needs to be considered in any fail safe 
dissolution mechanism we put in. So maybe not three votes, but certainly 
an ability to remove two votes that disagree with the IAB.

Later, Mike

---

From: Michael StJohns <[email-masked]>
Date: Thu, 26 Aug 2021 20:19:37 -0400

On 8/26/2021 8:10 PM, Michael StJohns wrote:
>> process (e.g., dissolving the RSAWG and reverting control to the 
>> IAB), would they be able to do so
>> without this mechanism?
>
> I don't see how.  The authority we're delegating is over the RFC 
> series process, not the meta process that created them.
>
Sorry - I hit send too early.  The other consideration is to the IESG 
and the LLC who may not want the process to revert to the IAB for 
whatever reason, or at least don't want the RSAB or RSWG to be in 
control of where it lands.

The members of the RSAB and RSWG can certainly decide they don't want to 
play anymore, but the remedy for that is replacement of the RSWG chairs 
and the RSAB members, not allowing those who have given up on the 
process to kill the process.

Mike

---

From: Michael StJohns <[email-masked]>
Date: Thu, 26 Aug 2021 20:20:52 -0400

On 8/26/2021 6:38 PM, Mark Nottingham wrote:
> I'm concerned that this might cause unnecessary strife
Could you explain that?   These terms tend to exist in most formally 
created bodies and in fact there's 4 paragraphs in the IETF LLC document 
on dissolution and how it happens.
> if it ever actually needs to be used; saying that the IETF rather than the IESG is problematic
Yup - I actually mean IESG here - good catch.
> because the only way to get an IETF position on something is to issue an RFC. Likewise, measuring the 'consensus of the community' has proven controversial, given the amorphous nature of the community in question.

Not really.   We publish the intent as broadly as we can, we invite 
comments, we respond to comments, and resolve comments and then the IAB, 
IESG and LLC review that and make a decision.   In some ways this would 
have been easier when we were part of the ISOC and indeed we probably 
need to include the ISOC as the place where an appeal of this decision 
would be heard.

> This document creates the RSAB, RSWG and Editorial Series by mutual agreement of the IAB, the IESG and the IETF LLC Board, reflecting community consensus as established in the RFC Editor Future Development Program.

Except that we've already agreed that this requires a community call for 
consensus outside this self-selected body.   So its not "as established 
in....".

>   Change to the Editorial Series are managed through the process defined here. Changes to the responsibilities and authorities of the RSAB and RSWG (including dissolution) require mutual agreement of the IAB, IESG and IETF LLC Board, well as a community consensus established in a manner defined by the IAB.

We're delegating all of the responsibility and authority for the RFC 
series to the RSAB/RSWG - I'm not sure what changes to those would make 
sense other than dragging them back and parceling them out again.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 26 Aug 2021 21:29:57 -0400

I had assumed that the problem being solved was how to recover if the 
RSWG / RSAB became non-functional.  Expecting the RSWG / RSAB to fix 
itself in that case seems unlikely.

Yours,
Joel

On 8/26/2021 7:59 PM, Eric Rescorla wrote:
> On Thu, Aug 26, 2021 at 4:50 PM Michael StJohns <[email-masked] 
> <mailto:[email-masked]>> wrote:
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 27 Aug 2021 13:39:58 +1200

On 27-Aug-21 12:16, Michael StJohns wrote:
>>> Neither the ISE nor the IRTF chair are selected by the community, but 
by the IAB.   While their needs and issues will be considered in the RSWG 
and RSAB, it's pretty clear that the IAB holds the reins for both of those positions and it's unclear why the IAB should get three votes here.
>> I'm having trouble interpreting this comment -- if the IAB were a single company, country or other interest, I could see where you're coming from, but they're selected from the community, by the community,  as a whole. They, in turn, select the IRTF Chair and ISE from the community, based 
upon community input; presumably, both of those people are respected by the community and act independently of the IAB. So I think it's a long stretch to see this as the IAB getting three votes -- and even if you view it that way, what kind of bias is being introduced?

> regardless of how much input the IAB gets on them.

The IRTF Chair convenes the IRSG and is certainly perceived in a
leadership role by IRTF participants. I think that means that the
Chair has an independent voice.

The ISE is a bit different, because there is (by construction; the
word is Independent) no community to be identified. But I'm not
aware of any ISE having considered themself a tool of the IAB.

> an ability to remove two votes that disagree with the IAB.

Yes, but if it came to that we'd have a much, much worse problem
with the IAB.

    Brian

---

From: Lars Eggert <[email-masked]>
Date: Fri, 27 Aug 2021 09:50:30 +0300

Hi,

On 2021-8-27, at 2:50, Michael StJohns <[email-masked]> wrote:
>> I actually meant IESG vice IETF.  And community stands in for what I think you mean by IETF above.

Mike's text (with that correction) would work for me. Jay's point - whether the involvement of the LLC here would need to be clarified a bit more - is IMO orthogonal.

> Neither the ISE nor the IRTF chair are selected by the community, but by the IAB.   While their needs and issues will be considered in the RSWG and RSAB, it's pretty clear that the IAB holds the re…

I agree with this, too. I think I made a similar argument some time ago on some other issue.

One open question is what happens if at some point an RFC stream got created that was not directly or indirectly under the control of the IAB, IESG or RSWG - would the owner of that stream get a voice in this process. They probably should.

Thanks,
Lars

PS: Speaking as an individual, above and in general on this list. (It's been pointed out to me that I should clarify when I speak as chair and when I don't. Generally, I try to post from chair @ietf.org when I do.)

---

From: Colin Perkins <[email-masked]>
Date: Fri, 27 Aug 2021 13:49:48 +0100

> On 27 Aug 2021, at 00:01, Brian E Carpenter <[email-masked]> wrote:
> 

“… by mutual agreement of the IAB, IESG, IRSG, ISE, and IETF LLC Board” 

> Also - I take your point about IESG v IETF, but I think the IESG must obtain IETF input for something this important. So "IESG after consulting the IETF" or something like that.

Is that not covered by the later mention of community consensus?

Or "by mutual agreement of … after consultation with their respective communities”?

That said, while mutual agreement on changes is a desirable goal, if things have broken down so badly that the IETF believes it has to dissolve the RSWG and RSAB, then I have trouble believing the other streams could, in practice, veto that, whatever we write here. 

Colin 
(as individual)

---

From: John C Klensin <[email-masked]>
Date: Sat, 28 Aug 2021 13:12:42 -0400

Mike and others,

(comment from the fringe)

I've tried to follow this thread (without complete success for
other reasons) and wonder if we are asking the wrong question
and, perhaps as a result, not only overengineering things but
applying our efforts in the wrong place.  Should sufficiently
bad conditions arise, I think it is extremely important that
"we" (for some value of "we") be able to look at the structure
this effort is producing and say "not working; unable to fix
itself; time to discard these ideas and start over".  However,
it is unclear to me that the mechanisms being described (and any
of the variations) are necessary and sufficient to the job.

Consider:

* When we completed the POISED work, we did not include
procedures for dissolving and discarding either the IAB or IESG.
I don't recall it even being discussed, but I think that we
assumed that, if there were serious problems, they were more
likely to lie in people than in institutional structures and
that, if the structures became a significant part of the
problem, we could return to the type of insurrection that led to
the major POISED changes (I think that hypothesis may now be
incorrect, but that is another issue).  These arrangements are
different because the interplay among three to five entitles
(RSAB, RSWG, RSEA*, and maybe RPC and LLC) is more complex than,
IMO, anything we have seen before.  But maybe not that different.

* The analogies to legal entities are interesting and important,
but perhaps mostly because such an entity is one thing that is
not being created here.

* This arrangement might be different, but history suggests that
it is as, and likely more, likely that the IAB or IESG will go
off the rails than the new structure will.  If one or both did
(perhaps by seriously disagreeing with some decision of the RFC
process), requiring those bodies to agree among themselves that
there was a serious enough problem with the RFC Editor Function
to justify dissolving anything would be likely to turn into an
opportunity to entangle the RFC Editor Function in far more
complicated disputes and power games.  In theory, the
community's remedy for that sort of problem --one than cannot
wait out a few Nomcom cycles-- is the recall procedure, but we
know that does not work.

So, two very tentative suggestions instead:

(1) Rather than working on dissolution mechanisms, let's think
of a periodic (or at least one-time) review model.  Perhaps we
could make this effort dormant rather than shutting it down but
reconvene it in a few years to do a review of what is working
and what isn't and whether more or less significant changes are
needed.  That review would focus exclusively on the structural
arrangements and not on people ... unless the structures were
preventing the people from functioning.  If particular people
were preventing the structures from functioning well, that is,
and would be, a different sort of problem.

(2) While it is far outside the scope of this effort, perhaps it
is time to take a serious look at the recall mechanism, the
reasons why it has become impossible to use it as a useful part
of an accountability model, and how it might be chanced or
replaced to be a meaningful accountability mechanism.  It is
possible that what we would learn from that discussion would be
helpful for the RFC Editor Function (or perhaps not).  I note
that the IESG has (at least apparently) been very resistant to
any changes to the recall mechanism that would make it easier
and faster to remove their members from office.  However, at
least part if the reason was that the problem didn't need
fixing.  If there were strong community consensus that it,
indeed, did need fixing, then maybe it would be possible to move
forward.

best,
   john

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 29 Aug 2021 10:25:56 +1200

> of a periodic (or at least one-time) review model.

Or do both, but certainly a review mechanism after N years seems
very useful.

(I agree about the recall mechanism needing review, but that should
probably be kicked over the fence to the IETF.)

Regards
   Brian

---

From: John C Klensin <[email-masked]>
Date: Sat, 28 Aug 2021 19:02:53 -0400

--On Sunday, August 29, 2021 10:25 +1200 Brian E Carpenter
<[email-masked]> wrote:

> Or do both, but certainly a review mechanism after N years
> seems very useful.

Ack.  But, in case it was not clear from the longer note, my
concern about dissolution mechanisms is that the long discussion
leaves me with the strong feeling that we will take a lot of
time getting the details pinned down and then, if we ever
discover the mechanism is needed, that it won't work.  The most
obvious case is that, if N bodies have to agree that something
should be dissolved, and one of those bodies was part of the
problem...
 
> (I agree about the recall mechanism needing review, but that
> should probably be kicked over the fence to the IETF.)

Indeed.  Relevant to this group only insofar as, if we had a
working one of those, it might provide a useful model for
dealing with a seriously disfunctional collection of RFC Editor
function bodies.  For example, if there were a problem for which
the right solution was to fire the membership of some particular
body and reconstitute the membership from scratch, dissolving
the body may be unnecessarily complex and destructive overkill.

    john