Subject: Re: [Rfced-future] Replacement text for Section 4.2

From: John C Klensin <[email-masked]>
Date: Mon, 02 Aug 2021 18:57:57 -0400

FWIW, Mike's comments below (and at least some of those
expressing agreement) are consistent with what I tried to say
during the meeting:

I'm concerned about handing too much over to the LLC because, in
this case, the optimal way to run a company may not be the
optimal way of overseeing / running the RFC Editor Function and
because it can lead to things closely resembling the "just a
contractor" disease that got us into this mess.  There is also
nothing in the job descriptions of either the LLC ExecDir or the
LLC Board requiring sufficient expertise in publication matters
to predict that they will be able to make educated decisions
about the selection of an RSEA or even that they would have
sufficient knowledge and expertise to be able to make a good
choice a search firms to help.  

However, if that is what we are doing -- either because others
are more comfortable with the "put the LLC in charge" idea or
because all other options are worse-- then let's try to minimize
very detailed instructions and trust Jan and his successors to
do their job(s).

   john

--On Sunday, 01 August, 2021 20:24 -0400 Michael StJohns
<[email-masked]> wrote:

> On 8/1/2021 7:38 PM, Brian E Carpenter wrote:
>> On 02-Aug-21 11:09, Michael StJohns wrote:
>>> So delete section 4.2 in its entirety?  I'm good with that.
>> Really? I agree that it is not a good idea to specify too
>> many details; the LLC clearly owns the process, but stating
>> that community feedback is part of the process seems
>> desirable. Something like:
>> 
>>     Periodically, the IETF LLC will evaluate the performance
>>     of the RSEA, including a call for confidential input from
>>     the community.
> 
> Really.  We're going to inject a requirement that the LLC
> make a call for community input, that implies that the LLC
> will do that whether or not it makes contractual or HR sense
> to do and that the LLC is required to pay an undefined level
> of attention to any input from that process.  I'd rather
> leave the whole evaluation thing in the LLC's hands to decide
> whether and when it needs to make a community call, and for
> the candidates being hired or contracted to be able to
> negotiate the impact of such input.    So if you want to
> specify the requirement for "confidential input from the
> community", then it's only fair to specify how that input will
> impact the LLC's decisions and provide the appropriate safety
> valves to allow the RSEA to push back against and the LLC to
> ignore inappropriate or biased input.
> 
> I'd rather leave this to the contracting process and for the
> LLC to do the right thing in conjunction with any HR and Legal
> help that they engage.  I expect they probably will ask for
> input, but it would be their choice to do so.
> 
> Was there any language in Jay's contract or employment
> agreement requiring the LLC to ask for public comment on his
> performance? If not, I don't see any reason to do that here.
> 
>> 
>> Also the last sentence of the current text needs to be said
>> somewhere:
>> 
>>     Whether the RSEA role is structured as a contractual or
>>     employee relationship is a matter for the IETF LLC and
>>     the IETF Executive Director to determine.
> 
> Was there something similar in one of the documents when
> Heather was hired/contracted?  I forget.  I don't actually
> think its necessary as the LLC holds the money and hence the
> decision process on the engagement mode.
> 
> Mike
> 
> 
> 
>> 
>>   Brian

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 2 Aug 2021 19:10:58 -0400

I read the text as being aimed at providing appropriate guardrails 
(mandating what we consider necessary) while trusting the LLC / IAD to 
execute reasonably well.

For example, if we do not tell them they need to consult the community, 
then a complaint to the nomcom that they did not consult the community 
is not very strong.  If we require it, then the complaint is saying 
something.

Yours,
joel

---

From: John C Klensin <[email-masked]>
Date: Mon, 02 Aug 2021 22:07:49 -0400

--On Monday, 02 August, 2021 19:10 -0400 "Joel M. Halpern"
<[email-masked]> wrote:

> I read the text as being aimed at providing appropriate
> guardrails (mandating what we consider necessary) while
> trusting the LLC / IAD to execute reasonably well.
> 
> For example, if we do not tell them they need to consult the
> community, then a complaint to the nomcom that they did not
> consult the community is not very strong.  If we require it,
> then the complaint is saying something.

Joel,

Given that we are going down that path, I have no problem with
"consult the community" and, for the reason you give, think it
is probably a good idea.  Where I start having a problem is with
getting into details about what "consult" means, how they are to
consult, what various people tell each other and how things are
reported, etc., etc.

   john

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 3 Aug 2021 14:24:27 +1200

> consult, what various people tell each other and how things are

Exactly why I suggested a single sentence version instead of the
two or three paragraphs in the current draft.

   Brian

---

From: Michael StJohns <[email-masked]>
Date: Mon, 2 Aug 2021 22:42:48 -0400

>      of the RSEA, including a call for confidential input from

*sigh* I can see where this is going, so I'm grudgingly willing to 
accept the above with the deletion of the word "confidential".  Leave it 
to the LLC to specify the form in which it is willing to accept comments 
when it issues such calls - that's in keeping with Eliot's commentary on 
legal/HR issues.

Or alternately,

"Periodically, the IETF LLC should make a call  to the community for 
comments on the performance of the RSCE and RPC and for any suggestions 
for the improvement of the RFC publication system."

Basically, any contract or employment agreement will have some form of 
periodic evaluation - we don't need to state that here it's really the 
sole responsibility of the engaging entity.

Later, Mike

---

From: Michael StJohns <[email-masked]>
Date: Mon, 2 Aug 2021 22:50:28 -0400

On 8/2/2021 7:10 PM, Joel M. Halpern wrote:
> community, then a complaint to the nomcom that they did not consult 
> the community is not very strong.  If we require it, then the 
> complaint is saying something.
>
> Yours,
> joel

I'll repeat the same question I asked before to wit:  Is the LLC 
required to consult the community for the IED - e.g. is there a formal 
requirement written somewhere that the LLC will periodically ask "how is 
Jay doing"?  If not, then why should this be any different?

I think your argument is too much of a strawman in any case. There are 
lots of reasons we might ding the LLC via the Nomcom - but personnel 
issues will not be (a useful) one of them as the actual personnel 
actions and who voted for what with respect to those actions will not be 
visible to the Nomcom.

Later, Mike

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 2 Aug 2021 23:04:25 -0400

It seems to me that if we as a community expect the LLC to do something, 
we should tell them rather than expecting them to guess correctly waht 
we want.

It can be short (Brian's proposal).   But leaving it out because we 
assume they will do the right thing seems rather odd.

Yours,
Joel

---

From: Jay Daley <[email-masked]>
Date: Tue, 3 Aug 2021 15:07:22 +1200

> On 3/08/2021, at 2:50 PM, Michael StJohns <[email-masked]> wrote:
> 
>> I read the text as being aimed at providing appropriate guardrails (mandating what we consider necessary) while trusting the LLC / IAD to execute reasonably well.
>> 
>> For example, if we do not tell them they need to consult the community, then a complaint to the nomcom that they did not consult the community is not very strong.  If we require it, then the complaint is saying something.
>> 
>> Yours,
>> joel
> 
> 
> I'll repeat the same question I asked before to wit:  Is the LLC required to consult the community for the IED - e.g. is there a formal requirement written somewhere that the LLC will periodically ask "how is Jay doing"?  If not, then why should this be any different?

It’s not in my contract no.  All it says is "The Employee agrees to participate fully in any formal performance appraisal program that shall be conducted by the company".  

Jay

> 
> I think your argument is too much of a strawman in any case. There are lots of reasons we might ding the LLC via the Nomcom - but personnel issues will not be (a useful) one of them as the actual personnel actions and who voted for what with respect to those actions will not be visible to the Nomcom.
> 
> Later, Mike
> 
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 3 Aug 2021 15:24:53 +1200

On 03-Aug-21 15:07, Jay Daley wrote:
> 
> 
>> On 3/08/2021, at 2:50 PM, Michael StJohns <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>> For example, if we do not tell them they need to consult the community, then a complaint to the nomcom that they did not consult the community 
is not very strong.  If we require it, then the complaint is saying something.
> It’s not in my contract no.  All it says is "The Employee agrees to participate fully in any formal performance appraisal program that shall be conducted by the company".  

BCP 101 doesn't specify any periodicity, but it does make it clear that the community can complain: https://www.rfc-editor.org/rfc/rfc8711.html#section-4.7

Since it's the LLC that will hire the RSCE, I suppose that avenue could apply here too. But since the RFC community is wider than the IETF community, it seems natural to me to write something down that is specific to the RSCE case.

   Brian

>> I think your argument is too much of a strawman in any case. There are 
lots of reasons we might ding the LLC via the Nomcom - but personnel issues will not be (a useful) one of them as the actual personnel actions and 
who voted for what with respect to those actions will not be visible to the Nomcom.
>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> 
>

---

From: John C Klensin <[email-masked]>
Date: Tue, 03 Aug 2021 08:12:00 -0400

(off list)

--On Monday, 02 August, 2021 22:42 -0400 Michael StJohns
<[email-masked]> wrote:

>...
> *sigh* I can see where this is going
>...

I assume you see the same thing I see.  We replace an out of
control and over-controlling RSOC and IAB with a sometimes out
of control and often over-controlling ExecDir who tends to be
controlling at times and, while I can't go public with what I
know because I (and they) are convinced it would cause
retribution for violating his instructions, has told various
people at AMSthat they are not allowed to participate in IETF
technical work or speak directly with the community without his
instructions and that they are forbidden to tell the community
about those restrictions.  They are all "just contractors" and
he is running the show.   The problem with Henrik was that he
was not managed and supervised enough, etc.

I think Jay is doing rather well at the job he believes he was
told to do, but I hope the community is going to be happy with
what it wished for.  I wish I knew how to fix this other than
concluding that the IETF has outlived its useful life.

    john

---

From: John C Klensin <[email-masked]>
Date: Tue, 03 Aug 2021 08:39:19 -0400

Hi.

Sorry.  I just sent a note to the list than was intended for
Mike only.  As many of your know, I'm often more blunt and
outspoken in private than in more public contexts.  Please
ignore if possible.

   john

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 3 Aug 2021 09:48:55 -0600

[ no hats ]

I thought Brian's one-sentence version covered things adequately:

  Periodically, the IETF LLC will evaluate the performance of the
  RSCE, including a call for confidential input from the community.

Peter

On 8/2/21 9:04 PM, Joel M. Halpern wrote:
>>> (mandating what we consider necessary) while trusting the LLC / IAD
>>> to execute reasonably well.
>>>
>> requirement written somewhere that the LLC will periodically ask "how
>> is Jay doing"?  If not, then why should this be any different?
>>
>> actions and who voted for what with respect to those actions will not
>> be visible to the Nomcom.
>>
>> Later, Mike
>>
>>
>

---

From: Jay Daley <[email-masked]>
Date: Wed, 4 Aug 2021 11:55:45 +1200

> On 4/08/2021, at 12:12 AM, John C Klensin <[email-masked]> wrote:
> 
> (off list)

Fortunately for me, it wasn't

> about those restrictions.  

That is a deeply poisonous lie.  You could have discounted it in just a few minutes with an email to AMS but the fact that you chose not to do that and instead to propagate and enhance it, speaks volumes to your character.

Jay

> They are all "just contractors" and

-- 
Jay Daley
IETF Executive Director
[email-masked]