Subject: [Rfced-future] Issue 71: Term limits for RSAB chairs?

From: Eliot Lear <[email-masked]>
Date: Sat, 14 Aug 2021 11:28:06 +0200

Currently the draft states the following:

>    The RSAB shall choose a chair from among its members using a method
>    to be determined by the RSAB.

But it says nothing about term limits.  This was mentioned during the 
June interim meeting, but no text has been proposed.  Can those who 
support this issue propose some text with some justification, so that 
the program can consider it?

Eliot

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 15 Aug 2021 08:59:04 +1200

> the program can consider it?

I'm not sure I exactly "support" the issue but I'd be inclined to
simply insert "annually" in that sentence, to make it clear that it
isn't a job for life.  I don't think that a specific term limit is
advisable in such a small committee, because it would over-constrain
the choice of chair.

   Brian

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 16 Aug 2021 11:12:58 +1000

> advisable in such a small committee, because it would over-constrain

That would be fine.

---

From: Michael StJohns <[email-masked]>
Date: Sun, 15 Aug 2021 21:30:44 -0400

> the program can consider it?

Actually, I've been thinking about this.  The Chair position isn't 
anything special (e.g. unlike the IAB/IESG/IRTF chairs) - it's just 
"additional duties as assigned" and mainly to preside over processing 
requests from the RSWG.  Rather than causing sturm und drang over 
worrying about "job for life" and "fairness", let's just rotate the 
position.

So text:

The RSAB chair duties shall rotate annually between each of its members 
in the following order: IAB, RSCE, IESG, IRTF, ISE.  That order was 
chosen to mirror the historical order of creation of the appointing 
organizations.   The RSAB may choose to follow a strict annual rotation, 
or may adjust the term to coincide with the end of a specific IETF 
meeting similar to the terms of the IAB and IESG.

Mike

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 17 Aug 2021 16:10:51 +1000

Hi Michael,

> On 16 Aug 2021, at 11:30 am, Michael StJohns <[email-masked]> wrote:
> 
> The RSAB chair duties shall rotate annually between each of its members in the following order: IAB, RSCE, IESG, IRTF, ISE.  That order was chosen to mirror the historical order of creation of the appointing organizations.   The RSAB may choose to follow a strict annual rotation, or may adjust the term to coincide with the end of a specific IETF meeting similar to the terms of the IAB and IESG.

Hmm. It strikes me that doing it this way might complicate the selection process for the various bodies. Finding someone who's willing to head up a stream and serve on the RSAB is different from finding someone who can do those _and_ take on extra chairing duties -- especially if they might occur down the track a bit, and especially if the candidates have other commitments coming and going as well.

--
Mark Nottingham   https://www.mnot.net/

---

From: Michael StJohns <[email-masked]>
Date: Tue, 17 Aug 2021 13:10:10 -0400

> Hmm. It strikes me that doing it this way might complicate the selection process for the various bodies. Finding someone who's willing to head up a stream and serve on the RSAB is different from fi…

So you'd rather have the various members of the RSAB play "not me" on an 
annual basis, with the probable result that the IAB and IRTF members 
will end up handing the position back and forth?  (I base this on your 
statement above that it might be difficult to find willing members and 
the following probable arguments:  RSCE - I'm not paid to do this - add 
it to my task order first; ISE - I'm only one person and a volunteer at 
that, find someone else; IESG - I've got 20 WGs to oversee, I don't have 
the time to chair).   I don't find this all that palatable.

Of those, I actually have sympathy with the ISE's argument and would add 
"The ISE at its discretion may pass on its opportunity to chair with the 
chair position rotating to the representative from the next organization 
in line."

So once every 4-5 years one of these groups has to find someone to do a 
bit of administrivia?  If it's that much of a problem, how about we go 
back to my first suggestion and set up the RSCE as the permanent chair?

If we pay the RSCE for the role, that would render moot your comments 
above.  And, as I've noted a few times, the chair position has some 
responsibility, but almost no authority.

Later, Mike

---

From: Eliot Lear <[email-masked]>
Date: Tue, 17 Aug 2021 19:57:51 +0200

Mike, just to boil things down a bit, I'm going to ask the obvious Eliot 
question:

Can you distill down what you think MUST be in the draft now and what 
might wait for some operational experience?  That is to say, in your 
opinion, does the community have the option to add this sort of rotation 
scheme in later if the situation seems to warrant?

More generally, should we create perhaps a bit of a checklist of things 
we decided not to decide so that those items get some attention just to 
see that things haven't broken?

Eliot

On 17.08.21 19:10, Michael StJohns wrote:
>>> The RSAB chair duties shall rotate annually between each of its 
>>> members in the following order: IAB, RSCE, IESG, IRTF, ISE.  That 
>>> order was chosen to mirror the historical order of creation of the 
>>> appointing organizations.   The RSAB may choose to follow a strict 
>>> annual rotation, or may adjust the term to coincide with the end of 
>>> a specific IETF meeting similar to the terms of the IAB and IESG.
>> Hmm. It strikes me that doing it this way might complicate the 
>> selection process for the various bodies. Finding someone who's 
>> willing to head up a stream and serve on the RSAB is different from 
>> finding someone who can do those _and_ take on extra chairing duties 
>> -- especially if they might occur down the track a bit, and 
>> especially if the candidates have other commitments coming and going 
>> as well.
>>
>>
>> -- 
> So you'd rather have the various members of the RSAB play "not me" on 
> an annual basis, with the probable result that the IAB and IRTF 
> members will end up handing the position back and forth?  (I base this 
> on your statement above that it might be difficult to find willing 
> members and the following probable arguments:  RSCE - I'm not paid to 
> do this - add it to my task order first; ISE - I'm only one person and 
> a volunteer at that, find someone else; IESG - I've got 20 WGs to 
> oversee, I don't have the time to chair).   I don't find this all that 
> palatable.
>
> Of those, I actually have sympathy with the ISE's argument and would 
> add "The ISE at its discretion may pass on its opportunity to chair 
> with the chair position rotating to the representative from the next 
> organization in line."
>
> So once every 4-5 years one of these groups has to find someone to do 
> a bit of administrivia?  If it's that much of a problem, how about we 
> go back to my first suggestion and set up the RSCE as the permanent 
> chair?
>

---

From: Michael StJohns <[email-masked]>
Date: Tue, 17 Aug 2021 14:55:46 -0400

On 8/17/2021 1:57 PM, Eliot Lear wrote:
> Mike, just to boil things down a bit, I'm going to ask the obvious 
> Eliot question:
>
> opinion, does the community have the option to add this sort of 
> rotation scheme in later if the situation seems to warrant?

If this is going to require the RSCE to perform chair duties at any 
time, that needs to be included so the LLC can budget for it and include 
it in the contract.     That's the mandatory part.

But!  Mark has already indicated that he feels the job will not be 
desirable and that various orgs will resist taking a turn as chair.  I 
think as part of giving them a voice on the RSAB (authority...) we need 
to bind that to whatever responsibilities also come from those 
positions.  So, yes, I think this needs to be specified in a manner that 
either a) requires everyone to take a turn, or b) pays the RSCE to do 
the administrivia of the chair job.  I don't think that should be deferred.

Note that I also suggested that the RSAB include non-ex officio members 
appointed by the Nomcom and that had we done that, sticking one of them 
with the chair job would moot the whole "its too much work" argument 
that Mark made.

Later, Mike

>
> More generally, should we create perhaps a bit of a checklist of 
> things we decided not to decide so that those items get some attention 
> just to see that things haven't broken?
>
> Eliot
>
>> members will end up handing the position back and forth?  (I base 
>> this on your statement above that it might be difficult to find 
>> willing members and the following probable arguments:  RSCE - I'm not 
>> paid to do this - add it to my task order first; ISE - I'm only one 
>> person and a volunteer at that, find someone else; IESG - I've got 20 
>> WGs to oversee, I don't have the time to chair).   I don't find this 
>> all that palatable.
>>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 17 Aug 2021 12:27:17 -0700

I guess we all have different forecasts about the future, because I don't
anticipate it will be that hard to find a chair, and I don't think we
should rotate.

I also think we should consider whether the RSCE should in fact be allowed
to be chair. They stand in a different relationship to things than the
other members.

-Ekr

On Tue, Aug 17, 2021 at 11:56 AM Michael StJohns <[email-masked]>
wrote:

> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future
>

---

From: Brian Rosen <[email-masked]>
Date: Tue, 17 Aug 2021 15:34:15 -0400

<no hats>
But chair here doesn’t have a lot of power.  If we don’t specifying a specific way to pick a chair, then, as the current text says, it’s up to the RSAB members to decide, and they can decide to allow the RSCE to be a chair or not.  It may be more who are the actual people involved vs what their positions or membership line on the RSAB is.  If we’re not tying the RSABs hands, then let them decide, change their minds, or evolve.   No need to limit.

Brian

> On Aug 17, 2021, at 3:27 PM, Eric Rescorla <[email-masked]> wrote:
> 
> I guess we all have different forecasts about the future, because I don't anticipate it will be that hard to find a chair, and I don't think we should rotate.
> 
> I also think we should consider whether the RSCE should in fact be allowed to be chair. They stand in a different relationship to things than the other members.
> 
> -Ekr
> 
> 
> On Tue, Aug 17, 2021 at 11:56 AM Michael StJohns <[email-masked] <mailto:[email-masked]>> wrote:
> >>>> On 16 Aug 2021, at 11:30 am, Michael StJohns 
> >>>> <[email-masked] <mailto:[email-masked]>> wrote:
> >>>>
> >>> Mark Nottingham   https://www.mnot.net/ <https://www.mnot.net/>
> >>>
> >>
> [email-masked] <mailto:[email-masked]>
> https://www.iab.org/mailman/listinfo/rfced-future <https://www.iab.org/mailman/listinfo/rfced-future>
> --

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 18 Aug 2021 08:46:36 +1200

On 18-Aug-21 07:34, Brian Rosen wrote:
> <no hats>
> But chair here doesn’t have a lot of power.  If we don’t specifying a specific way to pick a chair, then, as the current text 
says, it’s up to the RSAB members to decide, and they can decide to allow the RSCE to be a chair or not.  It may be more who are the actual people involved vs what their positions or membership line on the RSAB is.  If we’re not tying the RSABs hands, then let them decide, change their minds, or evolve.   No need to limit.

I agree, with the caveat I suggested a few days ago: the Chair is appointed annually.

  Brian (the other one)

> 
> Brian
> 
>> On Aug 17, 2021, at 3:27 PM, Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 18 Aug 2021 09:24:28 +1000

Mike, 

Please don't put words in my mouth. I expressed concern about making it more difficult to find the right person for the job, given people's other constraints, strengths and weaknesses -- not 'the job will not be desirable.'

I see no reason to tie the hands of these bodies when choosing their chair; we don't do that anywhere else. 

Cheers,

> On 18 Aug 2021, at 4:55 am, Michael StJohns <[email-masked]> wrote:
> 
>> Mike, just to boil things down a bit, I'm going to ask the obvious Eliot question:
>> 
>> Can you distill down what you think MUST be in the draft now and what might wait for some operational experience?  That is to say, in your opinion, does the community have the option to add this sort of rotation scheme in later if the situation seems to warrant?
> 
> If this is going to require the RSCE to perform chair duties at any time, that needs to be included so the LLC can budget for it and include it in the contract.     That's the mandatory part.
> 
> But!  Mark has already indicated that he feels the job will not be desirable and that various orgs will resist taking a turn as chair.  I think as part of giving them a voice on the RSAB (authority...) we need to bind that to whatever responsibilities also come from those positions.  So, yes, I think this needs to be specified in a manner that either a) requires everyone to take a turn, or b) pays the RSCE to do the administrivia of the chair job.  I don't think that should be deferred.
> 
> Note that I also suggested that the RSAB include non-ex officio members appointed by the Nomcom and that had we done that, sticking one of them with the chair job would moot the whole "its too much work" argument that Mark made.
> 
> Later, Mike
> 
> 
> 
>> 
>> More generally, should we create perhaps a bit of a checklist of things we decided not to decide so that those items get some attention just to see that things haven't broken?
>> 
>> Eliot
>> 
>>> So you'd rather have the various members of the RSAB play "not me" on an annual basis, with the probable result that the IAB and IRTF members will end up handing the position back and forth?  (I base this on your statement above that it might be difficult to find willing members and the following probable arguments:  RSCE - I'm not paid to do this - add it to my task order first; ISE - I'm only one person and a volunteer at that, find someone else; IESG - I've got 20 WGs to oversee, I don't have the time to chair).   I don't find this all that palatable.
>>> 
>>> Of those, I actually have sympathy with the ISE's argument and would add "The ISE at its discretion may pass on its opportunity to chair with the chair position rotating to the representative from the next organization in line."
>>> 
>>> So once every 4-5 years one of these groups has to find someone to do a bit of administrivia?  If it's that much of a problem, how about we go back to my first suggestion and set up the RSCE as the permanent chair?
>>> 
>>> If we pay the RSCE for the role, that would render moot your comments above.  And, as I've noted a few times, the chair position has some responsibility, but almost no authority.
>>> 
>>> Later, Mike
>>> 
>>> 
>>> 
>>> 
>> 
> 
> --

---

From: "StJohns, Michael" <[email-masked]>
Date: Tue, 17 Aug 2021 20:08:26 -0400

I read this email and my email multiple times and I still don’t know how I
“put words in your mouth".

WRT tying the hands of the bodies:  by RFC, the IETF chair is selected by
the nomcom.  By RFC, the chair of the IAB is selected by the IAB.  By RFC,
the chair of the IAB is selected annually by the IAB members.  By RFC, the
chair of the IRTF is selected by the IAB.  And I believe, but haven’t
verified, that an RFC specifies that the chair of the LLC and trust are
each selected by their members.

E.g. there is no one right way of doing this and a rotation, or sticking
the RSCE with the job is as viable an approach as having the members select
their chair.  In this particular case, I believe the chair job to be
thankless, and would  rather impose a requirement to rotate the pain than
just leave it to an annual not me fight.

Later, Mike

On Tue, Aug 17, 2021 at 19:24 Mark Nottingham <[email-masked]> wrote:

> Mike,
>
> Please don't put words in my mouth. I expressed concern about making it
> more difficult to find the right person for the job, given people's other
> constraints, strengths and weaknesses -- not 'the job will not be
> desirable.'
>
> time, that needs to be included so the LLC can budget for it and include it
> in the contract.     That's the mandatory part.
> >
> think as part of giving them a voice on the RSAB (authority...) we need to
> bind that to whatever responsibilities also come from those positions.  So,
> yes, I think this needs to be specified in a manner that either a) requires
> everyone to take a turn, or b) pays the RSCE to do the administrivia of the
> chair job.  I don't think that should be deferred.
> >
> with the chair job would moot the whole "its too much work" argument that
> Mark made.
> >
> > Later, Mike
> >
> >
> >
> >>
> we decided not to decide so that those items get some attention just to see
> that things haven't broken?
> >>
> >> Eliot
> >>
> members in the following order: IAB, RSCE, IESG, IRTF, ISE.  That order was
> organizations.   The RSAB may choose to follow a strict annual rotation, or
> may adjust the term to coincide with the end of a specific IETF meeting
> similar to the terms of the IAB and IESG.
> selection process for the various bodies. Finding someone who's willing to
> head up a stream and serve on the RSAB is different from finding someone
> who can do those _and_ take on extra chairing duties -- especially if they
> might occur down the track a bit, and especially if the candidates have
> other commitments coming and going as well.
> >>>>
> >>>>
> >>>> --
> an annual basis, with the probable result that the IAB and IRTF members
> statement above that it might be difficult to find willing members and the
> following probable arguments:  RSCE - I'm not paid to do this - add it to
> my task order first; ISE - I'm only one person and a volunteer at that,
> find someone else; IESG - I've got 20 WGs to oversee, I don't have the time
> to chair).   I don't find this all that palatable.
> >>>
> add "The ISE at its discretion may pass on its opportunity to chair with
> the chair position rotating to the representative from the next
> organization in line."
> >>>
> a bit of administrivia?  If it's that much of a problem, how about we go

---

From: John C Klensin <[email-masked]>
Date: Tue, 17 Aug 2021 21:38:43 -0400

--On Tuesday, August 17, 2021 14:55 -0400 Michael StJohns
<[email-masked]> wrote:

>...
> If this is going to require the RSCE to perform chair duties
> at any time, that needs to be included so the LLC can budget
> for it and include it in the contract.     That's the
> mandatory part.
>...

Independent of the other questions please think about whether
adding this type of mostly administrative responsibility to the
RSCE role will make it easier or harder to recruit the person
we'd like to have in that role or whether it would have any
effect.  I don't know the answer but I believe we should try to
ask the question each time we specify a role for the RSCE that
is not somehow critical to our perception of the job.  There
will be cases in which it is worth the risk of not being able to
find any qualified people who would take the job and ones where
it is not.  For the latter, let's not make the odds of being
able to find someone worse.

   john

---

From: Michael StJohns <[email-masked]>
Date: Tue, 17 Aug 2021 22:26:27 -0400

> able to find someone worse.
Hi John -

Good points, but I think the admin burden is small and would not 
materially affect either the LOE or scope of the RSCE if the document 
specified them as chair.  My argument for rotation is based on that 
judgement and the desire to specify an organization that doesn't 
necessarily depend on altruistic behavior of the members to function.

If the counter argument is that the burden is larger and that it might 
affect the ability to find stuckees from each sending organization who 
might find themselves acting as chair: That suggests both that leaving 
the choice of chair to the RSAB as constituted could end up with some 
unfairness as various members could duck out of responsibility, and that 
hiring the job to be done (e.g. either the RSCE or maybe the ISE) would 
act to mitigate such unfairness.

I have seen no good argument for why chairing the RSAB is a heavy burden 
given the proposed  constraining of the scope of the RSAB's remit in the 
current document.

To restate:  I don't think any of the possible choices will materially 
affect the ability to attract and contract with an RSCE to specifically 
include the assignment of the RSCE as chair or not.  If the assignment 
of the RSCE as chair is a possibility then it needs to be scoped and 
included in the proposed SOW offered to the RSCE candidates.

Later, Mike

---

From: Jay Daley <[email-masked]>
Date: Wed, 18 Aug 2021 15:30:14 +1200

> On 18/08/2021, at 2:26 PM, Michael StJohns <[email-masked]> wrote:
> 
> Good points, but I think the admin burden is small and would not materially affect either the LOE or scope of the RSCE if the document specified them as chair.  My argument for rotation is based on that judgement and the desire to specify an organization that doesn't necessarily depend on altruistic behavior of the members to function.
> 
> If the counter argument is that the burden is larger and that it might affect the ability to find stuckees from each sending organization who might find themselves acting as chair: That suggests both that leaving the choice of chair to the RSAB as constituted could end up with some unfairness as various members could duck out of responsibility, and that hiring the job to be done (e.g. either the RSCE or maybe the ISE) would act to mitigate such unfairness.
> 
> I have seen no good argument for why chairing the RSAB is a heavy burden given the proposed  constraining of the scope of the RSAB's remit in the current document.
> 
> To restate:  I don't think any of the possible choices will materially affect the ability to attract and contract with an RSCE to specifically include the assignment of the RSCE as chair or not. 

I agree.

> If the assignment of the RSCE as chair is a possibility then it needs to be scoped and included in the proposed SOW offered to the RSCE candidates.

It would help, yes.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]