Subject: [Rfced-future] Issue 81: who owns boiler plate

From: Eliot Lear <[email-masked]>
Date: Tue, 28 Sep 2021 16:09:03 +0200

Hi everyone,

We had a very productive interim meeting today.  During the call, we ran 
into difficulties with one issue, and it is over who owns boiler plate 
and how it should be updated.

The last proposal was to simply state that the RSWG and RSAB MAY 
establish policies governing boiler plate.  No further specification 
would take place in this document.  May I ask if there are objections, 
and for those to be made by the 12th of October?

Eliot

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 28 Sep 2021 10:20:03 -0400

I though we said "may establish policies governing boiler plate consist 
with the IETF Trust's needs to meet the mandated IPR and copyright rules"?

(Okay, we actually said "in consultation with the IEtF Trust", but I was 
trying to include "why?")

Yours,
Joel

---

From: Russ Housley <[email-masked]>
Date: Tue, 28 Sep 2021 10:38:18 -0400

Updates to the boilerplate for a stream require coordination with the other stream managers to avoid conflicts, and changes also require coordination with the IETF Trust to ensure that IPR is handled properly.  I think these points need to be made in the document to guide the RSWG and RSAB in the policies that they might set.

Russ

> On Sep 28, 2021, at 10:09 AM, Eliot Lear <[email-masked]> wrote:
> 
> Hi everyone,
> 
> We had a very productive interim meeting today.  During the call, we ran into difficulties with one issue, and it is over who owns boiler plate and how it should be updated.
> 
> The last proposal was to simply state that the RSWG and RSAB MAY establish policies governing boiler plate.  No further specification would take place in this document.  May I ask if there are objections, and for those to be made by the 12th of October?
> 
> Eliot

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 28 Sep 2021 14:44:35 +0000

On the call, we discussed exact language such as this. My take of the discussion on the call was: 
1) Yes, the updates DO require coordination with other stream managers, and the trust, etc etc, 
2) There are further questions that need to be resolved as to ownership of the boilerplate for a stream.
3) There are further questions that need to be resolved as to where the boilerplate updates should be published.
4) Those requirements don't need to be specified in THIS document.

	Tony

On 9/28/2021, 10:38 AM, "Rfced-future on behalf of Russ Housley" <[email-masked] on behalf of [email-masked]> wrote:

    Russ

---

From: Eliot Lear <[email-masked]>
Date: Tue, 28 Sep 2021 17:17:43 +0200

Given that this is REALLY meta, isn't the policy wording regarding the 
Trust something that the RSWG could specify? Alternatively, please 
supply text.

Eliot

On 28.09.21 16:20, Joel M. Halpern wrote:
> I though we said "may establish policies governing boiler plate 
> consist with the IETF Trust's needs to meet the mandated IPR and 
> copyright rules"?
>
> (Okay, we actually said "in consultation with the IEtF Trust", but I 
> was trying to include "why?")
>
> Yours,
> Joel
>
>> We had a very productive interim meeting today.  During the call, we 
>> ran into difficulties with one issue, and it is over who owns boiler 
>> plate and how it should be updated.
>>
>> would take place in this document.  May I ask if there are 
>> objections, and for those to be made by the 12th of October?
>>
>> Eliot
>>
>>
>>
>

---

From: John C Klensin <[email-masked]>
Date: Tue, 28 Sep 2021 11:27:04 -0400

Russ and Joel,

I'm concerned about having to get to this level of detail in the
document but, could we reasonably say that, while the
boilerplate for a given stream is, in principle, the
responsibility of that stream, any changes must be signed off by
the IETF Trust and the RSAG.   It is not clear to me that an
RSWG discussion would be helpful --again, changes for the
boilerplate for a given stream should be driven by the stream
and this would not constitute the RSAG originating and making
policy, just doing a review for conflicts with other streams or
policies. 

I can imagine circumstances in which other streams might want to
impose particular boilerplate requirements on a stream that
doesn't want them, but they give me a case of the creeps.  And,
if we get there, we probably have bigger problems. 

Just a thought...

   john

--On Tuesday, September 28, 2021 10:38 -0400 Russ Housley
<[email-masked]> wrote:

> Updates to the boilerplate for a stream require coordination
> with the other stream managers to avoid conflicts, and changes
> also require coordination with the IETF Trust to ensure that
> IPR is handled properly.  I think these points need to be made
> in the document to guide the RSWG and RSAB in the policies
> that they might set.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 28 Sep 2021 11:38:01 -0400

Did RSAG mean RSAB in the below?
Yours,
Joel

---

From: John C Klensin <[email-masked]>
Date: Tue, 28 Sep 2021 12:18:38 -0400

Yes.  Sorry... I'm suffering from a bad case of acronym overload
and confusion.
   john

--On Tuesday, September 28, 2021 11:38 -0400 "Joel M. Halpern"
<[email-masked]> wrote:

>> I'm concerned about having to get to this level of detail in
>> the document but, could we reasonably say that, while the
>> responsibility of that stream, any changes must be signed off
>> by the IETF Trust and the RSAG.   It is not clear to me that
>> an RSWG discussion would be helpful --again, changes for the
>> policy, just doing a review for conflicts with other streams
>> or policies.
>> 
>> I can imagine circumstances in which other streams might want
>> to impose particular boilerplate requirements on a stream that
>> doesn't want them, but they give me a case of the creeps.
>> And, if we get there, we probably have bigger problems.
>> 
>> Just a thought...
>> 
>>     john
>> 
>>> with the other stream managers to avoid conflicts, and
>>> changes also require coordination with the IETF Trust to
>>> ensure that IPR is handled properly.  I think these points
>>> need to be made in the document to guide the RSWG and RSAB
>>> in the policies that they might set.
>> 
>>

---

From: Jay Daley <[email-masked]>
Date: Wed, 29 Sep 2021 08:15:54 +1300

How about the following text:

—— 
Any changes to the boilerplate must be approved by the following parties, each of which has a separate area of responsibility with respect to the boilerplate:

* The stream(s) to which the new boilerplate applies, who approve that the new boilerplate meets the needs of that stream(s);
* The RSAB, who approve that the new boilerplate is consistent with the boilerplate used in the other streams
* The RPC, who approve that the language of the new boilerplate conforms to the Style Guide
* The IETF Trust, who approve the new boilerplate correctly states the position regarding rights and ownership
—— 

Jay

> On 29/09/2021, at 5:18 AM, John C Klensin <[email-masked]> wrote:
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Wed, 29 Sep 2021 08:25:19 +1300

> On 29/09/2021, at 8:15 AM, Jay Daley <[email-masked]> wrote:
> 

I should have explained that this text avoids any statement about ownership and any requirement that changes to the boilerplate must come through a specific route, therefore alllowing it to come directly from a stream, or from the RSWG.  It also prevents a policy being developed in the RSWG and then approved by majority in the RSAB, which imposes a boilerplate on a stream.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 28 Sep 2021 12:26:04 -0700

This looks right to me.

On Tue, Sep 28, 2021 at 12:25 PM Jay Daley <[email-masked]> wrote:

> > Any changes to the boilerplate must be approved by the following
> parties, each of which has a separate area of responsibility with respect
> to the boilerplate:
> >
> > * The stream(s) to which the new boilerplate applies, who approve that
> the new boilerplate meets the needs of that stream(s);
> I should have explained that this text avoids any statement about
> ownership and any requirement that changes to the boilerplate must come
> through a specific route, therefore alllowing it to come directly from a
> stream, or from the RSWG.  It also prevents a policy being developed in the
> RSWG and then approved by majority in the RSAB, which imposes a boilerplate
> on a stream.
>
> Jay
>
>
> >
> > Jay
> >
> >

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 28 Sep 2021 13:32:53 -0600

This seems reasonable.

For the avoidance of doubt, by "the boilerplate" we mean boilerplate for 
any stream present or future, not only for the Editorial Stream.

Peter

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 28 Sep 2021 15:44:45 -0400

Looks good to me.
Yours,
Joel

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 29 Sep 2021 08:58:23 +1300

Agreed

Regards
   Brian Carpenter

On 29-Sep-21 08:26, Eric Rescorla wrote:
> This looks right to me.
> 
> On Tue, Sep 28, 2021 at 12:25 PM Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 
>     > On 29/09/2021, at 8:15 AM, Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
>     >
>     > * The stream(s) to which the new boilerplate applies, who approve 
that the new boilerplate meets the needs of that stream(s);
>     >> On 29/09/2021, at 5:18 AM, John C Klensin <[email-masked] <mailto:[email-masked]>> wrote:
>     >>
>     >> <[email-masked] <mailto:[email-masked]>> wrote:
>     >>
>     >>>> <[email-masked] <mailto:[email-masked]>> wrote:
>     >>>>
>     >> [email-masked] <mailto:[email-masked]>
>     >> https://www.iab.org/mailman/listinfo/rfced-future <https://www.iab.org/mailman/listinfo/rfced-future>
>     >>
>     >
>     > --
>     > Jay Daley
>     > IETF Executive Director
>     > [email-masked] <mailto:[email-masked]>
>     >
>     > --
>     > [email-masked] <mailto:[email-masked]>
>     > https://www.iab.org/mailman/listinfo/rfced-future <https://www.iab.org/mailman/listinfo/rfced-future>
> 
>     -- 
>     Jay Daley
>     IETF Executive Director
>     [email-masked] <mailto:[email-masked]>
> 
>     -- 
>     [email-masked] <mailto:[email-masked]>
>     https://www.iab.org/mailman/listinfo/rfced-future <https://www.iab.org/mailman/listinfo/rfced-future>
> 
>

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 28 Sep 2021 22:14:21 +0000

+1

On 9/28/2021, 3:59 PM, "Rfced-future on behalf of Brian E Carpenter" <[email-masked] on behalf of [email-masked]> wrote:

    Agreed

    Regards
       Brian Carpenter

---

From: John C Klensin <[email-masked]>
Date: Tue, 28 Sep 2021 19:58:08 -0400

Wfm.  Appears to cover the issues.
   john

--On Wednesday, September 29, 2021 08:58 +1300 Brian E Carpenter
<[email-masked]> wrote:

>> On Tue, Sep 28, 2021 at 12:25 PM Jay Daley
>> <[email-masked] <mailto:[email-masked]>>
>> wrote:
>> 
>> 
>> 
>>     > On 29/09/2021, at 8:15 AM, Jay Daley
>>     > <[email-masked]
>>     > <mailto:[email-masked]>> wrote:
>>     > 
>>     > Any changes to the boilerplate must be approved by the
>>     > following parties, each of which has a separate area of
>>     > responsibility with respect 
> to the boilerplate:
>>     > 
>>     > * The RSAB, who approve that the new boilerplate is
>>     > consistent with the boilerplate used in the other
>>     > streams * The RPC, who approve that the language of the
>>     > new boilerplate conforms to the Style Guide * The IETF
>>     > Trust, who approve the new boilerplate correctly states
>>     > the position regarding rights and ownership ——
>> 
>>     I should have explained that this text avoids any
>>     statement about ownership and any requirement that
>>     changes to the boilerplate must come through a specific
>>     route, therefore alllowing it to come directly from a
>>     stream, or from the RSWG.  It also prevents a policy
>>     being developed in the RSWG and then approved by majority
>>     in the RSAB, which imposes a boilerplate on a stream.
>> 
>>     Jay
>> 
>> 
>>     > 
>>     > Jay
>>     > 
>>     > 
>>     >> On 29/09/2021, at 5:18 AM, John C Klensin
>>     >> <[email-masked] <mailto:[email-masked]>> wrote:
>>     >> 
>>     >> Yes.  Sorry... I'm suffering from a bad case of
>>     >> acronym overload and confusion.
>>     >>   john
>>     >> 
>>     >> 
>>     >> --On Tuesday, September 28, 2021 11:38 -0400 "Joel M.
>>     >> Halpern" <[email-masked]
>>     >> <mailto:[email-masked]>> wrote:
>>     >> 
>>     >>>> I'm concerned about having to get to this level of
>>     >>>> detail in the document but, could we reasonably say
>>     >>>> that, while the boilerplate for a given stream is,
>>     >>>> in principle, the responsibility of that stream, any
>>     >>>> changes must be signed off by the IETF Trust and the
>>     >>>> RSAG.   It is not clear to 
> me that
>>     >>>> an RSWG discussion would be helpful --again, changes
>>     >>>> for the boilerplate for a given stream should be
>>     >>>> driven by the stream and this would not constitute
>>     >>>> the RSAG originating and making policy, just doing a
>>     >>>> review for conflicts with other streams or policies.
>>     >>>> 
>>     >>>> I can imagine circumstances in which other streams
>>     >>>> might want to impose particular boilerplate
>>     >>>> requirements on a stream that doesn't want them, but
>>     >>>> they give me a case of the creeps. And, if we get
>>     >>>> there, we probably have bigger problems.
>>     >>>> 
>>     >>>> Just a thought...
>>     >>>> 
>>     >>>>    john
>>     >>>> 
>>     >>>> --On Tuesday, September 28, 2021 10:38 -0400 Russ
>>     >>>> Housley <[email-masked]
>>     >>>> <mailto:[email-masked]>> wrote:
>>     >>>> 
>>     >>>>> Updates to the boilerplate for a stream require
>>     >>>>> coordination with the other stream managers to
>>     >>>>> avoid conflicts, and changes also require
>>     >>>>> coordination with the IETF Trust to ensure that IPR
>>     >>>>> is handled properly.  I think these points need to
>>     >>>>> be made in the document to guide the RSWG and RSAB
>>     >> <https://www.iab.org/mailman/listinfo/rfced-future>
>>     >> 
>>     > 
>>     > --
>>     > Jay Daley
>>     > IETF Executive Director
>>     > <https://www.iab.org/mailman/listinfo/rfced-future>
>> 
>>     -- 
>>     Jay Daley
>>     IETF Executive Director
>>     <https://www.iab.org/mailman/listinfo/rfced-future>
>>

---

From: Eliot Lear <[email-masked]>
Date: Wed, 29 Sep 2021 07:25:58 +0200

Ok.

Barring objections we'll run with Jay's text.

Eliot

---

From: Wes Hardaker <[email-masked]>
Date: Wed, 29 Sep 2021 08:06:20 -0700

Jay Daley <[email-masked]> writes:

The only question I have about your proposal for the group to think
about is WRT this bullet:

> * The RSAB, who approve that the new boilerplate is consistent with
> the boilerplate used in the other streams

"consistent" could be interpreted both in good ways and bad ways (at one
extreme: they all must be the same to be consistent).

You might consider s/consistent/not in conflict/ if you want to give the
streams better independence.
-- 
Wes Hardaker
USC/ISI

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 29 Sep 2021 12:08:53 -0600

+1

---

From: Eliot Lear <[email-masked]>
Date: Wed, 29 Sep 2021 20:20:47 +0200

Does anyone object to this modification?

---

From: Jay Daley <[email-masked]>
Date: Thu, 30 Sep 2021 08:18:50 +1300

> On 30/09/2021, at 7:20 AM, Eliot Lear <[email-masked]> wrote:
> 

No.  A useful modification.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]