Subject: [Rfced-future] Figures in RFC8728

From: Brian E Carpenter <[email-masked]>
Date: Fri, 24 Sep 2021 15:33:54 +1200

I noticed that RFC8728 has a couple of figures:

https://www.rfc-editor.org/rfc/rfc8728.html#figure-1
https://www.rfc-editor.org/rfc/rfc8728.html#figure-2

Issue: Do we want updated versions in the new document?

Opinion: Figure 2, fortunately, would be simplified almost
out of existence. I don't think we need it. But Figure 1,
updated, would probably be helpful to readers.
 
Regards
   Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 24 Sep 2021 15:58:41 +1200

View the attachment in a fixed-width font...

Regards
   Brian

---

From: Christian Huitema <[email-masked]>
Date: Thu, 23 Sep 2021 23:34:21 -0700

> View the attachment in a fixed-width font...

Ah, the joy of state-of-the-art ascii art!

I am not sure about the left hand side of the graph. It shows

In any case, the box "IAB --> IAB" is somewhat confusing. Maybe 
something like "IAB drafts (architecture, reports, etc.) --> IAB stream 
manager. And maybe something similar for the IRTF and IETF boxes.

Do we want to somehow signal that the RSAB is composed of the stream 
managers?

The old figure had an IAB "on top" of the RSE box, with RSOC in between. 
RSOC disappears, and there should not be a direct box from IAB to RSAB 
-- I don't think we want to use ascii art to draw the appeal functions. 
However, the old figure had a line from IAB to ISE, because the IAB 
appoints the RSE, and that appointment process is still there. Should 
that be represented?

-- Christian Huitema

---

From: Eliot Lear <[email-masked]>
Date: Fri, 24 Sep 2021 09:03:04 +0200

If I understand that work, that diagram would look a little like this:

      +-------------+
      |  Community  |
      +------v------+
             |
         +---v-----+    +------------+     +----------+
         |   RFC   |    |   RFC      |     | Editoral |
         | Series  <---->  Series    |----->  Policy  |
         |   WG    |    | Approval   |     |   RFCs   |
         |         |    |  Board     |     |          |
         +----^----+    +--^-------^-+     +----v-----+
              .            |       |            |
       +------^------+     |       |            |
       |     RFC     |     |       |            |
       |   Series    >-----^       ^     V------<
       | Consulting  |             |     |
       |   Editor    > - - - - - - | - v |
       +-------------+             |   . |
                                   |   . |
+-------------+  +-------------+  |  +v-V--+        +-----+
|             |  |             |  |  |     |        |     |
| Independent |  | Independent |  |  | RFC |        |  E  |
|   Authors   +--> Submission  +--^-->     |        |  n  |
|             |  |   Editor    |  |  |  P  |        |  d  |
|             |  |             |  |  |  r  |        |     |
+-------------+  +-------------+  ^  |  o  |        |  U  |
+-------------+  +-------------+  |  |  d  |        |  s  |
|             |  |             |  |  |  u  |        |  e  |
|     IAB     +-->     IAB     +--^-->  c  |        |  r  |
|             |  |             |  |  |  t  |        |  s  |
+-------------+  +-------------+  |  |  i  >-------->     |
+-------------+  +-------------+  |  |  o  |        |  &  |
|             |  |             |  |  |  n  |        |     |
|    IRTF     +-->     IRSG    +--^-->     |        |  R  |
|             |  |             |  |  |  C  |        |  e  |
+-------------+  +-------------+  |  |  e  |        |  a  |
+-------------+  +-------------+  ^  |  n  |        |  d  |
|             |  |             |  |  |  t  |        |  e  |
|    IETF     +-->    IESG     +--^-->  e  |        |  r  |
|             |  |             |     |  r  |        |  s  |
+-------------+  +-------------+     +-----+        +-----+

For brevity's sake, the LLC isn't listed, but possibly could be squeezed 
in between the RFCs and the RPC.

Eliot

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 24 Sep 2021 07:19:42 -0600

I find the old diagram inscrutable and I’m not convinced that it’s helpful to include this…

Sent from mobile, might be terse 

> On Sep 24, 2021, at 1:03 AM, Eliot Lear <[email-masked]> wrote:
> 
> 
> For brevity's sake, the LLC isn't listed, but possibly could be squeezed in between the RFCs and the RPC.
> 
> Eliot
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Eliot Lear <[email-masked]>
Date: Fri, 24 Sep 2021 15:36:15 +0200

FYI - not wedded to this.  It could be that we split this into two: 
policy development and document development.

On 24.09.21 15:19, Peter Saint-Andre wrote:
>> For brevity's sake, the LLC isn't listed, but possibly could be 
>> squeezed in between the RFCs and the RPC.
>>
>> Eliot
>>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 25 Sep 2021 10:03:09 +1200

I'm certainly not wedded to my or Eliot's version. But now we've seen them, I repeat my question: do we *want* to include one or two diagrams?

If yes, we can debate their merits, and whether to do SVG versions as well as ASCII art.

Peter may well be right. As Christian's comments show, a legible diagram may show too little detail to be useful, especially with ASCII art constraints.

Maybe the correct answer is to have diagrams in slideware, which could be 
preserved on the rfc-editor web site, but no diagrams in the text.

Regards
   Brian Carpenter

On 25-Sep-21 01:36, Eliot Lear wrote:
> FYI - not wedded to this.  It could be that we split this into two: policy development and document development.
> 
>>>       +------^------+     
|       |            |
>>>       |     RFC     |     |       |            
|
>>>       |   Series    
>-----^       ^     V------<
>>>       |   Editor    
> - - - - - - | - v |