Subject: [Rfced-future] proposed note to the broader community

From: Eliot Lear <[email-masked]>
Date: Thu, 21 Oct 2021 19:28:37 +0200

Hi everyone,

As mentioned, we plan to invite the community to engage directly with us 
at the IETF meeting.  We chairs thought we'd do so with a note to a few 
places, like the IETF list, wgchairs, and elsewhere with a bit of an 
explanation.  Here's the note below.  We'd like to send it next week on 
your behalf. Edits/concerns?

Brian and Eliot

---

DRAFT DRAFT DRAFT DRAFT DRAFT

Dear colleagues,

In March of 2020 the IAB kicked off the RFC Series Editorial Future 
Development Program, a program opened to the entire community, with an 
eye toward reviewing the RFC Editor model.[1]  We are now coming to the 
conclusion of our work, and the IAB will soon formally solicit community 
input.

The program has developed an evolution of the RFC Editor Model and a 
small change to the charter of the IAB.  You can find this evolution in 
draft-iab-rfcefdp-rfced-model-05.[2]  This draft brings together many 
different points of view.

Here are some of the proposed changes that you may wish to know:

 1. The community is proposed to take on the role of seeing to the
    evolution of the series, in the form of an open working group. The
    streams in the form of an RFC Series Approval Board (RSAB) will
    review proposals that receive rough consensus.
 2. The RFC Editor role is evolving to that of a consulting editor (RFC
    Series Consulting Editor or RSCE).  In this model, an expert will
    provide guidance to the community, the streams, and to the RPC to
    evolve the series.
 3. The IAB will no longer manage or oversee the RFC series. The
    community and the streams will do that.  The IAB will continue to be
    in the appeal path if there are disputes.

There are a lot of things that won't change.  The RPC would continue to 
handle day-to-day functions of the RFC Editor function, and authors 
should not see any change in terms of how RFCs are published.  They 
continue to be managed through the LLC.  We will continue to benefit 
from the expertise of a professional expert, now the RSCE.

Of course, there's a lot more detail that is specified in the draft.

This is what will soon be put forth for your comments.  In the meantime, 
even though the formal comment period is not yet open, we invite you to 
review the model now and bring whatever questions you might have to the 
program when we meet on Wednesday, November 10th, at 14.30 GMT at the 
IETF meeting.  Of course you can also join the mailing list [3] and 
contribute your questions and comments there.

On behalf of the program,

Brian and Eliot

[1] 
https://www.iab.org/activities/programs/rfc-editor-future-development-program/
[2] https://datatracker.ietf.org/doc/html/draft-iab-rfcefdp-rfced-model-05
[3] https://www.iab.org/mailman/listinfo/rfced-future

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 Oct 2021 10:54:40 +1300

Hi,

Comments interspersed:

On 22-Oct-21 06:28, Eliot Lear wrote:
> Hi everyone,
> 
> As mentioned, we plan to invite the community to engage directly with us at the IETF meeting.  We chairs thought we'd do so with a note to a few places, like the IETF list, wgchairs, and elsewhere with a bit of an explanation.  Here's the note below.  We'd like to send it next week on your behalf.  Edits/concerns?

istm that "elsewhere" needs to include gendispatch, rfc-interest, and irtf-discuss.

> In March of 2020 the IAB kicked off the RFC Series Editorial Future Development Program, a program opened to the entire community, with an eye toward reviewing the RFC Editor model.[1]  We are now coming to the conclusion of our work, and the IAB will soon formally solicit community input.

Point here to the list archive?

> The program has developed an evolution of the RFC Editor Model and a small change to the charter of the IAB.  You can find this evolution in draft-iab-rfcefdp-rfced-model-05.[2]  This draft brings together many different points of view.
> 
>  1. The community is proposed to take on the role of seeing to the evolution of the series, in the form of an open working group. The streams in 
the form of an RFC Series Approval Board (RSAB) will review proposals that receive rough consensus.

Those sentences are both very hard to parse. Suggestion:

1. We propose that the community oversees the evolution of the series, by 
means of an open working group. Proposed changes that reach rough consensus will be reviewed by an RFC Series Approval Board (RSAB) representing the various RFC streams.

>  2. The RFC Editor role is evolving to that of a consulting editor (RFC 
Series Consulting Editor or RSCE).  In this model, an expert will provide guidance to the community, the streams, and to the RPC to evolve the series.

"is evolving" is a euphemism. It's changing. Don't be mealy mouthed.

Otherwise, all good.

Thanks
   Brian C

>  3. The IAB will no longer manage or oversee the RFC series.  The community and the streams will do that.  The IAB will continue to be 
> 
> There are a lot of things that won't change.  The RPC would continue to handle day-to-day functions of the RFC Editor function, and authors 
should not see any change in terms of how RFCs are published.  They continue to be managed through the LLC.  We will continue to benefit 
from the expertise of a professional expert, now the RSCE.
> This is what will soon be put forth for your comments.  In the meantime, even though the formal comment period is not yet open, we invite you to review the model now and bring whatever questions you might have to 
the program when we meet on Wednesday, November 10th, at 14.30 GMT at the 
IETF meeting.  Of course you can also join the mailing list [3] and contribute your questions and comments there.
> [1] https://www.iab.org/activities/programs/rfc-editor-future-development-program/

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 22 Oct 2021 08:59:38 +1100

I think this is worthy of posting to IETF-Announce -- perhaps the IAB can arrange it?

> On 22 Oct 2021, at 4:28 am, Eliot Lear <[email-masked]> wrote:
> 
> 
> Hi everyone,
> 
> 	• The community is proposed to take on the role of seeing to the evolution of the series, in the form of an open working group. The streams in the form of an RFC Series Approval Board (RSAB) will review proposals that receive rough consensus.
> 	• The RFC Editor role is evolving to that of a consulting editor (RFC Series Consulting Editor or RSCE).  In this model, an expert will provide guidance to the community, the streams, and to the RPC to evolve the series.
> 	• The IAB will no longer manage or oversee the RFC series.  The community and the streams will do that.  The IAB will continue to be in the appeal path if there are disputes.
> There are a lot of things that won't change.  The RPC would continue to handle day-to-day functions of the RFC Editor function, and authors should not see any change in terms of how RFCs are published.  They continue to be managed through the LLC.  We will continue to benefit from the expertise of a professional expert, now the RSCE.
> 
> This is what will soon be put forth for your comments.  In the meantime, even though the formal comment period is not yet open, we invite you to review the model now and bring whatever         questions you might have to the program when we meet on Wednesday, November 10th, at 14.30 GMT at the IETF meeting.  Of course you can also join the mailing list [3] and contribute your questions and comments there.
> 
> <OpenPGP_0x87B66B46D9D27A33.asc>-- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

--
Mark Nottingham   https://www.mnot.net/

---

From: Eliot Lear <[email-masked]>
Date: Fri, 22 Oct 2021 07:55:53 +0200

I can certainly ask.

---

From: Eliot Lear <[email-masked]>
Date: Fri, 22 Oct 2021 09:47:54 +0200

Brian,

Modulo a comma and very slight editorial tweaking, I have taken your 
comments onboard.  The draft is now live at 
https://github.com/intarchboard/program-rfced-future/blob/master/community-note-pre-consult.md. 
Comments, of course, to the list.  I've also added a reference to RFC 
4845, so that people know what to expect.

Eliot