Subject: [rmcat] fairness/unfairness metrics

From: Luca De Cicco <[email-masked]>
Date: Tue, 8 Oct 2013 15:02:46 +0200

Dear all,

I was wondering what's the status about the fairness/unfairness metric to
be adopted for evaluating rmcat flows.
In "draft-singh-rmcat-cc-eval-03" I only found some comments (open issue
(1)) on "unfairness" defining three criteria.

Thanks,
--
Luca De Cicco, PhD, Eng.
Politecnico di Bari
Dipartimento di Elettrotecnica ed Elettronica
Via Re David, 200 - Bari - ITALY
Office: +39 080 596 3851
http://c3lab.poliba.it/index.php/LDC

---

From: Varun Singh <[email-masked]>
Date: Tue, 8 Oct 2013 16:46:30 +0300

Hi Luca,

The last design meeting (in September) concluded that each scenario
would describe the expected behaviour or describe what behavior of
the congestion control it is attempting to verify.

For example the scenarios already implemented in some papers are
described in: https://sites.google.com/site/ietfrmcatsolutionevaluations/
, however,
comments on desired behaviour is still pending.

The three criteria in the cc-eval draft are more like a test than a
metric and may
not be applicable in all the cases.

Cheers,
Varun

On Tue, Oct 8, 2013 at 4:02 PM, Luca De Cicco <[email-masked]> wrote:
> Dear all,
>
> I was wondering what's the status about the fairness/unfairness metric to be
> adopted for evaluating rmcat flows.

-- 
http://www.netlab.tkk.fi/~varun/

---

From: Luca De Cicco <[email-masked]>
Date: Tue, 8 Oct 2013 16:54:40 +0200

Dear Varun,

thanks for the clear explanation :).

I have a follow-up question: what's the reason for considering only RED as
bottleneck
queue type? Also, why is drop-tail not to be considered?

Best,
Luca

---

From: Varun Singh <[email-masked]>
Date: Tue, 8 Oct 2013 18:22:16 +0300

Hi Luca,

We do consider Droptail, it is the default queue type (if it is not
already mentioned, I'll make it more explicit).
The open issue (no. 6) is if we should consider others, at the Berlin
meeting the conclusion was to start with Droptail and move to other
types of queue when we have more information about them.

Cheers,
Varun

---

From: Michael Welzl <[email-masked]>
Date: Wed, 9 Oct 2013 10:02:27 +0200

Hi,

IMO, a good reason to use only DropTail and RED would be that RED is, so far, the only IETF-recommended mechanism, and it'd be better for rmcat evaluations to not be based on a moving target...

Cheers,
Michael

---

From: Wesley Eddy <[email-masked]>
Date: Wed, 09 Oct 2013 09:05:55 -0400

On 10/9/2013 4:02 AM, Michael Welzl wrote:
> Hi,
> 
> IMO, a good reason to use only DropTail and RED would be that RED is,
> so far, the only IETF-recommended mechanism, and it'd be better for
> rmcat evaluations to not be based on a moving target...
> 

I'm not aware of an IETF recommendation for RED.

2309 was by the E2ERG, not an IETF consensus document, as I understand.

Given that, and the sensitivity to parameterizing RED, I would
personally be fine with tail-drop queues only, though I understand
the motivation here to be able to show performance in cooperation
with an AQM.  IMHO, that can be left as future work.

-- 
Wes Eddy
MTI Systems

---

From: Michael Welzl <[email-masked]>
Date: Wed, 9 Oct 2013 15:09:11 +0200

> 2309 was by the E2ERG, not an IETF consensus document, as I understand.

Sorry: IETF-described!  I know it's an important difference, really just mistyped, apologies.

> with an AQM.  IMHO, that can be left as future work.

+1, I actually agree on that.

Cheers,
Michael