Subject: [rmcat] compressed codec-free webrtc?

From: Dave Taht <[email-masked]>
Date: Tue, 29 Oct 2013 11:33:07 -0700

In having my eyes glaze over at the codec debate I found myself
wondering to what extent anyone was pursuing truly low latency video
and audio, along the lines of what the lola project has been doing for
collaborative concerts.

See:

http://www.conts.it/artistica/lola-project

They ship raw audio and raw video, they actually use cameras where
they can get at scanlines and ship that (saving 16ms)

So I'm ignorant of what webrtc can do is there a codec selection (yuv?
48 bit audio? for the rawest video and audio possible?) All the extra
encoding steps we take today induce extra latency, and available
bandwidth continues to increase... and from a cc perspective if you
drop some bits from a scanline that's not a problem, but from audio
it's a huge deal....

-- 
Dave Täht

Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html

---

From: Justin Uberti <[email-masked]>
Date: Tue, 29 Oct 2013 11:45:45 -0700

Uncompressed 720p30 (I420) is ~330 Mbps, so even though bandwidth continues
to increase, we're still not at the point where we no longer need codecs
(in the general case).

On Tue, Oct 29, 2013 at 11:33 AM, Dave Taht <[email-masked]> wrote:

> Fixing bufferbloat with cerowrt:
> http://www.teklibre.com/cerowrt/subscribe.html
>

---

From: Dave Taht <[email-masked]>
Date: Tue, 29 Oct 2013 13:00:03 -0700

On Tue, Oct 29, 2013 at 12:32 PM, Adam Roach <[email-masked]> wrote:
> On 10/29/13 13:33, Dave Taht wrote:
>
> 48 bit audio? for the rawest video and audio possible?)
>
>
> In theory, what you're looking for is this:
> http://tools.ietf.org/html/rfc4175

Thank you!

> However, the caveats in that document are pretty huge:
>
>    It is important to note that uncompressed video can have immense
>    bandwidth requirements (up to 270 Mbps for standard-definition video,
>    and approximately 1 Gbps for high-definition video).  This is
>    sufficient to cause potential for denial-of-service if transmitted
>    onto most currently available Internet paths.
>
>
> Given the risk of Destroying The Internet Forever[tm] if any major browser
> vendor implemented this, I don't expect you'll see much deployment any time
> soon.

I don't see people doing videoconferences in the same qty as we do,
say, torrents (famous last words!). Certainly the panopticon might
take over the internet (but in that case delays from encoding should
be acceptable to our new robotic panoptic overloads, it's just the
pesky humans that have trouble with latency)

So, maybe running at rates like this would trouble the "Internet" a
bit now, but on internal networks, not so much.

270Mbits is a trivial amount of bandwidth for a modern switched
network. Homes and businesses that are wired are probably close to
universally switched GigE, so internal conversations could possibly
run at max speed and minimal latency.

Internet-wise, Gfiber delivers GigE, upcoming docsis standards go well
above 200Mbit, 802.11ac goes past a gig, 802.11ad goes to 7gig.

Removing a serious delay-inducing-encoding step makes things like echo
cancellation unneeded, and live lola-like-collaboration possible.

> /a

-- 
Dave Täht

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Wed, 30 Oct 2013 05:15:59 +0000

Give app developers yuv, udp and native-speed js, and they won¹t need all
the webrtc plumbing at all. No chance of negotiation failure as icing. :)

Mo

On 10/29/13, 2:33 PM, Dave Taht <[email-masked]> wrote:

See:

-- 
Dave Täht

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 29 Oct 2013 18:47:29 +0000

Hi Dave,

As far as the standards is concerned, you are allowed to implement and use whatever codec you want.

The discussion is about whether there should be a codec that everyone MUST implement.

Regards,

Christer

-----Alkuperäinen viesti-----
Lähettäjä: [email-masked] [mailto:[email-masked]] Puolesta Dave Taht
Lähetetty: 29. lokakuuta 2013 20:33
Vastaanottaja: [email-masked]; [email-masked]
Aihe: [rtcweb] compressed codec-free webrtc?

In having my eyes glaze over at the codec debate I found myself wondering to what extent anyone was pursuing truly low latency video and audio, along the lines of what the lola project has been doing for collaborative concerts.

See:

They ship raw audio and raw video, they actually use cameras where they can get at scanlines and ship that (saving 16ms)

So I'm ignorant of what webrtc can do is there a codec selection (yuv?
48 bit audio? for the rawest video and audio possible?) All the extra encoding steps we take today induce extra latency, and available bandwidth continues to increase... and from a cc perspective if you drop some bits from a scanline that's not a problem, but from audio it's a huge deal....

--
Dave Täht

Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Adam Roach <[email-masked]>
Date: Tue, 29 Oct 2013 14:32:03 -0500

Given the risk of Destroying The Internet Forever[tm] if any major 
browser vendor implemented this, I don't expect you'll see much 
deployment any time soon.

/a

---

From: Leon Geyser <[email-masked]>
Date: Tue, 29 Oct 2013 23:14:37 +0200

Meanwhile where I live how long would it take to show one frame over a
256Kbit/s connection? :)
The MTI codec needs to be a lossy codec.

On 29 October 2013 22:01, Martin Thomson <[email-masked]> wrote:

> On 29 October 2013 12:32, Adam Roach <[email-masked]> wrote:
> I'm surprised that this didn't come up in the codec discussions.  Of
> course, you'd want to use FEC so that you could reduce the need for
> loss concealment.

---

From: Martin Thomson <[email-masked]>
Date: Tue, 29 Oct 2013 13:01:32 -0700

---

From: Matt Fredrickson <[email-masked]>
Date: Wed, 30 Oct 2013 10:08:48 -0500

On Tue, Oct 29, 2013 at 3:00 PM, Dave Taht <[email-masked]> wrote:

> browser

Echo cancellation will probably still be needed.  Audio as exposed to
userspace in the operating system is usually not low enough latency to
remove the need to do echo cancellation.  Packetization also induces delays
in the audio/video stack the necessitate echo cancellation.

Matthew Fredrickson