Subject: [rmcat] ECN marking for webrtc and stun packets?

From: Dave Taht <[email-masked]>
Date: Fri, 14 Mar 2014 05:39:03 -0700

I am curious if anyone has outlined an approach to CC for
webrtc (rtp, stun, etc) based on more fully utilizing ECN for
it?

The only thing that I see that sort of touches upon it was this:

http://www.tschofenig.priv.at/cc-workshop/draft-arkko-wscc-deployment-00.txt

-- 
Dave Täht

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 14 Mar 2014 12:56:06 +0000

Hi,

there is also RFC6679, which deals with RTP but not (necessarily) in the context of webrtc.

Lars

---

From: Michael Welzl <[email-masked]>
Date: Fri, 14 Mar 2014 14:02:39 +0100

... and NADA quite explicitly incorporates ECN:
http://tools.ietf.org/html/draft-zhu-rmcat-nada-03

Cheers,
Michael

---

From: Dave Taht <[email-masked]>
Date: Fri, 14 Mar 2014 06:09:51 -0700

> http://tools.ietf.org/html/draft-zhu-rmcat-nada-03

I obviously did not google hard enough. Thank you both.

(This is in reaction to the ongoing thread on using extensive QoS
markings in stun with the implied assumption that using AFxx
would actually accomplish anything on common media types like
wifi)

It does not appear if nada has made it as far as the webrtc sources.

-- 
Dave Täht

Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html