Subject: [rmcat] Pdf document formatting problems

From: Erlendur Karlsson <[email-masked]>
Date: Thu, 13 Mar 2014 08:49:59 +0000

Hi,

The pdf versions of the documents
draft-sarker-rmcat-eval-test-00<http://datatracker.ietf.org/doc/draft-sarker-rmcat-eval-test/> and draft-ietf-rmcat-cc-requirements-02<http://datatracker.ietf.org/doc/draft-ietf-rmcat-cc-requirements/>,
seem to be formatted in such a way that a document page is split onto two pages.

It would be greatly appreciated if the pdf formatting of these documents could be fixed.

Br,
Erlendur

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 13 Mar 2014 09:37:17 +0000

On 2014-3-13, at 9:49, Erlendur Karlsson <[email-masked]> wrote:
> draft-sarker-rmcat-eval-test-00 and draft-ietf-rmcat-cc-requirements-02,

http://tools.ietf.org/pdf/draft-sarker-rmcat-eval-test-00.pdf and
http://tools.ietf.org/pdf/draft-ietf-rmcat-cc-requirements-02.pdf look fine here?

Lars

---

From: Erlendur Karlsson <[email-masked]>
Date: Thu, 13 Mar 2014 12:12:29 +0000

In both of them I get the foot-line for the first page on top of the second page, which is empty except for that line. This line offset evolves for the following pages. While for other documents such as http://datatracker.ietf.org/doc/draft-ietf-rmcat-eval-criteria/ I have no problems with the pdf file, the foot-lines for all the pages are exactly where they should. It seems they are formatted differently.

Br,
Erlendur

-----Original Message-----
From: Eggert, Lars [mailto:[email-masked]] 
Sent: den 13 mars 2014 10:37
To: Erlendur Karlsson
Cc: [email-masked]
Subject: Re: [rmcat] Pdf document formatting problems

> seem to be formatted in such a way that a document page is split onto two pages.

http://tools.ietf.org/pdf/draft-sarker-rmcat-eval-test-00.pdf and http://tools.ietf.org/pdf/draft-ietf-rmcat-cc-requirements-02.pdf look fine here?

Lars

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 13 Mar 2014 13:01:51 +0000

Are you printing them or viewing them on screen?

If the former, I suspect a page size issue.

Lars

---

From: Erlendur Karlsson <[email-masked]>
Date: Thu, 13 Mar 2014 13:38:18 +0000

I am viewing them on the screen and it does not matter if it is in a Chrome browser or Acrobat Reader. 

Br,
Erlendur

-----Original Message-----
From: rmcat [mailto:[email-masked]] On Behalf Of Eggert, Lars
Sent: den 13 mars 2014 14:02
To: Erlendur Karlsson
Cc: [email-masked]
Subject: Re: [rmcat] Pdf document formatting problems

Lars

---

From: Stefan Alfredsson <[email-masked]>
Date: Thu, 13 Mar 2014 17:52:28 +0100

> If the former, I suspect a page size issue.

I became very curious of a PDF document that would *reformat*
in different viewers (xpdf showed blank pages, but chrome was OK).

However, the discrepancy is caused by a stale web cache:

$ wget 'http://tools.ietf.org/pdf/draft-sarker-rmcat-eval-test-00.pdf'
Connecting to tools.ietf.org (tools.ietf.org)|77.72.230.30|:80...
Length: 76566 (75K) [application/pdf]

### wait for it...

$ wget 'http://tools.ietf.org/pdf/draft-sarker-rmcat-eval-test-00.pdf'
 Connecting to tools.ietf.org (tools.ietf.org)|64.170.98.42|:80...
Length: 91706 (90K) [application/pdf]

(or you can do a couple of shift-reload in Chrome)

The PDF served from 77.72.230.30 has bad formatting,
but the PDF from 64.170.98.42 is fine.
As indicated above, they have different sizes and are
also created on different days:

$ pdfinfo draft-sarker-rmcat-eval-test-00.pdf | grep Creation
CreationDate:   Thu Feb 20 02:21:32 2014

$ pdfinfo draft-sarker-rmcat-eval-test-00.pdf.1 | grep Creation
CreationDate:   Wed Feb 19 13:38:50 2014

I'm CCing the tools-webmaster so they can investigate.

/Stefan

-- 
Stefan Alfredsson, PhD         Tel: +46 (0) 54 700 1668
Datavetenskap                  Kontor: 21F-425 (Hus Vanern)
Karlstads universitet          PGP 0xB19B4B16
SE-651 88 Karlstad             http://www.cs.kau.se/stefalfr/

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 14 Mar 2014 09:43:05 +0100

> I'm CCing the tools-webmaster so they can investigate.

The issue should be fixed now.  The underlying issue with the flawed generation
was fixed already about a month ago, but I'd neglected to clean out the cached
files on at least one of the tools servers.

Thanks for the analysis and alert!

Best regards,

	Henrik