Subject: Re: [rmcat] Physical interim meeting (in Zurich or Munich)

From: Zaheduzzaman Sarker <[email-masked]>
Date: Tue, 2 Sep 2014 13:09:50 +0000

Hi chairs,

Thanks for the initiative. We talked about interim meeting dedicated to evaluation of the candidate algorithms in Toronto. Will that still be the focus of this proposed interim meeting?

Being curious, is there any possibility to have virtual meeting instead?

BR

Zahed

> -----Original Message-----
> From: rmcat [mailto:[email-masked]] On Behalf Of Mirja Kühlewind
> Sent: den 29 augusti 2014 15:05
> To: [email-masked]
> Cc: Karen E. E. Nielsen; Eggert, Lars
> Subject: Re: [rmcat] Physical interim meeting (in Zurich or Munich)
> 
> Hi agian,
> 
> just to clarify the dates; sorry if this was confusing
> 
> * Zurich: Oct 8/9 (fixed)
> 
> * Munich: one or two days the same week between Oct 6 and Oct 9
> 
> Mirja
> 
> 
> 
> On 29.08.2014 11:31, Mirja Kühlewind wrote:
> > Hi w-g,
> >
> > as discussed at the last meeting, we would like to hold an intermin
> > meeting. We propose a physical meeting beginning of October. This will
> > probably be a meeting with two half days, so people can fly in in the
> > morning and leave the next afternoon/evening. There are two options.
> > We can choose whichever is more suitable for most of the people:
> >
> > * Zurich, Oct 8/9 (at ETH in the city center)
> >
> > * Munich, between 6-9 (at NetApp, 20 Minutes out of the city but good
> > train connection)
> >
> > Please let us know as soon as possible if you would be able to attend
> > (and which date would be best for you). If we get a sufficient number
> > of replies we will set up the logistics next.
> >
> > Thanks,
> > your chairs
> >
> >
> 
> --
> ------------------------------------------
> Dipl.-Ing. Mirja Kühlewind
> Communication Systems Group
> Institute TIK, ETH Zürich
> Gloriastrasse 35, 8092 Zürich, Switzerland
> 
> Room ETZ G93
> phone: +41 44 63 26932
> email: [email-masked]
> ------------------------------------------

---

From: Michael Welzl <[email-masked]>
Date: Tue, 2 Sep 2014 15:25:53 +0200

.... I would hope that this would also be a good time to talk about coupled congestion control and shared bottleneck detection (for the latter, we can try to get a draft out before the interim). Anyway, it would be good to know what the plan is, I agree...

---

From: Mirja Kühlewind <[email-masked]>
Date: Tue, 02 Sep 2014 16:03:02 +0200

Hi Zahed, hi Michael,

yes, this meeting is meant to focus on evaluation results. This is also 
the reason why we prefer to have a physical meeting. At least I believe 
that discussing evaluation graphs and data does only work well face-to-face.

Regarding the coupled CC and shared bottleneck detection, we definitely 
appreciate to get an update by then so we can move one or both documents 
forward. I believe if we will have a 1-2 days meeting there should be 
enough time to also discussion these proposals but we will definitely 
favor presentations of evaluation results.

Mirja

Room ETZ G93
phone: +41 44 63 26932

---

From: "Michael Ramalho (mramalho)" <[email-masked]>
Date: Tue, 2 Sep 2014 14:09:41 +0000

Chairs, et.al.,

That week happens to be bad for me (personal reasons). Travel from North America to Europe is nearly impossible.

Assuming we can generate a detailed agenda for the meeting (Zahed's point below), perhaps we can schedule a remote meeting sometime relatively soon. Cisco (i.e., me or Xiaoqing) can set up a WebEx for it.

Then may I suggest a Sunday morning (gasp!) meeting in Hawaii prior to the IETF week to go over results obtained in the interim.

Ideally, we ought to have a common understanding on how best to fuse delay and loss instrumentation when competing with various flavors of TCP (short chatty flows, long-term flows, TCP flows with differing RTTs and/or bottleneck queue depths). Perhaps if we advertise such a pre-IETF meeting some of the TCP transport dynamics experts (e.g., Matt/Jim/Dave) might be convinced to provide input when seeing the RMCAT tradeoffs of our simulations/experiments.

[FWIW - I think we have a good enough understanding of the delay-only adaptation mechanics - although the candidates use different mechanisms to achieve the desired ends.]

Comments?

Michael Ramalho

-----Original Message-----
From: rmcat [mailto:[email-masked]] On Behalf Of Zaheduzzaman Sarker
Sent: Tuesday, September 02, 2014 8:10 AM
To: Mirja Kühlewind; [email-masked]
Cc: Karen E. E. Nielsen; Eggert, Lars
Subject: Re: [rmcat] Physical interim meeting (in Zurich or Munich)

Hi chairs,

BR

Zahed

> > meeting. We propose a physical meeting beginning of October. This 
> > will probably be a meeting with two half days, so people can fly in 
> > in the morning and leave the next afternoon/evening. There are two options.
> > * Munich, between 6-9 (at NetApp, 20 Minutes out of the city but 
> > good train connection)
> >
> > Please let us know as soon as possible if you would be able to 
> > attend (and which date would be best for you). If we get a 
> > sufficient number of replies we will set up the logistics next.
> >
> > Thanks,
> > your chairs
> >
> >
> 
> --

---

From: Michael Welzl <[email-masked]>
Date: Tue, 2 Sep 2014 17:28:29 +0200

ok - makes sense of course, but good to know, thanks! then maybe a smaller number of folks will come from our side for this interim. i'll definitely be there though.

Sent from my iPhone

> On 2. sep. 2014, at 16:03, Mirja Kühlewind <[email-masked]> wrote:
> 
> Hi Zahed, hi Michael,
> 
> yes, this meeting is meant to focus on evaluation results. This is also the reason why we prefer to have a physical meeting. At least I believe that discussing evaluation graphs and data does only work well face-to-face.
> 
> Regarding the coupled CC and shared bottleneck detection, we definitely appreciate to get an update by then so we can move one or both documents forward. I believe if we will have a 1-2 days meeting there should be enough time to also discussion these proposals but we will definitely favor presentations of evaluation results.
> 
> Mirja
> 
> 
>

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Tue, 2 Sep 2014 16:11:12 +0000

Hi, 

I concur with Michael R that we will not be able to travel physically to
Europe for an interim meeting due to our travel budget constraints. At the
same time, I also feel that discussions of evaluation results will be most
effective in a face-to-face meeting.

So, can we do the following?  Can we have a virtual meeting via webex to
sync up on what eval results to collect from our respective testing
efforts. And then we can go over those together in a physical meeting
along side the November IETF meeting in Hawaii?  If folks don¹t like the
idea of meeting up on Sunday, maybe we can get a room on the side (as in
the case of previous design team meetings) during regular meeting hours
(or over lunch)?

Thanks,
Xiaoqing

On 9/2/14, 10:28 AM, "Michael Welzl" <[email-masked]> wrote:

>ok - makes sense of course, but good to know, thanks! then maybe a
>smaller number of folks will come from our side for this interim. i'll
>definitely be there though.
>
>Sent from my iPhone
>
>>> .... I would hope that this would also be a good time to talk about
>>>coupled congestion control and shared bottleneck detection (for the
>>>latter, we can try to get a draft out before the interim). Anyway, it
>>>would be good to know what the plan is, I agree...
>>> 
>>> 
>>>> Thanks for the initiative. We talked about interim meeting dedicated
>>>>to evaluation of the candidate algorithms in Toronto. Will that still
>>>>be the focus of this proposed interim meeting?
>>>> 
>>>>>>will
>>>>>>good
>>>>>>attend

---

From: Dave Taht <[email-masked]>
Date: Tue, 2 Sep 2014 09:36:33 -0700

On Tue, Sep 2, 2014 at 9:11 AM, Xiaoqing Zhu (xiaoqzhu)
<[email-masked]> wrote:
> Europe for an interim meeting due to our travel budget constraints.

I have no travel budget to speak of, either, but no limits on how or when
I travel.

What usually happens is I finagle a sponsor to and stay in europe for
a few weeks, park myself at their desk, partner up with people and get
some work done. It is very nice to share a time zone and do F2F work.

I MIGHT be in athens in 2 weeks for the IEEE 802 meeting, after that, no plans.

I am in los gatos, ca presently, if someone wants a F2F here.

>At the

I am bemused by not dogfooding webrtc with a webrtc enabled service
like appear.in or jit.si. By using those or something like those, the
existing algos in chrome, firefox, and the intermediate proxies could
be better understood.

appear.in/bufferbloat is a room where my group often meets.

> efforts.

My chief critiques of the last meeting were that:

a)  the evaluation results from different parties must be presented on
the same time scales. Or raw-er data provided to draw plots that could
be read without squinting.

b) I'd like to see some shorter RTTs and larger bandwidths added. My
standard set of RTTs is oriented around CDNs, however, and I'd suggest
adding 100us, 40ms and 80ms as videoconferencing choices for:
ethernet, half a (US) continental distance/typical eu distance and a
full US distance, in addition to the two RTTs used now.  As for
bandwidths, I listed the set I'm using in the sigcomm talk, I guess I
should put that down in an ID-like document somewhere.

c) from squinting at the 300ms results, I drew the conclusion that
something more like slow start is needed, some sort of
continual probing that the loss of packets won't affect (send a
duplicate frame?).

d) I'd dearly like to have a standardized set of inputs that could be
encoded and transmitted in conjunction with the netperf-wrapper tool.
Or a set of results gathered from some other tool while various
netperf-wrapper based tests (rrul, the web tests, simple stuff like
tcp_upload/download)

>And then we can go over those together in a physical meeting

-- 
Dave Täht

NSFW: https://w2.eff.org/Censorship/Internet_censorship_bills/russell_0296_indecent.article

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 2 Sep 2014 17:24:13 -0500

On Sep 2, 2014 9:09 AM, "Michael Ramalho (mramalho)" <[email-masked]>
wrote:
> Assuming we can generate a detailed agenda for the meeting (Zahed's point
below), perhaps we can schedule a remote meeting sometime relatively soon.
Cisco (i.e., me or Xiaoqing) can set up a WebEx for it.
>
> Then may I suggest a Sunday morning (gasp!) meeting in Hawaii prior to
the IETF week to go over results obtained in the interim.

On this particular point, both your responsible AD (me) and your
irresponsible AD (Martin) would ordinarily be meeting with the rest of the
IESG on Sunday morning of an IETF meeting week.

Do the right thing, but I wanted to make sure the working group knows that
...

Spencer

---

From: Varun Singh <[email-masked]>
Date: Tue, 9 Sep 2014 17:12:16 +0300

Hi,

What was the outcome of the discussion -- was a date picked for the interim?

Cheers,
Varun

On Fri, Aug 29, 2014 at 4:05 PM, Mirja Kühlewind
<[email-masked]> wrote:
>> morning and leave the next afternoon/evening. There are two options. We
>> can choose whichever is more suitable for most of the people:
>>
>> (and which date would be best for you). If we get a sufficient number of
>> replies we will set up the logistics next.
>>
>> Thanks,
>> your chairs
>>
>>
>
> --

-- 
http://www.netlab.tkk.fi/~varun/