Subject: [rmcat] Video sequences for emulation tests

From: Zaheduzzaman Sarker <[email-masked]>
Date: Sun, 19 Jul 2015 19:44:01 +0000

Hi,

As RMCAT congestion control algorithms are getting implemented, we will see more test results where real video encoder will be used.
We have seen results for GCC in the emulated network where a video sequence has been used. The evaluation results of SCReAM implementation we will also use some video sequences.

The eval-test (https://tools.ietf.org/html/draft-ietf-rmcat-eval-test-01) draft points to sources of the video sequences to use in the tests but does not pick any particular one(s). However, as the contents of the video sequences have impact on the encoder output, I believe it will be better if we can agree on the video sequences to use in the tests. This will make the results more comparable.

Any comments on that?

BR

Zahed

===============================================================================
ANM ZAHEDUZZAMAN SARKER
Senior Researcher
Services, Media and Network Features

Ericsson
Laboratoriegränd 11
97128 Luleå, Sweden
Phone +46 10 717 37 43
Mobile +46 76 115 37 43
Office +46 76 115 37 43
Fax +46 920 996 21
[email-masked]
www.ericsson.com<http://www.ericsson.com>
===============================================================================

---

From: Varun Singh <[email-masked]>
Date: Sun, 19 Jul 2015 23:08:03 +0200

Hi zahed,

We didn't explicitly say which videos, but the feast points to a URL with
sequences. These sequences were shared by Stephan Wenger a few IETF
meetings ago. IIRC, Foreman was used before that.  And the complete list is
at the url.

Cheers

[HEVC-seq] HEVC, , "Test Sequences", http://
<http://www.netlab.tkk.fi/~varun/test_sequences/>www.netlab.tkk.fi
<http://www.netlab.tkk.fi/~varun/test_sequences/>/~varun/test_sequences/
<http://www.netlab.tkk.fi/~varun/test_sequences/>
On Jul 19, 2015 9:44 PM, "Zaheduzzaman Sarker" <
[email-masked]> wrote:

>  Hi,
>
> As RMCAT congestion control algorithms are getting implemented, we will
> see more test results where real video encoder will be used.
> We have seen results for GCC in the emulated network where a video
> sequence has been used. The evaluation results of SCReAM implementation we
> will also use some video sequences.
>
> The eval-test (https://tools.ietf.org/html/draft-ietf-rmcat-eval-test-01)
> draft points to sources of the video sequences to use in the tests but does
> not pick any particular one(s). However, as the contents of the video
> sequences have impact on the encoder output, I believe it will be better if
> we can agree on the video sequences to use in the tests. This will make the
> results more comparable.
>
> Any comments on that?
>
> BR
>
> Zahed
>
>
> *===============================================================================*
>
> *ANM ZAHEDUZZAMAN SARKER *Senior Researcher
> *Ericsson *Laboratoriegränd 11
> 97128 Luleå, Sweden
> Phone +46 10 717 37 43
> Mobile +46 76 115 37 43
> Office +46 76 115 37 43
> Fax +46 920 996 21
> *www.ericsson.com* <http://www.ericsson.com>
>

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Sun, 19 Jul 2015 21:31:48 +0000

Hi Varun,

Yes, we haven’t explicitly said which videos. But now I think it would be good to pick up couple of them if not one.

BR

Zahed

From: Varun Singh [mailto:[email-masked]]
Sent: den 19 juli 2015 23:08
To: Zaheduzzaman Sarker
Cc: rmcat WG
Subject: Re: [rmcat] Video sequences for emulation tests

Hi zahed,

We didn't explicitly say which videos, but the feast points to a URL with sequences. These sequences were shared by Stephan Wenger a few IETF meetings ago. IIRC, Foreman was used before that.  And the complete list is at the url.

Cheers

[HEVC-seq] HEVC, , "Test Sequences", http://<http://www.netlab.tkk.fi/~varun/test_sequences/>www.netlab.tkk.fi<http://www.netlab.tkk.fi/~varun/test_sequences/>/~varun/test_sequences/<http://www.netlab.tkk.fi/~varun/test_sequences/>
On Jul 19, 2015 9:44 PM, "Zaheduzzaman Sarker" <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Any comments on that?

BR

Zahed

Ericsson
Laboratoriegränd 11
97128 Luleå, Sweden
Phone +46 10 717 37 43<tel:%2B46%2010%20717%2037%2043>
Mobile +46 76 115 37 43<tel:%2B46%2076%20115%2037%2043>
Office +46 76 115 37 43<tel:%2B46%2076%20115%2037%2043>
Fax +46 920 996 21<tel:%2B46%20920%20996%2021>
[email-masked]<mailto:[email-masked]>
www.ericsson.com<http://www.ericsson.com>
===============================================================================

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Sun, 19 Jul 2015 22:38:00 +0000

Agree that will be nice for folks to use the same set of video sequences for testing.  We have not yet tested with the sources shared by Stephan Wenger.  Will weigh in on this topic after we look into that.

BTW, from the link foreman15_4000.yuv has a size of 0 …

Thanks,
Xiaoqing

From: rmcat <[email-masked]<mailto:[email-masked]>> on behalf of Zaheduzzaman Sarker <[email-masked]<mailto:[email-masked]>>
Date: Sunday, July 19, 2015 at 4:31 PM
To: Varun Singh <[email-masked]<mailto:[email-masked]>>
Cc: rmcat WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rmcat] Video sequences for emulation tests

Hi Varun,

BR

Zahed

Hi zahed,

Cheers

Any comments on that?

BR

Zahed

Ericsson
Laboratoriegränd 11
97128 Luleå, Sweden

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Sun, 19 Jul 2015 22:43:37 +0000

The encoder and its configuration, particularly rate control settings, usually impacts output bitrate even more than the selection of raw sequences. So if we are moving towards guidelines for how CC candidates should test real video, some specific encoder and configuration should be specified in addition to specific raw sequences.

Cheers,
Mo

On Jul 19, 2015, at 11:31 PM, Zaheduzzaman Sarker <[email-masked]<mailto:[email-masked]>> wrote:

Hi Varun,

BR

Zahed

Hi zahed,

Cheers

Any comments on that?

BR

Zahed

Ericsson
Laboratoriegränd 11
97128 Luleå, Sweden