Subject: [rmcat] Generic RTCP feedback message AGAIN

From: Karen Elisabeth Egede Nielsen <[email-masked]>
Date: Mon, 16 Nov 2015 13:51:13 +0100

HI,

At the 2nd RMCAT session we proposed the following:

* Give usage of a common feedback message for sender side only RMCAT CC's
_a try_.

With the following proposed way forward

*1* Requirements to be considered in each CC algs draft
*2* Analyse required feedback rates and timing as well as content
   and point to existing remedies and/or what new needed

At the RMCAT session agreement on this not established.
Only *1* was agreed upon.  Whereas *2* was left for future potentially.

NOW given the recent discussion on the list it looks (to me) as
if we in the wg have a more mature view on this task.
Note the wg already has a milestone to which this work
can be associated. I.e., "Submit RTCP extension requirements
for use with congestion control algorithms to AVTCORE (if needed)".
Please respond to this email and give your view:

Shall we NOW give the usage of a common feedback message
for a sender side only CC a try ?
[Yes I want to be part of this - OR -  No I don't want to be part of this]

Assuming Yes. How shall we collect the requirements ?
Possible options (I can think of):

* have new updates of the CCs alg candidates (incl. SBD, coupled CC as
applicable)
   come soon with a good specification of the requested
* have the same information instead go into a (potentially temporary?)
    Appendix of draft-perkins-rmcat-rtp-cc-feedback-01.txt or new draft ?
* others - email ?

Assuming Yes. Where shall the outcome of the work be specified ?
draft-perkins-rmcat-rtp-cc-feedback-01.txt or new draft

BR,
Karen, on behalf of the chairs

> -----Original Message-----
> From: Karen Elisabeth Egede Nielsen [mailto:[email-masked]]
> Sent: 3. november 2015 01:29
> To: [email-masked]' <[email-masked]>
> Subject: Generic RTCP feedback message
>
> Hi,
>
> Following Stefan’s presentation in the RMCAT session yesterday there was
> agreement at the mike that we in the RMCAT wg should try to give the
usage
> of a generic common feedback message a try.
>
> It seems a prerequisite for this that the receiver (sender of the
feedback
> message) is (in principle) unaware of the particular CC algorithm that
the
> sender is using, but will generate a *to be defined* set of  feedback
> information in a *to be defined* form that will fulfil the requirements
of all
> RMCAT CC algorithms.
>
> In order to start on this task we hereby solicit for the people working
with CC
> algorithms to respond to this email with information on the requirements
> that they have to such a generic feedback mechanism.
>
> In addition _or alternatively_   please (all) provide feedback on
> * how you think we should proceed with this task, e.g., start a new
draft to
> collect this information (eventually to proceed in an ART wg)
> * concerns with this approach
>
> We will try to collect the information provided and have a short follow
up in
> Fridays RMCAT meeting.
> BR, Mirja/Karen

---

From: Stefan Holmer <[email-masked]>
Date: Fri, 20 Nov 2015 17:51:02 +0000

> [Yes I want to be part of this - OR -  No I don't want to be part of this]

Yes - I want to be part of this. :)

>     Appendix of draft-perkins-rmcat-rtp-cc-feedback-01.txt or new draft ?

I vote for either updating the current CC algorithm candidate drafts with
this information, or doing it over e-mail as a first step while we wait for
the updated drafts.

> draft-perkins-rmcat-rtp-cc-feedback-01.txt or new draft

No strong opinion about this.

---

From: Karen Elisabeth Egede Nielsen <[email-masked]>
Date: Mon, 23 Nov 2015 08:55:08 +0100

Thanks a lot Stefan !!

Others who want to share opinions on this and/or wants to be part of this
work.

Please repond ! J

BR, Karen

*From:* Stefan Holmer [mailto:[email-masked]]
*Sent:* 20. november 2015 18:51
*To:* Karen Elisabeth Egede Nielsen <[email-masked]>;
[email-masked]
*Cc:* Mirja Kühlewind <[email-masked]>
*Subject:* Re: [rmcat] Generic RTCP feedback message AGAIN

HI,

BR,

usage
feedback
the
of all
with CC
draft to
up in

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Tue, 24 Nov 2015 03:30:56 +0000

Hi Karen,

I'd like to be part of this effort too.  However, instead of jumping directly to the effort of trying with a common feedback message design, some preliminary work is needed.

For me the first two steps needed are exactly as you described: a) to clearly describe feedback mechanism used in the current CC implementation; and b) to perform some analysis on the required feedback interval and message content (what, when, how often).

With a good understanding of the above, we can then decide whether it's feasible to shift some of the receiver-based processing to the sender side - and, if so, how.

Best,
Xiaoqing

From: rmcat <[email-masked]<mailto:[email-masked]>> on behalf of Karen Elisabeth Egede Nielsen <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 23, 2015 at 1:55 AM
To: Stefan Holmer <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Mirja Kühlewind <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rmcat] Generic RTCP feedback message AGAIN

Thanks a lot Stefan !!

Others who want to share opinions on this and/or wants to be part of this work.
Please repond ! :)

BR, Karen

From: Stefan Holmer [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 20. november 2015 18:51
To: Karen Elisabeth Egede Nielsen <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Mirja Kühlewind <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rmcat] Generic RTCP feedback message AGAIN

On Mon, Nov 16, 2015 at 4:51 AM Karen Elisabeth Egede Nielsen <[email-masked]<mailto:[email-masked]>> wrote:
HI,

I vote for either updating the current CC algorithm candidate drafts with this information, or doing it over e-mail as a first step while we wait for the updated drafts.

BR,

> From: Karen Elisabeth Egede Nielsen [mailto:[email-masked]<mailto:[email-masked]>]
> To: [email-masked]<mailto:[email-masked]>' <[email-masked]<mailto:[email-masked]>>
> Following Stefan's presentation in the RMCAT session yesterday there was
usage
feedback
the
of all
with CC
draft to
up in

---

From: Colin Perkins <[email-masked]>
Date: Tue, 24 Nov 2015 16:27:54 +0000

Hi,

> On 16 Nov 2015, at 12:51, Karen Elisabeth Egede Nielsen <[email-masked]> wrote:
> 
> HI,
> 

I’d suggest either updates to the candidate drafts, or email on the list. 

> draft-perkins-rmcat-rtp-cc-feedback-01.txt or new draft

I view the role of that as being to describe what’s possible in terms of responsiveness of RTCP feedback. It talks about how much feedback can be provided, and how quickly, not what feedback information is needed. The combination of that draft, and requirements from the candidate drafts, will tell us whether RTCP feedback is sufficient, or if it needs some extensions/alternatives. 

Colin

-- 
Colin Perkins
https://csperkins.org/

---

From: Varun Singh <[email-masked]>
Date: Fri, 27 Nov 2015 12:12:43 +0200

Hi,

my opinions inline.

Regards,
Varun

On Fri, Nov 20, 2015 at 7:51 PM, Stefan Holmer <[email-masked]> wrote:
>
>
> On Mon, Nov 16, 2015 at 4:51 AM Karen Elisabeth Egede Nielsen
> <[email-masked]> wrote:
>>
>> HI,
>>

Yes - same as above.

> this information, or doing it over e-mail as a first step while we wait for

Individual algorithm candidates should update their documents, I suppose:
+ what metrics
+ when to send them, and how often.

Nonetheless, the discussion should continue on the mailing list.

-- 
http://www.callstats.io