Subject: [rmcat] Generic RTCP feedback message

From: Karen Elisabeth Egede Nielsen <[email-masked]>
Date: Tue, 3 Nov 2015 09:28:53 +0900

Hi,

Following Stefan's presentation in the RMCAT session yesterday there was
agreement at the
mike that we in the RMCAT wg should try to give the usage of a generic
common feedback message a try.

It seems a prerequisite for this that the receiver (sender of the feedback
message)
is (in principle) unaware of the particular CC algorithm that the sender
is using, but will generate a
*to be defined* set of  feedback information in a
*to be defined* form
that will fulfil the requirements of all RMCAT CC algorithms.

In order to start on this task we hereby solicit for the people working
with CC algorithms
to respond to this email with information on the requirements that they
have to such
a generic feedback mechanism.

In addition _or alternatively_   please (all) provide feedback on
* how you think we should proceed with this task, e.g., start a new draft
to collect this information (eventually to proceed in an ART wg)
* concerns with this approach

We will try to collect the information provided and have a short follow up
in Fridays RMCAT meeting.

BR, Mirja/Karen

---

From: Colin Perkins <[email-masked]>
Date: Tue, 3 Nov 2015 10:30:01 +0900

Hi,

I won’t be able to attend the Friday meeting, because of the conflict with PERC, but my understanding was that the group agreed to look into the requirements for RTCP feedback for the candidate congestion control algorithms, to see if a common RTCP feedback message makes sense, and whether the existing RTCP feedback packets are sufficient or whether we need to define a new feedback packet. 

Colin

> On 3 Nov 2015, at 09:28, Karen Elisabeth Egede Nielsen <[email-masked]> wrote:
> 
> Hi,
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Karen Elisabeth Egede Nielsen <[email-masked]>
Date: Tue, 3 Nov 2015 12:39:30 +0900

HI Colin,

Thanks.

I think that you are clarifying that within the *to de defined'*
includes the option that we may in fact not need at _new_ feedback packet.

BR, Karen

> -----Original Message-----
> From: Colin Perkins [mailto:[email-masked]]
> Sent: 3. november 2015 10:30
> To: Karen Elisabeth Egede Nielsen <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [rmcat] Generic RTCP feedback message
>
> Hi,
>
> I won’t be able to attend the Friday meeting, because of the conflict with
> PERC, but my understanding was that the group agreed to look into the
> requirements for RTCP feedback for the candidate congestion control
> algorithms, to see if a common RTCP feedback message makes sense, and
> whether the existing RTCP feedback packets are sufficient or whether we
> need to define a new feedback packet.
>
> Colin
>
>
>
>
> > Following Stefan's presentation in the RMCAT session yesterday there
> > was agreement at the mike that we in the RMCAT wg should try to give
> > the usage of a generic common feedback message a try.
> >
> > is (in principle) unaware of the particular CC algorithm that the
> > sender is using, but will generate a *to be defined* set of  feedback
> > information in a *to be defined* form that will fulfil the
> > requirements of all RMCAT CC algorithms.
> >
> > In order to start on this task we hereby solicit for the people
> > working with CC algorithms to respond to this email with information
> > on the requirements that they have to such a generic feedback
> > mechanism.
> >
> > * how you think we should proceed with this task, e.g., start a new
> > draft to collect this information (eventually to proceed in an ART wg)
> > We will try to collect the information provided and have a short
> > follow up in Fridays RMCAT meeting.
> >
> > BR, Mirja/Karen
> >
>
>
>
> --
> Colin Perkins
> https://csperkins.org/
>
>
>

---

From: Varun Singh <[email-masked]>
Date: Wed, 4 Nov 2015 10:59:50 +0900

Hi Karen,

As far as I can tell, there is a need for endpoints to use common RTCP
feedback messages.
The main reason is that endpoints implementing any of the RMCAT
algorithms can interoperate with each other by having common RTCP
feedback packets.
The metrics required for this common RTCP feedback packets may already
exist elsewhere, perhaps disjoint, ergo to map to existing XR blocks,
we need at least a set of congestion indicators, their reporting
frequency, and perhaps units of measurements.

Regards,
Varun

-- 
http://www.callstats.io