Subject: [rmcat] I-D Action: draft-ietf-rmcat-nada-05.txt

From: [email-masked]
Date: Thu, 28 Sep 2017 14:36:05 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the RTP Media Congestion Avoidance Techniques WG of the IETF.

        Title           : NADA: A Unified Congestion Control Scheme for Real-Time Media
        Authors         : Xiaoqing Zhu
                          Rong Pan
                          Michael A. Ramalho
                          Sergio Mena de la Cruz
                          Paul E. Jones
                          Jiantao Fu
                          Stefano D'Aronco
	Filename        : draft-ietf-rmcat-nada-05.txt
	Pages           : 25
	Date            : 2017-09-28

Abstract:
   This document describes NADA (network-assisted dynamic adaptation), a
   novel congestion control scheme for interactive real-time media
   applications, such as video conferencing.  In the proposed scheme,
   the sender regulates its sending rate based on either implicit or
   explicit congestion signaling, in a unified approach.  The scheme can
   benefit from explicit congestion notification (ECN) markings from
   network nodes.  It also maintains consistent sender behavior in the
   absence of such markings, by reacting to queuing delays and packet
   losses instead.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rmcat-nada/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rmcat-nada-05
https://datatracker.ietf.org/doc/html/draft-ietf-rmcat-nada-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rmcat-nada-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Thu, 28 Sep 2017 21:50:22 +0000

Hi Everyone, 

We have just updated the NADA draft with some minor algorithmic changes based on the input from Julius Flohr.  The changes are concentrated on Sec.4.2 (regarding how NADA behaves in the presence of loss), and can be summarized as follows: 

* Revised the criteria for determining when to perform non-linear warping: instead of abiding by a fixed expiration time (TEXP) as in the previous version, we now self-adapt this expiration time as multiples of the average packet loss intervals; 

* Recommended linear transition between warped and non-warped values of queuing delay during the transitional period switching from loss-based back to delay-based; 

* Revised the loss penalty function from linear to quadratic with respect to observed packet loss ratio. Also, for ease of understanding, revised the formula to anchor around a reference packet loss ratio so the scaling factor can be kept dimensionless. 

Basically, those changes are introduced to make the behavior of NADA more robust in the presence of loss-based flows (e.g., conventional TCP, as in RMCAT test case 5.6). We have implemented them in our ns3 reference code and verified their performance for all existing test cases.  Still pending efforts on testing this out in Julius' independent implementation on omnet (we are working together on this). 

Best regards,
Xiaoqing

________________________________________
From: rmcat <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Thursday, September 28, 2017 4:36 PM
To: [email-masked]
Cc: [email-masked]
Subject: [rmcat] I-D Action: draft-ietf-rmcat-nada-05.txt

Abstract: