Subject: Re: [rmcat] Benjamin Kaduk's No Objection on draft-ietf-rmcat-eval-test-09: (with COMMENT)

From: Colin Perkins <[email-masked]>
Date: Sun, 12 May 2019 22:14:52 +0100

Hi,

Just to follow-up: are there still updates required from the authors of this doc, or is it ready to progress?

Colin

> On 2 Apr 2019, at 10:02, Mirja Kuehlewind <[email-masked]> wrote:
> 
> Hi Zahed, hi Ben,
> 
> Just a quick note below.
> 
>> On 24. Mar 2019, at 14:51, Benjamin Kaduk <[email-masked]> wrote:
>> 
>>>>   Section 3
>>>> 
>>>>            +  Bottleneck-link capacity: defines minimum capacity of the
>>>>               end-to-end path
>>>> 
>>>>   I'm not sure I'd describe this as the "minimum capacity of the
>>>>   end-to-end path", since attempts to use anything larger than this value
>>>>   will pile up at the bottleneck.
>>>> 
>>>> [ZS] hmm, I guess that is why that link will act as bottleneck link for a respective testcase. If the flows remain below that capacity it should not experience queuing and as you said anything above that capacity will observe queuing. The job of the congestion control algorithm will be to avoid queuing.
>>> 
>>>   I think I was expecting "maximum capacity" to be more appropriate than
>>>   "minimum capacity".  Perhaps I'm confused about what is intended here.
>>> 
>>> (disclaimer. this has been done in the long past and I hope my memory is supporting me on explaining it ☺)
>>> 
>>> The thinking was that the bottleneck-link capacity was not equals to the maximum link capacity. That means if the maximum link capacity is X then the bottleneck-link capacity is Y , where Y<X and (X-Y) capacity is used by other traffic traversing that link. Hence, in the test if a link is assumed to be bottleneck then the "the bottleneck-link capacity" is the minimum capacity available to the media flow traversing that path. 
>> 
>> Ah, that makes sense.  Maybe "minimum guaranteed capacity" or similar would
>> convey the intent better.
> 
> The word “guaranteed” would be confusing here as people would associate this with some kind of resource reservation. Maybe "minimum link capacity of the end-to-end path”.
> 
> Mirja
> 
> 
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Thu, 23 May 2019 17:02:14 +0000

Hi Colin,

I have just submitted a -10 version where I believe I have addressed all the comments I have received so far.

BR

Zahed   
 
Ericsson Research
 
Network Architecture and Protocols 
Network Orchestration & Automation
[email-masked]
 
Ericsson
Torshamnsgatan 23
164 83, Stockholm
Sweden

On 2019-05-12, 23:15, "Colin Perkins" <[email-masked]> wrote:

    Hi,

    Colin

    
    -- 
    Colin Perkins
    https://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Thu, 23 May 2019 22:22:33 +0100

Hi, 

Zahed – Thank you for the update!

Mirja – It looks like this addresses the outstanding comments, and should be ready to go to the RFC Editor.

Cheers,
Colin

> On 23 May 2019, at 18:02, Zaheduzzaman Sarker <[email-masked]> wrote:
> 
> Hi Colin,
> 

-- 
Colin Perkins
https://csperkins.org/