Subject: Re: [rmcat] WG last call draft-ietf-rmcat-wireless-tests-06

From: Colin Perkins <[email-masked]>
Date: Tue, 7 May 2019 23:32:24 +0100

Thanks, Sergio. 

Authors – a reminder that these outstanding WG last call comments need to be addressed before this draft can advance.

Thanks,
Colin

> On 6 Feb 2019, at 15:04, Sergio Mena <[email-masked]> wrote:
> 
> RMCAT working group,
> 
> This is my review of draft-ietf-rmcat-wireless-tests-06. I realize my review comes a few days after the deadline. Sorry about that. Hopefully it's not too late.
> 
> I have structured my feedback in three parts: minor/editorial comments, "less minor" comments, and general comments.
> 
> * General comments.
>   - Although I had some (fairly minor) suggestions on the particular setup of test cases, I understand it is too late for that, as the draft is quite mature and several teams have already implemented the TCs as they are described, so this review doesn't attempt to re-discuss the values/topologies chosen for the test cases.
>   - Wifi6. The document does not make any reference to Wifi6. I am aware of the fact the the standard is not yet finalized, but I think the announced innovations (in particular OFDMA, and the increased scheduling flexibility it mail entail) would justify at least a general mention. My suggestion is that page 11 could be a good place to introduce such a reference. Section 4.3 is another good spot.
> 
> * "less minor"
>   - Page 6. Section 3.1.1. Please do not define the bandwidth as "infinite". That is problematic in a simulation. Rather, choose a big enough value (e.g., 10 Gbps) that is big enough so that it will not produce any congestion.
>   - Page 10. Last bullet. I would use the expression "non-congestion related losses" in this bullet, to be consistent with the cellular section.
>   - Page 11. Last paragraph. I wonder why the cellular section recommends or suggests that the tests should be carried out only in a simulator, whereas the WiFi section recommends to also run some "evaluation" in a real testbed.
>   - Page 16. "Congestion control" bullet includes the acronym [TBD]. Does it mean "to be decided"? If it does, what is the decision? BTW, why aren't TCP flows used in the cellular TCs (or did I miss them?)
> 
> * minor/editorial
>   - Abstract. "These applications are typically required to implement congestion control". Grammar is correct, but somewhat ambiguous on what requires what. Suggestion: "A congestion control algorithm is typically required by these applications"
>   - Page 4. 1st paragraph. "Besides, there are certain characteristics which make the cellular network different and challenging than other types of access network such as Wi-Fi and wired network”. Please fix grammar near the word "than".
>   - Page 5. "The key factors to define test cases for cellular network are" should read either "for a cellular network", or "for cellular networks". There are other occurrences of this further down in the text
>   - Page 6. In my opinion, "there should be enough amount of time" could be shortened to "there should be enough time"
>   - Page 8. "intercity" --> "intensity" (?)
>   - Page 11. First paragraph "singal" --> "signal"
>   - Page 11. "Throughout this draft". I would rather say "Throughout the 'WiFi networks' section" or "Throughout this section" something similar, to avoid confusion with the cellular section
>   - Page 12. 1st paragraph. "set up" --> "setup"
>   - All over. Search and replace: "traffics" --> "traffic"
>   - All over. Search and replace "followings" --> "following"
> 
> I hope this will help improve the quality of the text.
> 
> Sergio
> 
> 
> On 15/01/19 00:24, Colin Perkins wrote:
>> This is to announce a working group last call on the “Evaluation Test Cases for Interactive Real-Time Media over Wireless Networks” (draft-ietf-rmcat-wireless-tests-06).
>> 
>> Please send any final comments to the working group mailing list and the authors by 1 February 2019. If no substantive comments are received by that time, we intend to submit this draft to the IESG for publication as an Informational RFC.
>> 
>> Colin
>> (as WG co-chair)
>> 
>> 
>> 
>> 
>> 
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Wed, 8 May 2019 03:09:44 +0000

Thanks a lot, Sergio, for providing very detailed review comments to this draft.  Thanks to Colin for reminding us to respond. 

We will follow up with a revision to address these comments within about a week.  

Best,
Xiaoqing

On 5/7/19, 5:32 PM, "Colin Perkins" <[email-masked]> wrote:

    Thanks, Sergio. 

    Thanks,
    Colin

    
    -- 
    Colin Perkins
    https://csperkins.org/