Subject: [rmcat] How to handle remaining milestones

From: Anna Brunström <[email-masked]>
Date: Mon, 18 Nov 2019 14:47:00 +0000

Dear all,

As part of the WG status overview in tomorrow's rmcat meeting at IETF106 we want to bring up how to handle our remaining milestones:

Jul 2019            Publish first draft of evaluation results
Jul 2019            Publish first draft of Standards Track congestion control algorithm
Nov 2019          Submit interactions between applications and RTP flows to IESG as Informational
Nov 2019          Submit congestion control to IESG for Proposed Standard

One approach for how to move forward could be to gather evaluation results and experiences for the next 12 months or so (with meetings only if there are results to report) and then evaluate the status and whether to pursue further work. But the way forward of course depends on the interest of the working group and the intentions of the algorithm authors.

We just wanted to give a heads up for this discussion point so you all have a chance to think about it beforehand, also as it is not directly visible in the agenda as it is part of the WG status review. Any comment on the mailing list is of course also welcome!

Best Regards,
Anna (for the chairs)

---------------------------------------------------------------------
Professor Anna Brunstrom
Department of Mathematics and Computer Science
Karlstad University
651 88 Karlstad, Sweden
Phone:   +46 54 7001795
E-mail:  [email-masked]
---------------------------------------------------------------------

---

From: Ingemar Johansson S <[email-masked]>
Date: Tue, 19 Nov 2019 10:39:36 +0000

Hi

My plan is to drive an update of RFC8298 towards proposed standard status if
that is seen as important enough.

That update would also specify the L4S support either as implemented in the
example running code or some improved version of it. 

Still I would like to see more real life deployment experience, to get an
understanding of the possible outstanding issues that need to be fixed.

The problem is that SCReAM has not been deployed/experimented with other
than in a use case with remote controlled vehicles  and I don’t foresee any
wider deployment in other contexts for the moment. 

Question is if this is sufficient for a proposed standard status ?

/Ingemar

From: Anna Brunström <[email-masked]> 
Sent: den 18 november 2019 15:47
To: [email-masked]
Subject: [rmcat] How to handle remaining milestones

Dear all,

As part of the WG status overview in tomorrow’s rmcat meeting at IETF106 we
want to bring up how to handle our remaining milestones:

Jul 2019            Publish first draft of Standards Track congestion
control algorithm

Nov 2019          Submit interactions between applications and RTP flows to
IESG as Informational

One approach for how to move forward could be to gather evaluation results
and experiences for the next 12 months or so (with meetings only if there
are results to report) and then evaluate the status and whether to pursue
further work. But the way forward of course depends on the interest of the
working group and the intentions of the algorithm authors. 

We just wanted to give a heads up for this discussion point so you all have
a chance to think about it beforehand, also as it is not directly visible in
the agenda as it is part of the WG status review. Any comment on the mailing
list is of course also welcome!

Best Regards,
Anna (for the chairs)

Professor Anna Brunstrom

Karlstad University

651 88 Karlstad, Sweden

Phone:   +46 54 7001795

E-mail:  [email-masked] <mailto:[email-masked]>

---

From: Colin Perkins <[email-masked]>
Date: Wed, 20 Nov 2019 13:04:33 +0800

Hi Ingemar,

As we discussed in the meeting, I think we’re looking for some deployment experience before we progress candidate algorithms to proposed standard.

Colin

> On 19 Nov 2019, at 18:39, Ingemar Johansson S <ingemar.s.johansson=[email-masked]> wrote:
> 
> Hi
>  
> My plan is to drive an update of RFC8298 towards proposed standard status if that is seen as important enough.
> That update would also specify the L4S support either as implemented in the example running code or some improved version of it. 
> Still I would like to see more real life deployment experience, to get an understanding of the possible outstanding issues that need to be fixed.
> The problem is that SCReAM has not been deployed/experimented with other than in a use case with remote controlled vehicles  and I don’t foresee any wider deployment in other contexts for the moment. 
>  
> As part of the WG status overview in tomorrow’s rmcat meeting at IETF106 we want to bring up how to handle our remaining milestones:
>

---

From: Ingemar Johansson S <[email-masked]>
Date: Wed, 20 Nov 2019 10:56:17 +0000

OK  

Listened in on the RMCAT session, not sure that I get it fully.

I find it unlikely that SCReAM will find its way to web browser implementations. 

Will experience from remote control use cases be a sufficient toll gate to advance SCReAM to proposed standard?. I understand that remote control was not the initial intention in RMCAT.

/Ingemar

From: Colin Perkins <[email-masked]> 
Sent: den 20 november 2019 06:05
To: Ingemar Johansson S <[email-masked]>
Cc: Anna Brunstrom <[email-masked]>; [email-masked]; Ingemar Johansson S <[email-masked]>
Subject: Re: [rmcat] How to handle remaining milestones

Hi Ingemar,

Colin

On 19 Nov 2019, at 18:39, Ingemar Johansson S <ingemar.s.johansson=[email-masked] <mailto:ingemar.s.johansson=[email-masked]> > wrote:

Hi

/Ingemar

From: Anna Brunström <[email-masked] <mailto:[email-masked]> > 
Sent: den 18 november 2019 15:47
To: [email-masked] <mailto:[email-masked]> 
Subject: [rmcat] How to handle remaining milestones

Dear all,

Best Regards,
Anna (for the chairs)

Professor Anna Brunstrom

Karlstad University

651 88 Karlstad, Sweden

Phone:   +46 54 7001795

E-mail:   <mailto:[email-masked]> [email-masked]

---

From: Colin Perkins <[email-masked]>
Date: Thu, 21 Nov 2019 10:34:44 +0800

Hi Ingemar,

We’re looking for experience with use of these protocols over the Internet. This doesn’t necessarily have to be in browsers.

Colin

> On 20 Nov 2019, at 18:56, Ingemar Johansson S <ingemar.s.johansson=[email-masked]> wrote:
> 
> OK  
>  
> On 19 Nov 2019, at 18:39, Ingemar Johansson S <ingemar.s.johansson=[email-masked] <mailto:ingemar.s.johansson=[email-masked]>> wrote:
>  
> Hi
>  
> From: Anna Brunström <[email-masked] <mailto:[email-masked]>> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 21 Nov 2019 10:06:37 +0000

OK, great!

/Ingemar

From: Colin Perkins <[email-masked]> 
Sent: den 21 november 2019 03:35
To: Ingemar Johansson S <ingemar.s.johansson=[email-masked]>
Cc: Ingemar Johansson S <[email-masked]>; [email-masked]; Anna Brunstrom <[email-masked]>
Subject: Re: [rmcat] How to handle remaining milestones

Hi Ingemar,

Colin

On 20 Nov 2019, at 18:56, Ingemar Johansson S <ingemar.s.johansson=[email-masked] <mailto:ingemar.s.johansson=[email-masked]> > wrote:

OK  

/Ingemar

From: Colin Perkins <[email-masked] <mailto:[email-masked]> > 
Sent: den 20 november 2019 06:05
To: Ingemar Johansson S <[email-masked] <mailto:[email-masked]> >
Cc: Anna Brunstrom <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; Ingemar Johansson S <[email-masked] <mailto:[email-masked]> >
Subject: Re: [rmcat] How to handle remaining milestones

Hi Ingemar,

Colin

On 19 Nov 2019, at 18:39, Ingemar Johansson S < <mailto:ingemar.s.johansson=[email-masked]> ingemar.s.johansson=[email-masked]> wrote:

Hi

/Ingemar

From: Anna Brunström < <mailto:[email-masked]> [email-masked]> 
Sent: den 18 november 2019 15:47
To:  <mailto:[email-masked]> [email-masked]
Subject: [rmcat] How to handle remaining milestones

Dear all,

Best Regards,
Anna (for the chairs)

Professor Anna Brunstrom

Karlstad University

651 88 Karlstad, Sweden

Phone:   +46 54 7001795

-- 
Colin Perkins
https://csperkins.org/ <https://protect2.fireeye.com/v1/url?k=57ad173e-0b791f97-57ad57a5-865b3b1e120b-5e9570d91b85ec39&q=1&e=7cc68b02-6e14-481a-ab2c-c944a9f5694b&u=https%3A%2F%2Fcsperkins.org%2F>