Subject: [Rmt] Extended attributes

From: "Lindholm Roger" <[email-masked]>
Date: Sat, 4 Oct 2003 15:15:42 +0200

Hello,
I have just read the FLUTE specification and thinks it's a great step forward. I worked in a project a couple of years ago that developed a similar thing but propriatary. A couple of things that we needed that I can't see in the FLUTE or in any discussions on the mailinglist is a standard way to describe extended file attributes like Read only, Hidden, System and Archive. 
 
It would also be nice to be able to specify security related things like ACL/Rights, Owner, Group and Auditing when used in a controlled security domain even if this is probably harder to express in a OS independent way.

I understand that some of these attributes are OS dependent, but it would still be nice to have a standardized way to describe them for interoperability instead of letting each implementor chose their own syntax.
 
Best regards
Roger Lindholm

---

From: Justin Chapweske <[email-masked]>
Date: Sat, 04 Oct 2003 10:06:50 -0500

IMO, these types of attributes should be preserved by a file archival 
format, like tar, and not a transport protocol.

The transport protocol should aim to provide meta-data that is 
equivilent to what you would receive via HTTP.

-Justin

Lindholm Roger wrote:
> Hello,
> I have just read the FLUTE specification and thinks it's a great step 
> forward. I worked in a project a couple of years ago that developed a 
> similar thing but propriatary. A couple of things that we needed that I 
> can't see in the FLUTE or in any discussions on the mailinglist is a 
> standard way to describe extended file attributes like Read only, 
> Hidden, System and Archive.
>  
> It would also be nice to be able to specify security related things like 
> ACL/Rights, Owner, Group and Auditing when used in a controlled security 
> domain even if this is probably harder to express in a OS independent way.
> I understand that some of these attributes are OS dependent, but it 
> would still be nice to have a standardized way to describe them for 
> interoperability instead of letting each implementor chose their own syntax.
>  
> Best regards
> Roger Lindholm

-- 
Justin Chapweske, Onion Networks
http://onionnetworks.com/

_______________________________________________
Rmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rmt