Subject: [Rmt] EXP2ST: FLUTE, ALC and LCT need to explicitly allow simple broadcast

From: [email-masked]
Date: Tue, 28 Jun 2005 18:32:01 +0300

I raised the issue of manditory congestion control (CC) for any and every LCT and ALC deployment a long time ago (3 years?) and Mike wisely suggested raising it again in the great EXP exodus, so in brief...

For fully provisioned (congestion control below transport layer) systems, especially unidirectional multicast links to client end-points, there are very good use cases for LCT/ALC/FLUTE. I guess going into detail of the IP Datacast/broadcast use cases is redundant in this WG.

Hence, 3GPP have adopted FLUTE without any RMT defined congestion control for their MBMS (cellular multicast) system. DVB, OMA (and other cryptic acronym stnadardisation bodies and WGs) are also well on their way to using FLUTE in the same way.

Naturally, this is not the general public Internet where RMT CC would be essential to prevent meltdown, but it is IP, UDP and RMT specifications.

LCT and ALC are ambiguous over whether their use without RMT CC is allowed in any form. I would like it made explicit that in these broadcast cases it is allowed.

If everyone is happy with this, I'll suggest some spec text (I guess I pointed out the appropriate LCT and ALC sections 3 years ago - unforunately long before my google desk top took the pain out finding such gems of history).

Cheers, Rod.

_______________________________________________
Rmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rmt

---

From: "Michael Luby" <[email-masked]>
Date: Wed, 29 Jun 2005 10:35:34 -0700

I'm happy with this.  BTW Rod, if you need to find some old correpondence, I
am a data pack rat, so I can find it if you really want.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Tuesday, June 28, 2005 8:32 AM
> To: [email-masked]
> Subject: [Rmt] EXP2ST: FLUTE,ALC and LCT need to explicitly allow simple
> broadcast
>
>
> I raised the issue of manditory congestion control (CC) for any
> and every LCT and ALC deployment a long time ago (3 years?) and
> Mike wisely suggested raising it again in the great EXP exodus,
> so in brief...
>
> For fully provisioned (congestion control below transport layer)
> systems, especially unidirectional multicast links to client
> end-points, there are very good use cases for LCT/ALC/FLUTE. I
> guess going into detail of the IP Datacast/broadcast use cases is
> redundant in this WG.
>
> Hence, 3GPP have adopted FLUTE without any RMT defined congestion
> control for their MBMS (cellular multicast) system. DVB, OMA (and
> other cryptic acronym stnadardisation bodies and WGs) are also
> well on their way to using FLUTE in the same way.
>
> Naturally, this is not the general public Internet where RMT CC
> would be essential to prevent meltdown, but it is IP, UDP and RMT
> specifications.
>
> LCT and ALC are ambiguous over whether their use without RMT CC
> is allowed in any form. I would like it made explicit that in
> these broadcast cases it is allowed.
>
> If everyone is happy with this, I'll suggest some spec text (I
> guess I pointed out the appropriate LCT and ALC sections 3 years
> ago - unforunately long before my google desk top took the pain
> out finding such gems of history).
>
> Cheers, Rod.
>