Subject: RE: [rohc] Problems of implementating ROHC(RFC3095) on 802.11 WLA N

From: "Lars-Erik Jonsson (EPL)" <[email-masked]>
Date: Thu, 13 Jun 2002 15:33:36 +0200

Hi Wang,

> o   The CID is allocated by the compressor. But how to make 
> it an unique identifier at the de-compressor side? Because the WLAN 
> is a shared layer 2 linker. All the mobile nodes share the same 
> channel within a WLAN. If more than one mobile nodes send ROHC packet to 
> one access router which will do de-compression, how to make the CIDs 
> allocated by different mobile nodes be different?

ROHC assumes logical point-to-point channels, which can be created by
using e.g. link addressing in a shared media environment.

> o   The compressed packets' size may become less than 60 
> bytes. 60 bytes is the minimun size of a ethernet frame.  So if the
> size of a compressed packet is less than 60, it cannot be transefer
> in the ethernet.

ROHC padding might be used for this purpose.

> In fact, the Wireless LAN is a broad band wireless environment.
> We do not need to use ROHC. But I think the RFC3095 should consider 
> these problems.

Well, RFC 3095 does not consider this since logical point-to-point
channels are assumed. It might be useful to elaborate a little bit
more about that when we cycle the RFC for Drafts Standard. Still,
what you ask for is more of an issue for a "ROHC over X"-document,
if X is not by nature a point-to-point link.

Cheers,
/L-E 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Wang Hui <[email-masked]>
Date: Fri, 14 Jun 2002 23:51:10 +0800 (CST)

Thanks for Jonsson's reply.

> using e.g. link addressing in a shared media environment.

Yes, it seems that we have to do like this.

> ROHC padding might be used for this purpose.

Since the minimun frame size is moderate big, we have to do padding with a
lot of packets especially when we send small packet (eg. VoIP packets)
often.  Could we choose that we dont do ROHC in such a case?

> if X is not by nature a point-to-point link.

Yes, I guess maybe after our expierence of implementing ROHC on 802.11b,
we might write a draft as 'ROHC over 802.11b'.  Then we can discuss these
issues in more detailed level.

Best regards,
Wang

--
 Wang Hui
 Next Generation Internet Research Team,
 InfoNet Lab, USTC
 http://mail.ustc.edu.cn/~whui
 Tel: +86-551-3603634