Subject: RE: [rohc] IPv6 deployment in profile 2 and 4

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Mon, 22 Jul 2002 12:12:52 +0200

Hi Ana and others,

First an important note. Profile 4 has not yet been defined, there 
is a proposal available but that does not mean the profile will look
that way when it is finalized.

Anyway, back to the original question. If a format is used for IPv6,
which has an IP ID field, that could be set to any value since it 
would not be used by the decompressor.

If you have more specific questions about certain formats, please
refer to the exact format (there are several formats, e.g. TS or ID).

BR
/L-E

> -----Original Message-----
> From: Ana Carolina Minaburo
> [mailto:[email-masked]]
> Sent: den 22 juli 2002 10:03
> To: ROHC
> Subject: [rohc] IPv6 deployment in profile 2 and 4
> 
> 
> Hi!
> 
> When using IPv6 with profile 2 and 4 the field IP-ID in R-1 and UO-1 
> packets does not exist in the original IPv6 header then which 
> could be 
> the possible value in these packets type for this field?
> 
> Ana
> 
> 
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Ana Carolina Minaburo <[email-masked]>
Date: Mon, 22 Jul 2002 16:01:11 +0200

Hi,

>that way when it is finalized.
Ok, as in your draft description profile 4 seams to be similar to 
profile 2, then normally you use the same packets types with the same 
fields.

>would not be used by the decompressor.
Ok, but perhaps it is better do not send it. Perhaps I am wrong but if 
it is not needed is better do not send it.

Also for example for IPv6 you could  reduce the SN number in one bit and 
with this reduce the header size to 1 byte or perhaps add some bits to 
the CRC and SN bits and then send more useful information?  

OR another proposition could be send the mode of operation, in profile 1 
you send the mode of operation in the RTP dynamic part. Then when you 
describe the profile 2 you do not include the mode in any dynamic part, 
then for profile 4 you have the same problem?

>refer to the exact format (there are several formats, e.g. TS or ID).
Yes there are several formats in profile 1 but only one for IPv6.

Thank you for your comments,
Ana