Subject: [rohc] LZSS, LZ77 and LZW byte Code

From: [email-masked]
Date: Fri, 16 Aug 2002 16:52:28 -0500

Hi,
   I'm attaching the output of my assembler (supposed to generate minimum encoding byte code) for mnemonic code algorithms described in Sigcomp User Guide. At this point i'm attaching  the output of LZ77, LZW and LZW. Based upon your feedback, i will generate byte codes for DEFLATE, LZJH etc. Note that all values of the bytecode are in hexadecimal format. 
	Please test the byte code with your UDVMs and let me know the results. 

thanks,
Narendra <<UG_LZ77.txt>>  <<UG_LZSS.txt>>  <<UG_LZW.txt>>

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 17 Aug 2002 16:37:31 +0200

Narendra,

this is interesting.
I haven't checked your binary code yet, but let me make one observation:
At the end of the assembly, you can normally squash trailing zero bytes (as well 
as leading ones, if there is a number that can be expressed in the sigcomp header).
This would make your code pieces much smaller, so they are more representative 
of what actually will be transmitted.

Gruesse, Carsten

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc