Subject: RE: [rohc] SigComp: CRC

From: Adam Roach <[email-masked]>
Date: Mon, 5 Aug 2002 19:26:43 -0500

> -----Original Message-----
> From: Surtees, Abigail [mailto:[email-masked]]
>
> We have achieved interoperation with other 
> implementers so presumably they do LSB first too.  Carsten? Adam?
> 
> For reference over the data:
> 01 02 03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f 10 11 12 13 14 
> 15 16 17 18 80 81 82 83 84 85 86 87 88 89 8a 8b 8c 8d 8e 8f 
> 90 91 92 93 
> 
> the 16 bit LSB crc is 62cb 
> and the 16 bit MSB crc is 696.

Like Carsten, I interpreted the SigComp definition to mean "just like PPP".
My result for your set of data is 0x62CB.

So, I second Mark's suggestion that we officially say "we do exactly the
same thing as 1662."

/a

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Wed, 7 Aug 2002 15:29:55 +0100

> Like Carsten, I interpreted the SigComp definition to mean 
> "just like PPP". My result for your set of data is 0x62CB.
> 
> So, I second Mark's suggestion that we officially say "we do 
> exactly the same thing as 1662."
> 
> /a

I third Mark's suggestion. RFC 1662 has a detailed explanation
of its version of the CRC calculation, so we should take advantage
of this to improve the clarity of the SigComp RFC. We also avoid
needing to modify all of the existing implementations of SigComp.

Regards,

Richard