Subject: [rohc] Sigcomp Assembler interoperability tests.

From: [email-masked]
Date: Mon, 12 Aug 2002 17:56:38 -0500

Hi,
  we have a sigcomp assembler that generates byte code(minimum encoding) from the mnemonic code and we would like to conduct interoperability tests on it. Can anyone provide us mnemonic code and it's corresponding byte code ( with minimal encoding). It's fine even if one can provide us mnemonic code; we will send you the byte code generated by my assembler back.

thanks,
narendra

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lajos Zaccomer (ETH)" <[email-masked]>
Date: Tue, 13 Aug 2002 10:41:01 +0200

Hi Narenda,

We have a series tests for the UDVM instructions, and there are the decompressors in the SigComp User Guide. Of course the tests are very simple, they may be a good start for testing your assembler. I can provide you the generated bytecodes as well, however, the current encoding is not always optimal depending on the structure of the mnemonic code.
I attach the list of the test purposes (the User Guide you already know), and you may choose what mnemonic codes and/or generated bytecodes to send.

Regards,

Zacco

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, August 13, 2002 12:57 AM
To: [email-masked]
Subject: [rohc] Sigcomp Assembler interoperability tests.

Hi,

thanks,
narendra

---

From: [email-masked]
Date: Tue, 13 Aug 2002 18:26:22 -0500

Hi Zacco,
      I would like to have  tc022, tc015 test cases. Actually, i want to test the assembler (byte code generator) rather than UDVM. Anyway, i will generate byte code for decoding algorithms described in sigcomp user guide and post them for verification.

-Narendra

-----Original Message-----
From: ext Lajos Zaccomer (ETH) [mailto:[email-masked]]
Sent: 13 August, 2002 03:41 AM
To: Chaparala Narendra (EXT-NRC/Dallas)
Cc: [email-masked]'
Subject: RE: [rohc] Sigcomp Assembler interoperability tests.

Hi Narenda,

Regards,

Zacco

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, August 13, 2002 12:57 AM
To: [email-masked]
Subject: [rohc] Sigcomp Assembler interoperability tests.

Hi,

thanks,
narendra

---

From: "Lajos Zaccomer (ETH)" <[email-masked]>
Date: Thu, 15 Aug 2002 17:31:01 +0200

Hi Narenda,

You might have missed the input data. Here they are:

; --- 0 - 143 ---
;   0 = 0x0000 ~> [0011][0000] => 0x30
;  77 = 0x004D ~> [0111][1101] => 0x7D
; 143 = 0x008F ~> [1011][1111] => 0xBF
; --- 144 - 255 ---
; 144 = 0x0090 ~> [1100][1000][0 => 0xC8
; 204 = 0x00CC ~> 111][0011][00 => 0x73
; 255 = 0x00FF ~> 11][1111][111 => 0x3F
; --- 256 - 279 ---
; 256 = 0x0100 ~> 0][0000][00 => 0xE0
; 265 = 0x0109 ~> 00][0100][1 => 0x04
; 279 = 0x0117 ~> 001][0111] => 0x97
; --- 280 - 287 ---
; 280 = 0x0118 ~> [1100][0000] => 0xC0
; 284 = 0x011C ~> [1100][0100] => 0xC4
; 287 = 0x011F ~> [1100][0111] => 0xC7

;DATA 0x30, 0x7D, 0xBF, 0xC8, 0x73, 0x3F, 0xE0, 0x04, 0x97, 0xC0, 0xC4, 0xC7;

(I removed them from the test, because it was not needed to generate the bytecode. Sorry, if it mislead you.) 

Does your assembler follow the notation of the UG? If not, I may send you our rewritten version if it helps.

Regards,

Zacco

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, August 15, 2002 12:07 AM
To: [email-masked]
Subject: RE: [rohc] Sigcomp Assembler interoperability tests.

Hi Zacco,
  thanks for sharing the info.  But i had problems intrepreting the tc015.asm. I could not follow the objective of the test. I see a series of INPUT_HUFFMAN instructions. 
   anyway, my assembler showed some bugs with sigcomp user guide lz77. I will gte back to you once i fix that.

-narendra

-----Original Message-----
From: ext Lajos Zaccomer (ETH) [mailto:[email-masked]]
Sent: 14 August, 2002 01:28 AM
To: Chaparala Narendra (EXT-NRC/Dallas)
Subject: RE: [rohc] Sigcomp Assembler interoperability tests.

Hi Narenda,

Here they are! You may have to rephrase the codes, because my developer fellow constructed his parser before the issue of the UG. I commented the instructions that are specific to our implementation (as you may see thay are for debug purposes). This way the tests become dummy, but in your case this is not very important. Later on I would like to extend the test suite with more complex ones and negative tests as well, if I have time, which may be of use to you, too.

If you are ready, send the bytecodes and I will compare the results. If you send me UG bytecodes, you should know, that our assembler does not support the following instructions (at the moment):
- .pad
- .align
- .byte
These can be easily substituted by labels. And the following four symbols are predefined in the assembler's symbol table, which may result in some further difference in the codes.
    byte_copy_left = 64;
    byte_copy_right = 66;
    input_bit_order = 68;
    stack_location = 70;
If these make comparison difficult, we may return to it soon with our comformized assembler.

Regards,

Zacco

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, August 14, 2002 1:26 AM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [rohc] Sigcomp Assembler interoperability tests.

Hi Zacco,

-Narendra

-----Original Message-----
From: ext Lajos Zaccomer (ETH) [mailto:[email-masked]]
Sent: 13 August, 2002 03:41 AM
To: Chaparala Narendra (EXT-NRC/Dallas)
Cc: [email-masked]'
Subject: RE: [rohc] Sigcomp Assembler interoperability tests.

Hi Narenda,

Regards,

Zacco

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, August 13, 2002 12:57 AM
To: [email-masked]
Subject: [rohc] Sigcomp Assembler interoperability tests.

Hi,

thanks,
narendra