Subject: [rohc] UDVM memory size

From: [email-masked]
Date: Mon, 11 Nov 2002 10:49:01 -0600

Hi,
  I just want to clarify the amount of memory allocated for UDVM when a sigcomp message with uploaded byte code is received. By default, remote endpoint offers 2k memory and let the sigcomp message size is 1003 bytes.3 bytes are for sigcomp header, 500 bytes for byte code and 500 bytes for compressed message. Is the memory allcated for UDVM is (2048 - 1003) = 1045  bytes or (2048 - 503) = 1545. 503 implies 3 bytes for header and 500 bytes for compressed message.
   So, my question is, does byte code size is included in calculating the amount of memory available to UDVM? I wanted to know how sigcomp implementors calculated the memory size for UDVM. 

-Narendra
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Wed, 13 Nov 2002 17:18:36 -0000

Hi,

The memory allocated to the UDVM is the decompression_memory_size
minus the size of the entire SigComp message (which in your
example gives an answer of 1045 bytes). This approach costs
a few hundred extra bytes of memory due to storing two copies of
the UDVM bytecode: however we didn't consider this to be
enough of a problem to warrant a more complex solution.

Regards,

Richard

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Monday, November 11, 2002 4:49 PM
> To: [email-masked]
> Subject: [rohc] UDVM memory size
> 
> 
> Hi,
>   I just want to clarify the amount of memory allocated for 
> UDVM when a sigcomp message with uploaded byte code is 
> received. By default, remote endpoint offers 2k memory and 
> let the sigcomp message size is 1003 bytes.3 bytes are for 
> sigcomp header, 500 bytes for byte code and 500 bytes for 
> compressed message. Is the memory allcated for UDVM is (2048 
> - 1003) = 1045  bytes or (2048 - 503) = 1545. 503 implies 3 
> bytes for header and 500 bytes for compressed message.
>    So, my question is, does byte code size is included in 
> calculating the amount of memory available to UDVM? I wanted 
> to know how sigcomp implementors calculated the memory size for UDVM. 
> 
> -Narendra