Subject: [rohc] Question about ROHC TS encoding at wrap around

From: "Sarkar, Rajib" <[email-masked]>
Date: Tue, 19 Nov 2002 13:25:29 -0800

Hi,

    I have a question about ROHC scaled TS encoding at wrap around
(basically section 4.5.3, point 5)

    Lets say for scaled TS 26843545 I send last 4 bits (k=4) to the
decompressor 1001. Also assume that TS_STRIDE=160. The next scaled TS is 2.
Now do I need to do anything special or if still my k=4, I just send 0010?
In that case values from 1010 to 1111 are still in interpretation interval,
but never used.

Thanks

Rajib

---

From: "Sarkar, Rajib" <[email-masked]>
Date: Wed, 20 Nov 2002 08:55:28 -0800

Hi,

    I got the idea what to do. However, it is still not clear to me why we
need to do such thing? Lets say in the first example (when a =4), what will
be the problem if we send just 4 LSBs (1001) and not the b LSBs (b=5)? My
second question is do we need to apply this algorithm for only when
v=TSS_MAX or every time when TSS_MAX is in the interpretation interval?

Thanks for your explanation.

Rajib

-----Original Message-----
From: Anton Mårtensson (EAB) [mailto:[email-masked]]
Sent: Wednesday, November 20, 2002 2:30 AM
To: 'Sarkar, Rajib'
Cc: [email-masked]'
Subject: RE: [rohc] Question about ROHC TS encoding at wrap around

Hi Rajib,
That is true that values from 1010 to 1111 in the interpretation interval
will not be used (if you are using the same 
number of bits during the interval as before, 4 bits). That is why we have
the wrap-around rule in
Section 4.5.3, point 5. If we want to keep the robustness during the
wrap-around we need to send more
bits when TSS_MAX is in the interpretation interval. So how many bits do I
need (please see the rule in point 5)?
a = 4
TSS_MAX LSBs = 10011001
Point 5 says that a (a=4) LSBs of TSS_MAX should be set to zero = 10010000
If you compare this value with 0 (00000000) you will get that you need to
send
at least 5 bits during the wrap (since the 5th bit (from right) is the first
bit set to 1.
 
Another example:
Assume that you are using 5 bits instead of 4 before the wrap (a=5). I this
case we need to set 
the 5 LSBs of TSS_MAX to zero (10000000). If we compare it to 00000000 we
get 
that we need to use 8 bits (the 8th bit from the right differs) during the
wrap to keep the same robustness.
 
I hope this helped!
 - Anton

 -----Original Message-----
From: Sarkar, Rajib [mailto:[email-masked]]
Sent: den 19 november 2002 22:25
To: [email-masked]'
Subject: [rohc] Question about ROHC TS encoding at wrap around

Hi,

Thanks

Rajib

---

From: Anton Mårtensson (EAB)<[email-masked]>
Date: Thu, 21 Nov 2002 12:49:16 +0100

Hi,
If you want to keep the robustness against packet losses during the wrap
you need to apply the algorithm.
In your example:
For RTP SN with 4 bits the interpretation interval is [-3 12] (see 5.7 and 4.5.1), i.e. it can handle
up to 11 packet losses without loss of synchronization (if not in wrap-mode). The problem is when
TSS_MAX is within the interpretation interval, since 6 values in the interval are not valid (1010-1111).
In this case we can only handle 5 losses without sync loss, i.e. the robustness against losses
has bin reduced. But if you use more bits during the wrap it is possible to keep the robustness level.
 
You second question:
You need to apply the rule every time TSS_MAX is in the interpretation interval.
 
 - Anton

-----Original Message-----
From: Sarkar, Rajib [mailto:[email-masked]]
Sent: den 20 november 2002 17:55
To: 'Anton Mårtensson (EAB)'
Cc: [email-masked]'
Subject: RE: [rohc] Question about ROHC TS encoding at wrap around

Hi,

    I got the idea what to do. However, it is still not clear to me why we need to do such thing? Lets say in the first example (when a =4), what will be the problem if we send just 4 LSBs (1001) and not the b LSBs (b=5)? My second question is do we need to apply this algorithm for only when v=TSS_MAX or every time when TSS_MAX is in the interpretation interval?

Rajib

-----Original Message-----
From: Anton Mårtensson (EAB) [mailto:[email-masked]]
Sent: Wednesday, November 20, 2002 2:30 AM
To: 'Sarkar, Rajib'
Cc: [email-masked]'
Subject: RE: [rohc] Question about ROHC TS encoding at wrap around

Hi Rajib,
That is true that values from 1010 to 1111 in the interpretation interval will not be used (if you are using the same 
number of bits during the interval as before, 4 bits). That is why we have the wrap-around rule in
Section 4.5.3, point 5. If we want to keep the robustness during the wrap-around we need to send more
bits when TSS_MAX is in the interpretation interval. So how many bits do I need (please see the rule in point 5)?
a = 4
TSS_MAX LSBs = 10011001
Point 5 says that a (a=4) LSBs of TSS_MAX should be set to zero = 10010000
If you compare this value with 0 (00000000) you will get that you need to send
at least 5 bits during the wrap (since the 5th bit (from right) is the first bit set to 1.
 
Another example:
Assume that you are using 5 bits instead of 4 before the wrap (a=5). I this case we need to set 
the 5 LSBs of TSS_MAX to zero (10000000). If we compare it to 00000000 we get 
that we need to use 8 bits (the 8th bit from the right differs) during the wrap to keep the same robustness.
 
I hope this helped!
 - Anton

 -----Original Message-----
From: Sarkar, Rajib [mailto:[email-masked]]
Sent: den 19 november 2002 22:25
To: [email-masked]'
Subject: [rohc] Question about ROHC TS encoding at wrap around

Hi,

    I have a question about ROHC scaled TS encoding at wrap around (basically section 4.5.3, point 5)

    Lets say for scaled TS 26843545 I send last 4 bits (k=4) to the decompressor 1001. Also assume that TS_STRIDE=160. The next scaled TS is 2. Now do I need to do anything special or if still my k=4, I just send 0010? In that case values from 1010 to 1111 are still in interpretation interval, but never used.

Thanks

Rajib