Subject: [rohc] SigComp: question about STATE-CREATE

From: Zoltan Barczikay <[email-masked]>
Date: Thu, 14 Nov 2002 18:25:50 +0100 (MET)

Hello,

the draft says in 9.4.6 that when the STATE-CREATE instruction is encountered, 
only its five operands are buffered, and the actual state value is saved only at 
END-MESSAGE.

Is this correct? That is, the state value can get overwritten between the 
STATE-CREATE and END-MESSAGE, so the saved state value will be different than 
expected.

Or should I copy the state value to a buffer at STATE-CREATE, so that it is not 
modified by subsequent UDVM instructions?

Thanks in advance for your help.

/Zoltan Barczikay.

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: [email-masked]
Date: Thu, 14 Nov 2002 18:09:11 -0600

Hi zoltan,
   Your understanding that state value could be overwritten between STATE_CREATE and END_MESSAGE is correct. The compressor cannot assume temporary buffers; it has to operate under default decompression memory sizes or advertised decompression memory sizes which is divided between UDVM  and storing sigcomp message. 

Regards,
Narendra

-----Original Message-----
From: ext Zoltan Barczikay [mailto:[email-masked]]
Sent: 14 November, 2002 11:26 AM
To: [email-masked]
Subject: [rohc] SigComp: question about STATE-CREATE

Hello,

/Zoltan Barczikay.