Subject: [rohc] SN encoding problem

From: "Sarkar, Rajib" <[email-masked]>
Date: Tue, 26 Nov 2002 16:42:25 -0800

Hi,
	I am trying to encode a SN 0x1f with respect to v_ref 0x10.
	Now as the number of bits in SN is 5, so my p is 2^(5-5) - 1 = 0
	So with 4 bits my interpretation interval is 10 to 1f
	I send this 4 bits in UO-0 packet
	The receiver receives it and calculates  p=1 bits(SN) <=4 ---- Step
1
	Now for the decompressor the interpretation interval becomes f to 1E
	Is there any problem with my logic, I think I did some mistake in
Step 1
	Any help!!!!
Thanks
Rajib
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lalit Kumar Bhasin" <[email-masked]>
Date: Wed, 27 Nov 2002 11:47:16 +0530

Hi Rajib,

----- Original Message ----- 
From: "Sarkar, Rajib" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, November 27, 2002 6:12 AM
Subject: [rohc] SN encoding problem

> Now as the number of bits in SN is 5, so my p is 2^(5-5) - 1 = 0
The valus of p at compressor =  1 and using this value of p,  k comes
out to be  5. 
( The value of p can never be 0 for SN since the value of SN  is
always increasing;  refer  4.5.1 rfc 3095)

> So with 4 bits my interpretation interval is 10 to 1f

So with 5 bits, your interpretation interval becomes (0x09, 0x2E)

> The receiver receives it and calculates  p=1 bits(SN) <=4 ---- Step

With k = 5 ( > 4),  the p calculated at decompressor = -1 

> Now for the decompressor the interpretation interval becomes f to 1E

The interpretation interval at decompressor becomes 
        (0x10 + 1, 0x10 + 1 - 1 + 2^5) = (0x11, 0x30)
and 1F lies in this interpretation interval. 

> Is there any problem with my logic, I think I did some mistake in

Regds,
Lalit