Subject: [rohc] IP HC - rfc 2507 question

From: Haim Ben-lulu <[email-masked]>
Date: Tue, 05 Nov 2002 15:35:37 +0200

Hi

I hope that this is the right place to ask beginner question about IPHC.

In a non-TCP header compression , there is a RANDOM field which can 
include the Identification field and/or data from Option field In IPv4, 
or extension headers in IPv6.
I want to write a sw program to parse Non TCP IPHC , but i didn't find 
in the rfc how can I know the IPHC length !! if the RANDOM field is a 
dynamic field and can vary from 2 bytes to .....
Is the RANDOM field size need to be negotiate in the Setup phase ?

Thank in advance

-- 
Regards,
Haim
-----------------------------------
Haim B.L
System & Design engineer
Motorola semi-conductor

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Yang Chang" <[email-masked]>
Date: Wed, 6 Nov 2002 09:53:52 +0800

Dear Haim,

In IPHC, you have to get a FULL_HEADER to know what are subheaders in a flow before you could decompress succeeding compressed packets in this flow. That is to say, you can imply what RANDOM fields will be in compressed header from the FULL_HEADER that you have already got. If there is unpredictable changes happening, the IPHC compressor need to send a FULL_HEADER to refresh decompressor.

I wish this could be helpful to you!

Best regards,

YANG Chang

Panasonic Singapore Laboratories

---

From: "Mikael Degermark" <[email-masked]>
Date: Wed, 6 Nov 2002 12:51:12 -0700

Hello Haim, 

The size ultimately depends on the MAX_HEADER parameter, 
the negotiation of which is defined in RFC 2509. 

Without observing this negotiation, it is hard to know what the 
size is. One might be able to deduce it by comparing the FULL_HEADER
sizes with the compressed header sizes in some fashion, but I
haven't figured out how to do that in a reliable manner. 

Cheers, 

Micke