Subject: RE: [rohc] ROHC-TCP and EPIC-LITE

From: "Surtees, Abigail" <[email-masked]>
Date: Mon, 11 Nov 2002 09:47:02 -0000

Hi Julije, William,

The working group has agreed that this approach to header compression can be split into
- a formal notation for describing a protocol header and 
- the encoding rules for mapping from the compressed information to 'bits on the wire' (defining packet formats e.g. EPIC-lite).  
The formal notation is deliberately abstract from an implementation, to give maximum implementation freedom.  The key issue is interoperability, which means having a formal definition of what the mappings between compressed and uncompressed field values mean.

I'm not sure what you mean by PEBBLE/ROHC and PEBBLE/EPIC-lite?  EPIC-lite is an algorithm for generating packet formats from a formal description.  ROHC encompasses a complete framework for compression, as well as a number of profiles.  EPIC-lite is one possible way of generating the packet formats to go with a particular profile in this framework, so there is no 'choice' between ROHC and EPIC-lite.

The current focus of work is on the notation, because without that it is difficult to define packet formats (or the means of generating them).  The packet format generation is a relatively small part of the whole process.  As work is ongoing and the current focus is the notation, it would be better to comment on and implement the formal notation for parsing and compressing field values, and then put the packet generation on afterwards when that has been agreed.

Best regards,

Abbie

>-----Original Message-----
>From: Julije Ozegovic [mailto:[email-masked]]
>Sent: 08 November 2002 13:26
>To: william zheng
>Cc: [email-masked]
>Subject: Re: [rohc] ROHC-TCP and EPIC-LITE
>
>
>Hi William,
>
>PEBBLE is official IETF draft, it is concerned for draft 
>standardization as RFC, and future implementations should 
>consider PEBBLE.
>
>However, PEBBLE is syntax-only specification, it does not imply 
>actual implementation model, like EPIC-Lite does. So, to make 
>functional implementation, you must choose PEBBLE/ROHC or 
>PEBBLE/EPIC-Lite model. Or, to wait until whole situation clears 
>up. Or to proceed with EPIC-Lite, and later upgrade with PEBBLE 
>preprocessing.
>
>Best regards,
>Julije Ozegovic
>
>
>---------------------------
>Julije Ozegovic, PhD
>University of Split
>FESB Split
>R.Boskovica bb
>Croatia
>tel.++385 21 305725
>mailto:[email-masked]
>http://www.fesb.hr/~julije
>---------------------------
>
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Julije Ozegovic <[email-masked]>
Date: Mon, 11 Nov 2002 11:11:42 +0100

Hi Abbie, William,

this is exactly what I have said: at the moment we do not have 
explicit standard how to implement PEBBLE to actual ROHC or 
EPIC-Lite model, assuming EPIC-Lite is a refinement under the 
ROHC framework.

For interoperability, "bits on the wire" is all that counts!

Best regards,
Julije

Surtees, Abigail wrote:
>>------------------------------------------------------------------------
>>
>>Registered Office: Roke Manor Research Ltd, Siemens House, Oldbury, Bracknell, 
>>Berkshire. RG12 8FZ
>>
>>The information contained in this e-mail and any attachments is confidential to Roke 
>>Manor Research Ltd and must not be passed to any third party without permission. This 
>>communication is for information only and shall not create or change any contractual 
>>relationship.
>