Subject: [rohc] Reporting state saved

From: Chan Kwang Mien <[email-masked]>
Date: Tue, 05 Nov 2002 09:58:21 +0800

hi,

In the sigcomp draft ver 7, after the statehandler has saved a particular 
state, the UDVM reports
back the partial state identifier and its length to the compressor.

Should UDVM also report back the size of the state that is saved ? this is 
because there may be cases
when the state creation request needs more state memory than the total 
state_memory_size of the
compartment. As a result, the state creation request cannot be totally 
satisfied.

Any help is greatly appreciated.

regards,
Kwang Mien

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Tue, 5 Nov 2002 11:42:37 -0000

Hi,

If the state creation request exceeds the total state_memory_size
for the compartment then the state handler saves only the first
(state_memory_size - 64) bytes of state. There's no need to report
back how much state has been saved because the compressor already
knows the state_memory_size of the compartment, and can infer how
much state has been saved just by subtracting 64 from this value.

Regards,

Richard

> -----Original Message-----
> From: Chan Kwang Mien [mailto:[email-masked]]
> Sent: Tuesday, November 05, 2002 1:58 AM
> To: [email-masked]
> Subject: [rohc] Reporting state saved
> 
> 
> hi,
> 
> In the sigcomp draft ver 7, after the statehandler has saved 
> a particular state, the UDVM reports back the partial state
> identifier and its length to the compressor.
> 
> Should UDVM also report back the size of the state that is 
> saved ? this is because there may be cases when the state
> creation request needs more state memory than the total 
> state_memory_size of the compartment. As a result, the state
> creation request cannot be totally satisfied.
>