Subject: [rohc] Question on ROHC segmentation

From: "Soyoung Lee" <[email-masked]>
Date: Tue, 26 Nov 2002 16:36:46 +0900

Dear ROHC experts,

I have a question on ROHC segmentation.
In my understanding, ROHC segmentation happens when the packet size is larger than the maximum packet size in Packet Size Allowed Set.
And padding is added more commonly to make a proper packet size.

For example, 
Packet Size Allowed Set = { 2, 4, 20, 60, 255}

1) when the packet size is 40 in compressor, the 20 byte padding will be added to build up 60byte size.
Is it right? Also, in this case, can the 40 byte packet be segmented to two 20 bytes packet? 

2) when the packet size is 300 in compressor, the packet is segmented to one 255 bytes packet and one 20 byte packet which is added 15 byte padding.
Is it right operation?

Thanks in advance.

 ===========================
  Soyoung Lee
  LG Electronics Inc. Korea

  e-mail: [email-masked]
  phone: +82-31-450-7859
  fax: +82-31-450-7912
===========================
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lalit Kumar Bhasin" <[email-masked]>
Date: Tue, 26 Nov 2002 13:34:40 +0530

----- Original Message ----- 
From: "Soyoung Lee" <[email-masked]>
To: "ROHC" <[email-masked]>
Sent: Tuesday, November 26, 2002 1:06 PM
Subject: [rohc] Question on ROHC segmentation

> Is it right? Also, in this case, can the 40 byte packet be segmented to two 20 bytes packet? 
Yes, 40 bytes  ROHC pkt would be padded to 60 bytes size with 20 bytes of padding

 40 bytes ROHC packet would be segmented into 20 bytes ( first 19 bytes of ROHC pkt + 1 Segmentation  octet ) , 20 bytes ( next 19 bytes for ROHC pkt  + 1 Segmentation  octet), and 20 bytes ( last 2 bytes of ROHC pkt + 5 Segmentation octet including FCS-CRC + 13 Padding octet).

> 2) when the packet size is 300 in compressor, the packet is segmented to one 255 bytes packet and one 20 byte packet which is added 15 byte padding.

The Packet is segmented in to one 255 bytes packet ( having first 254 bytes from ROHC pkt + 1 Seg octet) and one 60 bytes packet ( last 46 bytes from ROHC pkt + 5 segmentation octets including fcs-crc + 9 padding octets)