Subject: Re: [rohc] SN encoding problem

From: "Lalit Kumar Bhasin" <[email-masked]>
Date: Wed, 27 Nov 2002 11:55:55 +0530

Hi Rajib,
  Some modification in calculating interpretation interval at decompressor end ,
  
with k = 5 ( > 4) , the value of p comes out to be 0.
The interpretation interval with k = 5 and p = 0 is (0x10, 0x29)
and 1F lies in this interval.
Regds,
Lalit
  ----- Original Message ----- 
  From: Lalit Kumar Bhasin 
  To: Sarkar, Rajib ; [email-masked] 
  Sent: Wednesday, November 27, 2002 11:47 AM
  Subject: Re: [rohc] SN encoding problem

  Hi Rajib,

  ----- Original Message ----- 
  From: "Sarkar, Rajib" <[email-masked]>
  To: <[email-masked]>
  Sent: Wednesday, November 27, 2002 6:12 AM
  Subject: [rohc] SN encoding problem

  > Hi,
  > I am trying to encode a SN 0x1f with respect to v_ref 0x10.
  > Now as the number of bits in SN is 5, so my p is 2^(5-5) - 1 = 0
  The valus of p at compressor =  1 and using this value of p,  k comes
  out to be  5. 
  ( The value of p can never be 0 for SN since the value of SN  is
  always increasing;  refer  4.5.1 rfc 3095)

  > So with 4 bits my interpretation interval is 10 to 1f

  So with 5 bits, your interpretation interval becomes (0x09, 0x2E)

  > I send this 4 bits in UO-0 packet
  > The receiver receives it and calculates  p=1 bits(SN) <=4 ---- Step
  > 1

  With k = 5 ( > 4),  the p calculated at decompressor = -1 

  > Now for the decompressor the interpretation interval becomes f to 1E

  The interpretation interval at decompressor becomes 
          (0x10 + 1, 0x10 + 1 - 1 + 2^5) = (0x11, 0x30)
  and 1F lies in this interpretation interval. 

  > Is there any problem with my logic, I think I did some mistake in
  > Step 1
  > Any help!!!!
  > Thanks
  > Rajib

  Regds,
  Lalit

  > _______________________________________________
  > Rohc mailing list
  > [email-masked]
  > https://www1.ietf.org/mailman/listinfo/rohc

---

From: [email-masked]
Date: Wed, 27 Nov 2002 10:02:28 -0600

(v_ref = 0x10, v = 0x1F) ==> compressor has to send 5 bits SN

5 bits SN ==> p = 0 ==> interval(0x10, 5) = [0x10, 0x2F]

This means compressor cannot use UO-0. For UO-mode, you can use 
UO-1-ID with extension 0, which gives you 7 bits SN. For R-mode, 
you can use R-0 which gives you 6 bits SN.

See section 4.5.1 for details. Hope this helps.

Zhigang

-----Original Message-----
From: ext Lalit Kumar Bhasin [mailto:[email-masked]]
Sent: November 27, 2002 12:26 AM
To: Sarkar, Rajib; [email-masked]
Subject: Re: [rohc] SN encoding problem

Hi Rajib,
  
----- Original Message ----- 
From: Lalit Kumar Bhasin 
To: Sarkar, Rajib ; [email-masked] 
Sent: Wednesday, November 27, 2002 11:47 AM
Subject: Re: [rohc] SN encoding problem

Hi Rajib,

----- Original Message ----- 
From: "Sarkar, Rajib" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, November 27, 2002 6:12 AM
Subject: [rohc] SN encoding problem

Regds,
Lalit

---

From: "Surtees, Abigail" <[email-masked]>
Date: Wed, 27 Nov 2002 16:21:22 -0000

Hi Lalit, Rajib,
 
I think p should be the same at the decompressor and depends on the number of bits of SN being sent (k).  If p is different at each end then the interpretation intervals are different and though they may overlap, they will not always get the same answer.
 
SN 0x1f with v_ref of 0x10.
 
The compressor has to decide on the value of k.
 
If k = 3 then we have p = 1 according to 5.7. rfc 3095.
 
This gives an interpretation interval of 0x0f ->0x16 inclusive.  This doesn't include 0x1f so is not enough
 
If k = 4 then we have p = 1 
 
This gives an interpretation interval of 0x0f ->0x1e inclusive.  This doesn't include 0x1f so is not enough
 
If k = 5 then we have p = 2^(5-5) - 1 = 0
 
This gives an interpretation interval of 0x10 ->0x2f inclusive.  This includes 0x1f so the number of bits to send is 5.
 
The decompressor receives 5 bits and does the same calculation for p, consequently getting the same interpretation interval.  
 
(Except that according to ROHC packet formats the number of bits of SN is 4 in UO-0 and UO-1 and 6 in UOR-2 so there is no way to send only 5 bits.  In this case 6 bits would have to be sent and received giving p = 2^(6-5)-1 = 1 and an interpretation interval of 0x0f ->0x4e inclusive.  This includes 0x1f and cannot be mistaken for 0x3f because the 6th bit is present and is zero.)
 
I hope this clarifies things.
 
Regards,
 
Abbie
Abbie Surtees 
Engineer 
Internet Applications and Mobility 
Roke Manor Research Ltd 
Tel:   +44 (0) 1794 833131  

 -----Original Message-----
From: Lalit Kumar Bhasin [mailto:[email-masked]]
Sent: 27 November 2002 06:26
To: Sarkar, Rajib; [email-masked]
Subject: Re: [rohc] SN encoding problem

Hi Rajib,

----- Original Message ----- 
From: Lalit  <mailto:[email-masked]> Kumar Bhasin 
To: Sarkar,  <mailto:[email-masked]> Rajib ; [email-masked] <mailto:[email-masked]>  
Sent: Wednesday, November 27, 2002 11:47 AM
Subject: Re: [rohc] SN encoding problem

Hi Rajib,
 
----- Original Message ----- 
From: "Sarkar, Rajib" <  <mailto:[email-masked]> [email-masked]>
To: <  <mailto:[email-masked]> [email-masked]>
Sent: Wednesday, November 27, 2002 6:12 AM
Subject: [rohc] SN encoding problem

 

 

 
Regds,
Lalit

>  <mailto:[email-masked]> [email-masked]
>  <https://www1.ietf.org/mailman/listinfo/rohc> https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Sarkar, Rajib" <[email-masked]>
Date: Wed, 27 Nov 2002 08:35:37 -0800

Hi,
    So it seems my decompressor part's logic is fine, but do I always use p
=1 for SN encoding? In section 5.7 it says 
SN: The compressed RTP Sequence Number.

       Compressed with W-LSB.  The interpretation intervals, see section
       4.5.1, are defined as follows:

            p = 1                   if bits(SN) <= 4
            p = 2^(bits(SN)-5) - 1  if bits(SN) >  4

Is that true for only decompressor? 
Thanks
Rajib

-----Original Message-----
From: Lalit Kumar Bhasin [mailto:[email-masked]]
Sent: Tuesday, November 26, 2002 10:17 PM
To: Sarkar, Rajib; [email-masked]
Subject: Re: [rohc] SN encoding problem

Hi Rajib,
 
----- Original Message ----- 
From: "Sarkar, Rajib" <  <mailto:[email-masked]>
[email-masked]>
To: <  <mailto:[email-masked]> [email-masked]>
Sent: Wednesday, November 27, 2002 6:12 AM
Subject: [rohc] SN encoding problem

 

 

 
Regds,
Lalit

>  <https://www1.ietf.org/mailman/listinfo/rohc>

---

From: "Sarkar, Rajib" <[email-masked]>
Date: Wed, 27 Nov 2002 08:39:28 -0800

I think that helps a lot, I did some miscalculation in finding the
interpretation interval and I figured that out from your explanation, your
explanation clarifies my doubt.<?xml:namespace prefix = o ns =
"urn:schemas-microsoft-com:office:office" />

Thanks

Rajib

[Sarkar, Rajib] 
 -----Original Message-----
From: Surtees, Abigail [mailto:[email-masked]]
Sent: Wednesday, November 27, 2002 8:21 AM
To: 'Lalit Kumar Bhasin'; Sarkar, Rajib; [email-masked]
Subject: RE: [rohc] SN encoding problem

Hi Lalit, Rajib,
 
I think p should be the same at the decompressor and depends on the number
of bits of SN being sent (k).  If p is different at each end then the
interpretation intervals are different and though they may overlap, they
will not always get the same answer.

 
 
This gives an interpretation interval of 0x0f ->0x16 inclusive.  This
doesn't include 0x1f so is not enough

This gives an interpretation interval of 0x0f ->0x1e inclusive.  This
doesn't include 0x1f so is not enough

This gives an interpretation interval of 0x10 ->0x2f inclusive.  This
includes 0x1f so the number of bits to send is 5.
 
The decompressor receives 5 bits and does the same calculation for p,
consequently getting the same interpretation interval.  
 
(Except that according to ROHC packet formats the number of bits of SN is 4
in UO-0 and UO-1 and 6 in UOR-2 so there is no way to send only 5 bits.  In
this case 6 bits would have to be sent and received giving p = 2^(6-5)-1 = 1
and an interpretation interval of 0x0f ->0x4e inclusive.  This includes 0x1f
and cannot be mistaken for 0x3f because the 6th bit is present and is zero.)

Regards,
 
Abbie

Abbie Surtees 
Engineer 

 -----Original Message-----
From: Lalit Kumar Bhasin [mailto:[email-masked]]
Sent: 27 November 2002 06:26
To: Sarkar, Rajib; [email-masked]
Subject: Re: [rohc] SN encoding problem

Hi Rajib,
  Some modification in calculating interpretation interval at decompressor
end ,

----- Original Message ----- 
From: Lalit  <mailto:[email-masked]> Kumar Bhasin 
To: Sarkar, Rajib <mailto:[email-masked]>  ; [email-masked]
<mailto:[email-masked]>  

Hi Rajib,
 
----- Original Message ----- 

 

 

 
Regds,
Lalit