Subject: Re: [rohc] COPY_LITERAL and COPY_OFFSET torture test

From: Mural Kumar <[email-masked]>
Date: Mon, 9 Dec 2002 09:36:27 -0800 (PST)

Hi , 
 I'm wondering if my interpretation of section 8.4 is correct, especially when you have over written instructions and byte_copy_left + byte_copy_right. The draft says that copying should be done in ascending respecting the bounds of byte_copy_left and byte_copy_right. What if the start and/or destination are beyond byte_copy_left and byte_copy_right? 
Let's say, byte_copy_left = 64,  byte_copy_right = 128 and destination = 66. 
Let's say i have the following instructions. 
LOAD (destination, 256) 
COPY_LITERAL (130, 100, $destination). 
    How should the copying should take place for the above instruction? start and destination are beyond the byte_copy_left and byte_copy_right. In my implementation, i start copying from 130 into 256. Start and destination are updated as per section 8.4. 
Is my copying correct here? 
regards, 
Mural. 
 
 Chan Kwang Mien <[email-masked]> wrote: hi Mural,

my UDVM memory is 2048 but i don't have this problem. take care that copying operation is bounded by byte_copy_left
and byte_copy_right. So although the value in offset can be very large, it would not lead to decompression failure. this is 
further described in section 8.4 in the sigcomp draft.

regards,
Kwang Mien

Hi,

  I'm having problems with my UDVM on sigcomp torture test for COPY_LITERAL and COPY_OFFSET. Problem arises while executing LOAD ($offset, 1) instruction. The contents of udvm at address "offset" and "offset+1" are 0x40 and 0x40 before executing the LOAD instruction. So, LOAD fails claiming "address out of udvm memory" (I allocated 4k to UDVM). 

Does sigcomp tests expects 64k memory for UDVM? Did anyone had any problems executing this particular torture test?

thanks in advance,

murali.

Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now 

---------------------------------
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now

---------------------------------
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now

---

From: Chan Kwang Mien <[email-masked]>
Date: Tue, 10 Dec 2002 17:36:32 +0800

hi Mural,

from my interpretation of section 8.4 of the draft, byte_copy_left and
byte_copy_right defines the boundaries for copying operations if the first
byte
to be
copied lies within the boundaries OR the first byte lies below the
byte_copy_left. however, if the first byte to be copied lies above the
byte_copy_right, 
then section 8.4 doesn't apply. so, in your case, i don't think the boundaries
applies.

can anybody confirm this ? Thanks !!

regards,
Kwang Mien 

>
>   
>
> Hi , 
>>
>>  I'm wondering if my interpretation of section 8.4 is correct, especially
>> when you have over written instructions and byte_copy_left +
>> byte_copy_right. The draft says that copying should be done in ascending
>> respecting the bounds of byte_copy_left and byte_copy_right. What if the
>> start and/or destination are beyond byte_copy_left and byte_copy_right? 
>>
>>     How should the copying should take place for the above instruction?
>> start and destination are beyond the byte_copy_left and byte_copy_right. In
>> my implementation, i start copying from 130 into 256. Start and destination
>> are updated as per section 8.4. 
>>
>> my UDVM memory is 2048 but i don't have this problem. take care that
copying
>> operation is bounded by byte_copy_left 
>> and byte_copy_right. So although the value in offset can be very large, it
>> would not lead to decompression failure. this is 
>>>   I'm having problems with my UDVM on sigcomp torture test for
COPY_LITERAL
>>> and COPY_OFFSET. Problem arises while executing LOAD ($offset, 1)
>>> instruction. The contents of udvm at address "offset" and "offset+1" are
>>> 0x40 and 0x40 before executing the LOAD instruction. So, LOAD fails
>>> claiming "address out of udvm memory" (I allocated 4k to UDVM). 
>>>
>>> Does sigcomp tests expects 64k memory for UDVM? Did anyone had any
problems
>>> executing this particular torture test?
>>>
>>> thanks in advance,
>>>
>>> murali.
>>>
>>>
>>>
>>>
>>>
>>> Do you Yahoo!? 
>>> <http://rd.yahoo.com/mail/mailsig/*http://mailplus.yahoo.com>Yahoo! Mail
>>> Plus - Powerful. Affordable.
>>> <http://rd.yahoo.com/mail/mailsig/*http://mailplus.yahoo.com>Sign up now 
>>
>
>
>
> Do you Yahoo!? 
> <http://rd.yahoo.com/mail/mailsig/*http://mailplus.yahoo.com>Yahoo! Mail
Plus
> - Powerful. Affordable.
> <http://rd.yahoo.com/mail/mailsig/*http://mailplus.yahoo.com>Sign up now
>
>
>

Do you Yahoo!?
<http://rd.yahoo.com/mail/mailsig/*http://mailplus.yahoo.com>Yahoo! Mail
Plus -
Powerful. Affordable.
<http://rd.yahoo.com/mail/mailsig/*http://mailplus.yahoo.com>Sign up now