Subject: [rohc] SigComp interoperability test

From: "Surtees, Abigail" <[email-masked]>
Date: Wed, 18 Dec 2002 19:04:47 -0000

Hi,

A quick question about the proposed SigComp testing at SIPit, having had a look at the test description document...

It looks like the plan is to test 'SIP over SigComp' - i.e. with SigComp integrated into a SIP stack.  Obviously we've done a fair amount of UDVM testing (torture tests, etc.) and a small amount of SigComp testing.  So, can we assume that SigComp itself will be sufficiently tested by the SIP exchanges?  (Or that SigComp will be previously/subsequently tested in some (as yet undefined) standalone manner?)  Is anyone prepared to confirm or deny this assumption?!

Also how much time is going to be allocated to testing SigComp at SIPit?  (Our main interest would be in testing SigComp -- we don't really have any interest in taking part in general SIP tests...)

Kind regards,

Abbie

Abbie Surtees
Engineer
Internet Applications and Mobility
Roke Manor Research Ltd
Tel:   +44 (0) 1794 833131

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Robert Sparks <[email-masked]>
Date: 20 Dec 2002 10:45:10 -0600

> It looks like the plan is to test 'SIP over SigComp' - i.e. with SigComp integrated into a SIP stack.  Obviously we've done a fair amount of UDVM testing (torture tests, etc.) and a small amount of…

One way to get at least a thumbnail answer to that question is to start
an outline of an interop statement for sigcomp and see how much of that
statement could be filled out based on tests we're currently describing.
That effort is also likely to suggest further tests we can document and
perform.

> Also how much time is going to be allocated to testing SigComp at SIPit?  (Our main interest would be in testing SigComp -- we don't really have any interest in taking part in general SIP tests...)
As much time as there is interest. We have a side area for multiparty
tests that run continually through the event. We typically have
coordinated efforts taking a half day each, but if there is a group
that wants to spend the whole week focusing on one thing, the
resources are there for them to do so. Realistically, I'd expect
there to be 1/2 to 1 day on this.