Subject: [rohc] Sigcomp torture test: Sorting Test Case

From: [email-masked]
Date: Fri, 13 Dec 2002 16:16:28 -0600

Hi,
      i see that one integer in the 2-byte word list is not properly encoded in the byte code. The sixth element in the second 2-byte word list is 11296. This should be encoded as 0x2c20 in the byte code. Instead, it is encoded as 0x202c (8236).

  I realized that my output and draft output differ with this 2-byte word. The first few bytes of my output are 0x466f  7264 202c 796f...

-Narendra
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Mon, 16 Dec 2002 14:40:44 -0000

Hi Narendra,

Yes, you are right.  It should be encoded as 0x2c20 and will be corrected in an update of the draft.  Thank you for pointing that out.

Best regards,

Abbie

>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]
>Sent: 13 December 2002 22:16
>To: [email-masked]
>Subject: [rohc] Sigcomp torture test: Sorting Test Case
>
>
>Hi,
>      i see that one integer in the 2-byte word list is not 
>properly encoded in the byte code. The sixth element in the 
>second 2-byte word list is 11296. This should be encoded as 
>0x2c20 in the byte code. Instead, it is encoded as 0x202c (8236).
>
>  I realized that my output and draft output differ with this 
>2-byte word. The first few bytes of my output are 0x466f  7264 
>202c 796f...
>
>
>-Narendra