Subject: [rohc] ROHC CRC confusion

From: "Sarkar, Rajib" <[email-masked]>
Date: Tue, 3 Dec 2002 16:42:26 -0800

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office"
/>

    I have a question about CRC calculation. Lets say I have smooth packet
flow happening in U mode and I am sending 3 bit CRC using CRC_STATIC field.
So my CRC is

CRC [CRC_STATIC [IPv4, UDP, RTP], CRC_DYNAMIC [IPv4, UDP, RTP].

    Now suddenly for some reason I have to send a type 2 packet, and I have
to send 7 bit CRC. Isn't it then I have to recalculate CRC_STATIC and find
out CRC again? If this is correct, isn't it better to precalculate both 7
bit and 3 bit CRC_STATIC?

    I have another confusion, from the document it seems that for IR and
IR-DYN packets CRC is calculated over IR and IR-DYN packet with CID octets,
where as for Type0/1/2 packets CRC is calculated over the actual IPv4 header
(40 bytes), is my understanding correct?
 
Thanks
Rajib Sarkar
Ph No (310) 481 5709

---

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Fri, 6 Dec 2002 12:05:58 +0100

-----Original Message-----
From: Sarkar, Rajib [mailto:[email-masked]]
Sent: den 4 december 2002 01:42
To: [email-masked]
Subject: [rohc] ROHC CRC confusion

Hi,
> I have a question about CRC calculation. Lets say I
> have smooth packet flow happening in U mode and I am
> sending 3 bit CRC using CRC_STATIC field. So my CRC
> is CRC [CRC_STATIC [IPv4, UDP, RTP], CRC_DYNAMIC
> [IPv4, UDP, RTP]. Now suddenly for some reason I have
> to send a type 2 packet, and I have to send 7 bit CRC.
> Isn't it then I have to recalculate CRC_STATIC and
> find out CRC again? If this is correct, isn't it
> better to precalculate both 7 bit and 3 bit CRC_STATIC?

You will have to recalculate CRC_STATIC when any of
the fields covered by it changes. Further, I agree that
it might make sense to keep a CRC_STATIC for both 3-bit
and 7-bit CRC's. However, these are just implementation
issues, do as you prefer.

> I have another confusion, from the document it seems
> that for IR and IR-DYN packets CRC is calculated over
> IR and IR-DYN packet with CID octets, where as for
> Type0/1/2 packets CRC is calculated over the actual
> IPv4 header (40 bytes), is my understanding correct?

Yes, this is what 5.9.1 and 5.9.2 says.

BR
/L-E
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Sarkar, Rajib" <[email-masked]>
Date: Fri, 6 Dec 2002 11:33:51 -0800

Hi,
	Thanks for your explanation. Now going a little bit deep in the
calculation of CRC, once we do a CRC for a data packet there are severel
fields such as UDP Length, IPv4 Total length which are dynamic, is there any
specific reason they are decided to be dynamic?
Thanks
Rajib

-----Original Message-----
From: Lars-Erik Jonsson (EAB) [mailto:[email-masked]]
Sent: Friday, December 06, 2002 3:06 AM
To: 'Sarkar, Rajib'; [email-masked]
Subject: RE: [rohc] ROHC CRC confusion

-----Original Message-----
From: Sarkar, Rajib [mailto:[email-masked]]
Sent: den 4 december 2002 01:42
To: [email-masked]
Subject: [rohc] ROHC CRC confusion

Hi,

BR
/L-E

---

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Sun, 8 Dec 2002 18:31:59 +0100

> calculation of CRC, once we do a CRC for a data packet there 
> are several fields such as UDP Length, IPv4 Total length which are 
> dynamic, is there any specific reason they are decided to be dynamic?

Because these fields indicate the whole packet length, which is not
often fixed. The fields must therefore be classified as dynamic.

/L-E