Subject: [rohc] COPY_LITERAL and COPY_OFFSET torture test

From: Mural Kumar <[email-masked]>
Date: Sun, 8 Dec 2002 18:54:32 -0800 (PST)

Hi,

  I'm having problems with my UDVM on sigcomp torture test for COPY_LITERAL and COPY_OFFSET. Problem arises while executing LOAD ($offset, 1) instruction. The contents of udvm at address "offset" and "offset+1" are 0x40 and 0x40 before executing the LOAD instruction. So, LOAD fails claiming "address out of udvm memory" (I allocated 4k to UDVM). 

Does sigcomp tests expects 64k memory for UDVM? Did anyone had any problems executing this particular torture test?

thanks in advance,

murali.

---------------------------------
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now

---

From: Chan Kwang Mien <[email-masked]>
Date: Mon, 09 Dec 2002 16:13:12 +0800

hi Mural,

my UDVM memory is 2048 but i don't have this problem. take care that 
copying operation is bounded by byte_copy_left
and byte_copy_right. So although the value in offset can be very large, it 
would not lead to decompression failure. this is
further described in section 8.4 in the sigcomp draft.

regards,
Kwang Mien

>Hi,
>
>   I'm having problems with my UDVM on sigcomp torture test for 
> COPY_LITERAL and COPY_OFFSET. Problem arises while executing LOAD 
> ($offset, 1) instruction. The contents of udvm at address "offset" and 
> "offset+1" are 0x40 and 0x40 before executing the LOAD instruction. So, 
> LOAD fails claiming "address out of udvm memory" (I allocated 4k to UDVM).
>
>Does sigcomp tests expects 64k memory for UDVM? Did anyone had any 
>problems executing this particular torture test?
>
>thanks in advance,
>
>murali.
>
>
>
>Do you Yahoo!?
><http://rd.yahoo.com/mail/mailsig/*http://mailplus.yahoo.com>Yahoo! Mail 
>Plus - Powerful. Affordable. 
><http://rd.yahoo.com/mail/mailsig/*http://mailplus.yahoo.com>Sign up now