Subject: RE: [rohc] Do we need a special profile for Mobile IPv6 packets?

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Mon, 9 Dec 2002 17:53:57 +0100

Ana,
 
That is one of my points. The problem does not have to be in the technical
solution available, but in the way the specification is written (it might even
give people the incorrect impression that there are necessarily things
missing).
 
We are progressing with getting implementations of RFC 3095 and we have
identified some ambiguities with the document that we have provided
clarifications to in the implementer's guide. Input on problems with the list
compression scheme is welcome as well, preferably on this list.
 
I try to answer all questions and collect the issues we identify with 3095,
to simplify for implementers. I think it is desirable to have specifications
that people can understand and implement, and list compression might
be a difficult part of 3095. However, I have not yet seen any concrete
technical questions or identified problems with the list compression
scheme.
 
RFC 3095 was openly defined and agreed on this list. The protocol has
strengths and weaknesses, but we have not yet identified any important
missing pieces (although some people would claim we did include too
many optimizations for specific cases). Anyway, this is what we have
today and this is our starting point when considering new ideas. Anyone
can send questions to the list and get answers about what the protocol
can do, how it works, etc. I think no one should be able to claim that
questions to the ROHC list are not being answered. If someone thinks
something is missing, that question should be bought to the list as well. 
We should then work together to figure out whether the "missing piece"
is really missing, or if there is already a solution (and it is of course 
always an advantage if no extra work is needed). However, when claiming
that something new is needed, the proponent is always the one with
the burden of motivating and justifying that claim.
 
BR
/L-E

-----Original Message-----
From: Ana Carolina Minaburo [mailto:[email-masked]]
Sent: den 9 december 2002 16:18
To: Lars-Erik Jonsson (EAB); [email-masked]
Subject: Re: [rohc] Do we need a special profile for Mobile IPv6 packets?

Lars-Erik,

I think the list compression as is in the RFC3095 is not really well explained. If you do not want to receive new draft with new profile for this kind of stuffs you need to clarify the use of the list and you need to convince others that this list is the best way to send extensions of IPv6 and Mobile IPv6. 

Ana

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 9 Dec 2002 14:32:26 -0800 (PST)

Hello,
  I read draft-hwang, it suggests processing MIPv6 HOA
and Type 2 routing headers with a ROHC profile. 
  The draft seems to have found some encouragement
from the statements in RFC 3095 which says that when
MIPv6 is finalized maybe a special profile will be
needed for MIPv6.
  From the discussions on the list, Lars-Erik is
asserting that RFC 3095 is sufficient in order to
process these two types of IPv6 extension headers, to
which I have nothing to say. These two headers have
existed in MIPv6 since 1996 so I do not see any reason
why RFC 3095 could not compress them
  
  However, as draft-hwang talks about, what is new in
MIPv6 are the mobility headers used for securing route
optimization. draft-hwang says that they are used for
only a short period of time so therefore their
compression would not be effective.
  
  Maybe what we need is to modify the statements on
MIPv6 in RFC 3095, that's all.

BR

--behcet
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc