Subject: RE: [rohc] Updating the ROHC impl. guide

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Mon, 3 Mar 2003 09:56:52 +0100

Zhigang,

In the updated draft, your comment has been addressed.

All packets are "totally updating", except for UO-1-ID.
Of course, packets such as R-0 or UO-0 can not update
fields like TTL, as they do not carry a TTL field.
However, I think it is still ok to say "update all
header fields", and make UO-1-ID the exception.

/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: den 28 februari 2003 17:32
> To: Lars-Erik Jonsson (EAB); [email-masked]
> Subject: RE: [rohc] Updating the ROHC impl. guide
> 
> 
> Lars-Erik,
> 
> Any thoughts on my proposed text for section 4.7? In particular,
> if you have think it is correct? Note that I added UO-0 in the
> last sentence. Also, what about UO-1 and UO-1-TS? Do they update
> all the header fields or just a subset?
> 
> ------------------
> "In UO-mode, all packets are updating packets, while in R-mode
> all packets with a CRC are updating packets. An updating packet
> in R-mode updates the reference values of all header fields, either 
> explicitly or implicitly. Same is true for updating packets in
> UO-mode, except for UO-1-ID and UO-0, which only update TS, SN 
> and IP-ID (see 5.7.3)."
> ------------------
> 
> Zhigang
> 
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Mon, 3 Mar 2003 09:58:28 +0100

> > Anyway, there is no single criteria, we have to look at each case.
> 
> Since this is a WG document, it would help to have some kind of
> criteria/rules for what should be included and what should not.

That would be impossible with this kind of document, as we can not
know what kind of things will have to be further explained or
clarified. When someone identifies an issue, we discuss it and 
find out whether it should be added, and then what should be added.

The purpose of the document is to provide additional guidelines for
implementer's of ROHC. It should be short enough so that people
bother to read it and easily find answers to their questions, but
it should also contain enough material to really answer the most
common questions and clarify identified ambiguities.

BR
/L-E

---

From: [email-masked]
Date: Mon, 3 Mar 2003 10:59:58 -0600

Lars-Erik,

Could you send out the new text about this in the updated 
draft, so I can take a look? I want to check if my comments
has been addressed correctly, since it looks you don't want to
use my proposed text and I haven't seen you explaining the
reasons. As a technical discussion, it would be helpful if 
you simply point out what you disagree with my text, like what 
I did with the text of current draft.

BTW, your reply below is confusing. For example, R-0 is NOT an 
updating packet. It does not update *anything*. I don't know 
why it is mentioned at all in the context of updating TTL field. 
But again, I'd like to read the new text and see if it indeed 
addresses my comments.

Zhigang

> From: ext Lars-Erik Jonsson (EAB)
> [mailto:[email-masked]]
> Sent: March 03, 2003 2:57 AM
> To: [email-masked]

---

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Tue, 4 Mar 2003 09:24:53 +0100

Zhigang,

The text of the updated draft became as follows:

  "An updating packet thus updates the reference values of all header
   fields, either explicitly or implicitly, with an exception for the
   UO-1-ID packet, which only updates TS, SN and IP-ID (see 5.7.3). In
   UO-mode, all packets are updating packets, while in R-mode all
   packets with a CRC are updating packets."

This is the same text as before, but adjusted based on your comment.
If you still think there are contradictions, we can fix that in the
next update. The reason I did not just take your alternative text was
that it changed the order of the sentences, and that made it fit less
well within the section as a whole.

Regarding your BTW, you are right that R-0 is a non-updating
packet as it does not have a CRC, but replace R-0 in my note with
R-0-CRC and you should get the point. All packets that are updating 
(i.e. all but R-0) update *all* fields (i.e. fields for which data
is sent in the compressed header plus TS & IP-ID implicitly), with
the single exception of UO-1-ID, which ONLY updates SN, TS & IP-ID.

/L-E

> Sent: den 3 mars 2003 18:00
> > > in R-mode updates the reference values of all header fields,
> > > either explicitly or implicitly. Same is true for updating
> > > packets in UO-mode, except for UO-1-ID and UO-0, which only
> > > update TS, SN and IP-ID (see 5.7.3)."
> > > ------------------
> > > 
> > > Zhigang
> > >