Subject: RE: [rohc] FW: ESP and header compression (ROHC)

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Tue, 15 Apr 2003 10:22:30 +0200

> Taking the 'ROHC over re-ordering channels' question more 
> generally; RFC 3095 does not work in such an environment.  
> However, we are (I believe) trying to address this issue as 
> part of ROHC for TCP...

This was a design decision we made for 3095, but personally
I think the modifications needed to make it work also in case
of mis-ordering are small. If someone wants to look at this
and write some input on it, I would be more than happy.

> Anyway, tunnels (and especially IPsec) can simply be treated 
> as a link.  In which case, rohc can be applied on that link.

Yes, a "ROHC over tunnels" document could potentially be 
justifiable.

> In the case of IPsec/ESP it may make a great deal of sense to 
> compress the headers inside of the tunnel encapsulation.  The 
> VPN endpoints are probably disjoint from any particular 
> physical link that benefits from compression and so, to me, 
> it makes sense to do the compression in the two different places.

Yes, that is what you would have to do if encryption is applied
over the tunnel.

/L-E
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Bjoern Groenvall <[email-masked]>
Date: 15 Apr 2003 12:50:28 +0200

>>>>> "Lars-Erik" == Lars-Erik Jonsson (EAB) <[email-masked]> writes:

>> generally; RFC 3095 does not work in such an environment.  However,
>> we are (I believe) trying to address this issue as part of ROHC for
>> TCP...

Lars-Erik> This was a design decision we made for 3095, but personally
Lars-Erik> I think the modifications needed to make it work also in
Lars-Erik> case of mis-ordering are small. If someone wants to look at
Lars-Erik> this and write some input on it, I would be more than
Lars-Erik> happy.

The ESP and AH headers also have a "Sequence Number"-field that may be
used to detect reordering and packet losses.

/Björn

-- 
  _     _                                               ,_______________.  
Bjorn Gronvall (Björn Grönvall)                        /_______________/|     
Swedish Institute of Computer Science                  |               ||
PO Box 1263, S-164 29 Kista, Sweden                    | Schroedingers ||
Email: [email-masked], Phone +46 -8 633 15 25              |      Cat      |/
Cellular +46 -70 768 06 35, Fax +46 -8 751 72 30       `---------------' 
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Mikael Degermark" <[email-masked]>
Date: Tue, 15 Apr 2003 18:13:04 -0700

What will be needed for "ROHC over tunnels" is allocation
of an IP type identifier for ROHC. A "ROHC over tunnels"
document would then be exactly the fodder we'd need to
feed to the IANA/IESG in order to allocate such an identifier.

The indentifier would mean "the payload is a ROHC packet".
The profiles used over such a tunnel should be able to deal
with the kind of reordering and loss one would see in the tunnel.

There may be a need for a negotiation procedure to negotiate
ROHC parameters over the tunnel, but I'm not entirely sure
this will be needed in all cases. If we decide that it IS needed,
that negotiation might be defined the "ROHC over tunnels"
document as well.

Mikael Degermark

----- Original Message -----
From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
To: "'Yaron Sheffer'" <[email-masked]>; "IPSec List"
<[email-masked]>; <[email-masked]>
Sent: Tuesday, April 15, 2003 1:22 AM
Subject: RE: [rohc] FW: ESP and header compression (ROHC)