Subject: [rohc] ROHC-FN and TCP Profile - Version 2

From: "Price, Richard" <[email-masked]>
Date: Wed, 23 Apr 2003 12:48:51 +0100

Hi,

Now that Easter's out of the way, it might be a good
time to restart the discussion on ROHC-FN and the TCP
compression profile. In the interests of getting the
discussion going, here's a link to Version 2 of our
implementation:

http://sigcomp.srmr.co.uk/~rjp/ROHC-FN_Version_2.zip

For the updated implementation we've added all of the
encoding methods not supported in Version 1, including
Huffman-based discriminator encoding (i.e. EPIC-lite)
as well as "list" encoding for the TCP options and
the IP extension headers. We've also added support for
real IR packets with the correct indicator bits.

The TCP packet formats have been updated to take
advantage of the new encoding methods - we can now
compress various TCP options using list encoding, and
have a single discriminator for the header as a whole.
Minimum compressed header size is now 3 bytes.

One other issue - the updated implementation is
written in a different language from the original
(namely Prolog rather than Haskell). We're still
working on the Haskell code, but we're turning it into
a "proper" implementation (with full debugging and a
nice user interface).

A suitable Prolog interpreter can be downloaded from:

http://www.swi-prolog.org/download.html

For simplicity, the implementation is provided as a
single Prolog source file. Just open it and type
"comp_list(tcp_test_n)." where n is the TCP test flow
to be compressed.

Regards,

Richard
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: [email-masked]
Date: Fri, 25 Apr 2003 12:06:39 -0500

Hi Richard,
Could you please share the version 2 for the TCP compression profile in the pictorial form with textual description (basically, in the I-D format). Something similar you did for the previous version.

Thanks,
Yousuf

-----Original Message-----
From: ext Price, Richard [mailto:[email-masked]]
Sent: Wednesday, April 23, 2003 6:49 AM
To: [email-masked]'
Subject: [rohc] ROHC-FN and TCP Profile - Version 2

Hi,

Regards,

Richard

---

From: "Price, Richard" <[email-masked]>
Date: Tue, 29 Apr 2003 15:51:22 +0100

Hi Yousuf,

Drawing the Version 2 packet formats out pictorially might
be a bit of a challenge, as they're a *lot* more complex
than the Version 1 formats. They're now roughly as
complicated as the packet formats in RFC 3095, so the
pictorial form plus accompanying text will be around 100
pages long  - a non-trivial amount of effort to generate
by hand ;-)

A possible solution would be to modify our implementation
so that it can automatically convert a ROHC-FN description
of the packet formats into a pictorial one. If you think
this feature would be useful, let me know so that we can
add it to the next version of the implementation.

Regards,

Richard

> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, April 25, 2003 6:07 PM
> To: Price, Richard; [email-masked]
> Subject: RE: [rohc] ROHC-FN and TCP Profile - Version 2
> 
> 
> Hi Richard,
> Could you please share the version 2 for the TCP compression 
> profile in the pictorial form with textual description 
> (basically, in the I-D format). Something similar you did for 
> the previous version.
> 
> Thanks,
> Yousuf
>

---

From: [email-masked]
Date: Tue, 29 Apr 2003 15:42:31 -0500

Hi Richard,
I think it would be useful to have the pictorial format generation. 

Thanks,
Yousuf

-----Original Message-----
From: ext Price, Richard [mailto:[email-masked]]
Sent: Tuesday, April 29, 2003 9:51 AM
To: Saifullah Yousuf (NRC/Dallas); [email-masked]
Subject: RE: [rohc] ROHC-FN and TCP Profile - Version 2

Hi Yousuf,

Regards,

Richard