Subject: [rohc] Clarification on LSB encoding

From: [email-masked]
Date: Fri, 13 Jun 2003 20:14:39 +0530

Dear ROHC Experts,

Referring to section - 5.7 Packet Formats

Can somebody explain me the concept behind lines below :

##################################################################
SN: The compressed RTP Sequence Number.

       Compressed with W-LSB.  The interpretation intervals, see section
       4.5.1, are defined as follows:

            p = 1                   if bits(SN) <= 4
            p = 2^(bits(SN)-5) - 1  if bits(SN) >  4
##################################################################

How p = 2^(bits(SN)-5) - 1  if bits(SN) >  4 is devised ?

regards,
Madhusudan

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended solely for the use of the individual to whom it is
addressed. It may contain  privileged or confidential information and
should not be circulated or used for any purpose other than for what it is
intended. If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient, you are
notified that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. HSS accepts no responsibility for
loss or damage arising from the use of the information transmitted by this
email including damage from virus."

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: [email-masked]
Date: Fri, 13 Jun 2003 18:12:39 -0500

Hi Madhusudan,

That means p=0 if bits(SN)=5, p=1 if bits(SN)=6, and so on.
I.e., value of p depends on the number of SN bits carried in 
a compressed header. The rational is that with more SN bits
(and thus larger compressed header), we want to be able to
encode even misordered (before compressor) RTP packets.

BR,
Zhigang

---

From: [email-masked]
Date: Mon, 16 Jun 2003 09:52:56 -0500

Hi Vishal,

The assignment of P value for SN is mainly based on the possible
length of SN bits in various compressed headers (see below). Namely,
it allows 4-bit and 6-bit SN to handle misordering (duplicate packets
or -1 change in SN). Note that there is no packet format that can 
carry 5-bit SN.

SN bits     Packet Type
---------------------------
4 bits      UO-0, UO-1*
6 bits      R-0, R-1*, UOR-2*
7 bits	R-0-CRC

(more SN bits can be carried with extensions for type 1 and 2)

BR
Zhigang

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: June 14, 2003 01:37 AM
> To: Liu Zhigang.C (NRC/Dallas)
> Cc: [email-masked]; [email-masked]
> Subject: RE: [rohc] Clarification on LSB encoding
> 
> 
> 
> 
> 
> 
> 
> Dear zhigang,
> 
> Thanks for the response. Please provide the detailed analysis 
> of the query.
> 
> Refer to the table below
> SN          p           interval                      Comment
> 4           1           vref-1,vref + (2^k -1) -1           
> (left shift)
> 5           0           vref,vref+(2^k-1)             (no shift)
> 6           1           vref-1,vref + (2^k -1) -1           
> (left shift)
> 7           3           vref-3,vref + (2^k -1) -3           
> (left shift)
> 
> When we are using 4 bit compressed header (CH  for SN,  the 
> value of p is 1
> which implies that there is a left shift in the 
> interpretation interval ,
> where as in case of  5 bit CH p comes out to be 0, which 
> means there is no
> shift in the interval. Considering SN=6 , p will be 1, again 
> there is a
> left shift in interval. Now this to and fro movement is 
> insuring correct
> encoding of misordered packets, How ?
> 
> What is the reason behind choosing 4 and 5 in section given 
> for calculation
> of p.
> Please elaborate on this concept.
> 
> regards,
> Vishal
> 
> 
> 
> 
> 
> 
> 
> 
> [email-masked]@ietf.org on 06/14/2003 12:12:39 AM
> 
> Sent by:    [email-masked]
> 
> 
> To:    Madhusudan Pawar/HSS@HSS, <[email-masked]>
> cc:
> 
> Subject:    RE: [rohc] Clarification on LSB encoding
> 
>