Subject: [rohc] IP-ID field in RTP packets always 0?

From: Haipeng Jin <[email-masked]>
Date: Thu, 11 Sep 2003 11:51:02 -0700 (PDT)

Hi,

I have compiled Vovida RTP under Redhat Linux and run some test using the
rtpPlay/rtpRecord programs provided. During the test, I noticed that all
the RTP/UDP/IP packets sent between the rtpPlay host and the rtpRecord
host have an IP Identification field of value 0 all the time.

The same thing happened with the RTP stack provided by Common Multimedia
Library from UCL.

I also noticed a 0 valued IPID field in one example packet posted by Alan
when discussing ROHC compression ratio.

From the RFC791 as well as the ROHC assumption the IP-ID field should be
changing from packet to packet. So could anyone please
explain what is happening here? Is it because Linux IP stack or the RTP
stack implementation? If this is normal and appears frequently, won't it
be better to allow encoding of the absolute IP ID value instead of the
offset from SN in such cases?

Thanks.

Haipeng Jin

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Fri, 12 Sep 2003 10:43:42 +0200

This is a known "problem" with Linux, and has been
discussed on this earlier this year. The new IP profile
has a solution for this, but unfortunately not the
currently existing profiles (need to send full IP-ID).

/L-E

> -----Original Message-----
> From: Haipeng Jin [mailto:[email-masked]]
> Sent: den 11 september 2003 20:51
> To: [email-masked]
> Subject: [rohc] IP-ID field in RTP packets always 0?
> 
> 
> Hi,
>