Subject: RE: [rohc] Problem with RFC 3095 Extension Header encoding

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Fri, 12 Sep 2003 10:59:26 +0200

Kristofer,

It seems like we did not mean the same thing....and you are probably
correct in this case. Although it would be better to use LSB-encoding
as usual, "LSB of sequence number" must probably be interpreted 
exactly as LSB's, i.e. the MSB's must just be appended without any
specific interpretation interval.

Agree?

/L-E

> -----Original Message-----
> From: Kristofer Sandlund [mailto:[email-masked]]
> Sent: den 9 september 2003 14:38
> To: Lars-Erik Jonsson (LU/EAB); [email-masked]
> Subject: Re: [rohc] Problem with RFC 3095 Extension Header encoding
> 
> 
> Hi!
> 
> Comments inlined below.
> 
> Lars-Erik Jonsson (LU/EAB) wrote:
> > Starting to catch up...
> > 
> > 
> >>-----Original Message-----
> >>From: Price, Richard [mailto:[email-masked]]
> >>Sent: den 4 juni 2003 18:19
> >>To: [email-masked]
> >>Subject: [rohc] Problem with RFC 3095 Extension Header encoding
> >>
> >>
> >>Hi,
> >>
> >>I'm currently attempting to add support for IP Extension Headers to
> >>our ROHC-TCP implementation - the plan is to reuse the 
> existing packet
> >>formats from RFC 3095. However, I'm having some difficulty 
> >>decoding the
> >>compressed versions of the AH, ESP and GRE Sequence Numbers.
> >>
> >>What isn't clear from the standard is the following:
> >>
> >>1. What interpretation interval should I use to decode the sequence
> >>   number LSBs?
> > 
> > 
> > Looking at 5.8.5, I can not find any interpretation interval either,
> > so I would treat the LSB's as pure LSB's....i.e. with p=1.
> > 
> > 
> 
> Hmm... I'm not sure it is about LSB encoding at all here. The 
> picture in 5.8.5.1:
> 
>       0   1   2   3   4   5   6   7       0   1   2   3   4   
> 5   6   7
>     +---+---+---+---+---+---+---+---+   
> +---+---+---+---+---+---+---+---+
>     | 0 |   LSB of sequence number  |   | 1 |                 
>           |
>     +---+---+---+---+---+---+---+---+   +---+                 
>           +
>                                         |                     
>           |
>                                         +     LSB of sequence 
> number    +
>                                         |                     
>           |
>                                         +                     
>           +
>                                         |                     
>           |
>                                         
> +---+---+---+---+---+---+---+---+
> 
> So it says "LSB of sequence number" and not "LSB encoded 
> sequence number". Yes, 
> this would be inefficient if AH/GRE/ESP SN jumps while we 
> "wrap" the bits 
> around, but I don't think the above can be interpreted as LSB 
> encoding.
> Also, the fact that 'p' is left out seems to support my 
> interpretation.
> 
> > 
> >>2. Should the decoded sequence number be treated as an 
> absolute value,
> >>   or as an offset from the RTP Sequence Number?
> > 
> > 
> > My interpretation of the text in 5.8.4 and 5.8.5 is that 
> these sequence
> > numbers are NOT sent as offset from the RTP SN.
> > 
> 
> I agree, it should be an absolute value.
> 
> Rgds,
> 	Kristofer Sandlund, Effnet AB
> 
> > 
> > Any other opinions on these matters?
> > 
> > /L-E
> > 
> > _______________________________________________
> > Rohc mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/rohc
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Kristofer Sandlund <[email-masked]>
Date: Fri, 12 Sep 2003 11:26:33 +0200

Lars-Erik,

Yes, that is exactly my interpretation of it. Even though it's not the best form 
of encoding, I think this is what we must use.

Rgds,