Subject: [rohc] Yet another thread on IPR...

From: "West, Mark" <[email-masked]>
Date: Tue, 2 Sep 2003 18:39:08 +0100

Hi all...

Yes -- me again.  Yes -- IPR again.  But, a different subject.

I was looking through the 'IP only' profile (draft-ietf-rohc-ip-only-02) recently, with a view to starting a more thorough review and was struck by the following...

This draft contains no IPR statement.  

It also, interestingly, contains no actual description of the compression, except by reference: "In general, there are no major difference between the ROHC UDP profile and the IP profile (ROHC IP) defined in this document, since the removal of UDP has no impact on the compression mechanisms."

However, it is clear that the UDP packet formats include some old friends: a CRC over the uncompressed header and the use of W-LSB encoding.

So, this triggers the following questions:

- are we to assume, because a normative reference of this document asserts IPR claims, that such claims apply to this document?

- or, should this document contain an IPR claim?  
(it's clear that the authors are aware of at least some of the relevant IPR ;-)

- finally, yet perhaps most importantly, do we want an *encumbered* IP only profile?  Wouldn't it be nice if the most widely applicable of the ROHC profiles was also freely deployable..?  (Assuming that we're trying to move that way, in general, for new profiles)

Slightly random questions, but I'd be very interested to in any comments and opinions...

Cheers,

Mark.

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Wed, 3 Sep 2003 11:56:35 +0200

> I was looking through the 'IP only' profile 
> (draft-ietf-rohc-ip-only-02) recently, with a view to 
> starting a more thorough review and was struck by the following...
> 

True, we should have one, clarifying that the IPR statement of 3095
apply equally, as this IP profile is defined on 3095 to make that
profile set complete.
 
> - are we to assume, because a normative reference of this 
> document asserts IPR claims, that such claims apply to this document?

Maybe we could, but I think we should clarify it explicit in the draft.

/L-E