Subject: [rohc] Comments on draft-ietf-rohc-udp-lite-01.txt

From: Kristofer Sandlund <[email-masked]>
Date: Thu, 18 Dec 2003 12:47:04 +0100

Hi!

I have looked through the UDP-lite profile draft and have the following comments:

* "4.1 design motivations" more or less says that the profile should be as 
similar as possible to the UDP profile, and then the "arbitrary number of IP 
headers" are added as in the IP profile. I'm not saying this is wrong, but 
possibly there should be some text saying that "and also include the 
improvements to ROHC included in the IP only profile" or something along those 
lines (Note: I know this is in "Introduction", but that's not really enough).

* Since we're adding the arbitrary number of headers, then we should also add 
the CONTEXT_MEMORY feedback option as in the IP profile.

* In 5.3.2, below the picure, it explains the special updating properties of 
CE(ON) and CE(OFF). I think it should be said here that these two packet types 
cannot be used to extend R-0 and R1* headers instead of mentioning it in the 
separate sections for these packets on the next page. It will just lead to 
confusion the first time reading it.

Overall, the document looks good seems to fill its purpose.

Rgds,
	Kristofer Sandlund, Effnet AB

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Ghyslain Pelletier <[email-masked]>
Date: Thu, 18 Dec 2003 13:05:55 +0100

Hi Kristofer,

Thanks for your review and your comments! I agree with all three
comments and will make the appropriate changes to the document, unless I
hear objections on the list regarding these comments. I will thus update
the design motivations, add the CONTEXT_MEMORY feedback option and
clarify the special updating properties of the CE(*) packets, as you
suggested.

> Overall, the document looks good seems to fill its purpose.
Can I conclude from this that you agree with the general approach taken
for the profiles for UDP-Lite and the proposed solution?

Now that the UDP-Lite draft has been approved by the IESG and is in the
RFC queue, I would like to move forward with the ROHC profiles for
UDP-Lite. I'd like to invite other people interested in this document to
provide feedback to the list (Mark? Richard?). Thanks!

Best regards,

/Ghyslain

-- 
Ghyslain Pelletier, Dipl. Ing.
Wireless IP Optimizations
AWARE - Advanced Wireless Algorithm Research
Ericsson Research, Corporate Unit

Ericsson AB, Laboratoriegränd 11
Box 920, S-97128 Luleå, SWEDEN
Phone : +46 (0) 920 20 24 32 
Mobile: +46 (0) 706 09 27 73
[email-masked]
http://www.ericsson.com

I have a new mail address: [email-masked]
My old e-mail address will function until 2004-06-01.
Please change my address in your personal address book.

---

From: Ghyslain Pelletier <[email-masked]>
Date: Thu, 18 Dec 2003 13:48:56 +0100

Ghyslain Pelletier wrote:

> I will thus update the design motivations, add the CONTEXT_MEMORY
> feedback option and clarify the special updating properties of the
> CE(*) packets, as you suggested.

Oups - I did mean "clarify the special updating properties of the CE(ON)
and CE(OFF)" only, not CE(*)...

/Ghyslain