Subject: RE: [rohc] ROHC context reuse & mode

From: "Lars-Erik Jonsson" <[email-masked]>
Date: Wed, 18 Feb 2004 09:44:01 +0100

Zhigang,

I am not sure there would be any technical problems
with it, but it is indeed a change in principle from
what is stated by 3095, as 3095 clearly says new
contexts must start in U-mode.

Either way, we should put some clarifying text in the
impl. guide, we just have to agree on what (I'll have
to think some more about this, or let others convince
me on which approach makes most sense).

/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: den 17 februari 2004 19:31
> To: Lars-Erik Jonsson (LU/EAB); [email-masked]
> Cc: [email-masked]
> Subject: RE: [rohc] ROHC context reuse & mode
> 
> 
> Lars-Erik,
> 
> Technically, I don't seen any interoperability problem for the
> compressor to stay in current mode (see my email to Kristofer). 
> Do you?
> 
> BTW, could you please copy me in the To or CC list when commenting
> on my emails? That makes it easier for me to know you have comments.
> Thanks.
> 
> Zhigang
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of ext
> > Lars-Erik Jonsson (LU/EAB)
> > Sent: 16 February, 2004 03:05 AM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: RE: [rohc] ROHC context reuse & mode
> > 
> > 
> > > Case 2: start a new flow with a CID that hasn't been used. Simple.
> > > Start in U-mode as it should be.
> > > 
> > > Case 3: start a new flow but reuse CID. This is the sticky case.
> > > Two subcases. 
> > > 
> > > 3a) If the new flow belongs to a different profile, the compressor
> > > should start in U-mode as discussed. 
> > > 
> > > 3b) If same profile, this is actually similar to Case 1 (if 
> > you think 
> > > hard about it). The only difference is that the 
> decompressor didn't
> > > send STATIC-NACK. The compressor can stay in the same 
> mode for the 
> > > CID (before the new flow), and send all context info in IR 
> > > (see Case 1 above).
> > 
> > One question is whether this is ok according to 3095? Personally, I
> > agree with Carsten that when a new context is initialized, it must
> > start in U-mode, and that would also apply to the CID reuse case.
> > 
> > /L-E
> > 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Kristofer Sandlund <[email-masked]>
Date: Wed, 18 Feb 2004 14:21:37 +0100

Zhigang/L-E,

I think that Zhigang's scheme of letting mode be inherited when we have the same 
profile seems like the best choice to me. I think this approach will be more 
consistent with the mode transition logic.
If we choose the "always U-mode when new flow" approach, and a new flow appears 
in the middle of a pending mode transition, we would probably have to specify 
that the decompressor must detect that it is a new flow (for example 
static-def-diffing as I suggested earlier) and also it should set D_TRANS=done & 
D_MODE=U-mode when we have a new flow (i.e. mode trans must be restarted). The 
inheritance scheme will just complete the mode transition without having to 
understand that it is a new flow.

I can agree that this is slightly inconsistent with the spec, but I don't think 
it "clearly says new contexts must start in U-mode". All it says is "Compression 
with ROHC MUST start in the Unidirectional mode" (sec. 4.4.1), which _could_ be 
interpreted as being on a per-channel basis. If so, mode inheritance is 
completely ok.

Rgds,
	Kristofer Sandlund, Effnet AB