Subject: [rohc] LLA-ROHC question

From: Qiaobing Xie <[email-masked]>
Date: Fri, 06 Feb 2004 18:06:48 +0800

Hi,

I wonder how friendly is LLA-ROHC towards RTP packets with a customer 
defined header extension (i.e., X flag =1). How is this handled?

regards,
-Qiaobing

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Tue, 10 Feb 2004 09:17:31 +0100

Qiaobing,

I do not know exactly what you mean with friendly, using a non-standard
extension is in my opinion not what I would call friendly...=)

Anyway, LLA [profile 5] handles Xtensions as ROHC RTP [profile 1], i.e.
its presence is indicated in IR's (or extensions to CO) and the X-bit
is thus transparently decompressed (as all fields). The extension
itself is seen as just another part of the payload data.

Rgds,
/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Qiaobing Xie
> Sent: den 6 februari 2004 11:07
> To: ROHC WG
> Subject: [rohc] LLA-ROHC question
> 
> 
> Hi,
> 

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Thu, 12 Feb 2004 11:21:12 +0100

> So, in other words, when a RTCP/UDP/IP packet is presented
> to the compressor, the RTCP portion will be treated as just
> a general UDP payload and will not be compressed by ROHC
> or LLA-ROHC?

That is correct. To my knowledge, compression of RTCP has
never been seriously considered. 

/L-E