Subject: [rohc] Regarding SIP and sigcomp

From: suman <[email-masked]>
Date: Wed, 31 Mar 2004 11:50:22 +0530

Hi,

    The SigComp solution for compressing messages requires state memory to be allocated
on a per compartment basis.  For a sip endpoint, the recommended state memory size is 2048 bytes.
   However, for a SIP proxy implementing SIGCOMP and handling thousands of endpoints, maintaining so many states requires memory which most of the proxies cannot afford.
  Going for a simple stateless mechanism is one way of alleviating this problem, but the compromise
is the lower compression ratio.

  What is the recommded implementation at the SIP proxy ?? Is is stateful or stateless,..??

   Any comments on this would be useful,

thanks
suman

---

From: chintan <[email-masked]>
Date: Wed, 31 Mar 2004 09:30:38 -0600

Hi,
A sip endpoint may request state creation request upto 2048 bytes. The 
state creation request may be for a state that is already present at the 
state handler in which case there is no additional memory allocated, but 
just the state identifier returned.

Hence the amount of memory allocated may be less than (num_of_endpoints 
* 2048)

suman wrote:

>    However, for a SIP proxy implementing SIGCOMP and handling 
> thousands of endpoints, maintaining so many states requires memory 
> which most of the proxies cannot afford.