Subject: [rohc] Regd. generation of state identifier for SIP static dictionary(rfc 3485)

From: sasidhar <[email-masked]>
Date: Mon, 08 Mar 2004 15:11:56 +0530

We tried to generate the 20-byte SHA-1 hash (RFC-3174) over the byte string formed by concatenating the state_length, state_address, state_instruction, minimum_access_length and state_value(in that order) with the values given in the rfc 3485 (pg.7) for the static dictionary. The result didnot match with the state-identifier given for the same.The procedure we followed is according to the rfc 3320. I have verified the input many times and even with different implementations of SHA-1 hash, but it didn't work. This is very important and urgent. Please help me out of this problem. 

Thanks and regards,
Sasidhar

---

From: "Richard Price" <[email-masked]>
Date: Mon, 08 Mar 2004 10:29:24 +0000

Sasidhar,

The first thing to check is that your implementation of SHA-1
passes the four tests specified in RFC-3174.

Assuming that this is the case, the problem might lie in the input
that you're passing to the SHA-1 hash. One point to note is that
the state_length, state_address, state_instruction and
minimum_access_length are all 2-byte values. It might also be
worth checking that you've remembered to delete the leftmost
column of RFC-3485, because this column contains line numbers
only, and is not part of the static dictionary itself.

Could you verify that the first 48 bytes you're passing to the
SHA-1 hash are as follows:

0x12e4 0000 0000 0006 0d0a 5265 6a65 6374
0x2d43 6f6e 7461 6374 3a20 0d0a 4572 726f
0x722d 496e 666f 3a20 0d0a 5469 6d65 7374 ...

Regards,

Richard

>From: sasidhar <[email-masked]>
>Reply-To: sasidhar <[email-masked]>
>To: [email-masked]
>Subject: [rohc] Regd. generation of state identifier for SIP static 
>dictionary(rfc 3485)
>Date: Mon, 08 Mar 2004 15:11:56 +0530
>
>We tried to generate the 20-byte SHA-1 hash (RFC-3174) over the byte string 
>formed by concatenating the state_length, state_address, state_instruction, 
>minimum_access_length and state_value(in that order) with the values given 
>in the rfc 3485 (pg.7) for the static dictionary. The result didnot match 
>with the state-identifier given for the same.The procedure we followed is 
>according to the rfc 3320. I have verified the input many times and even 
>with different implementations of SHA-1 hash, but it didn't work. This is 
>very important and urgent. Please help me out of this problem.
>
>Thanks and regards,
>Sasidhar

_________________________________________________________________
Tired of 56k? Get a FREE BT Broadband connection 
http://www.msn.co.uk/specials/btbroadband

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc