Subject: Re: [rohc] Slope used to compress/decompress RTP Timestamp field

From: "Kavitha KR" <[email-masked]>
Date: Mon, 29 Mar 2004 09:44:33 +0530

hi kamal,

I think it is rather left to implementation.
For e.g in the 3GPP2 cdma networks, the default value is simply taken to be
3.

Btw, what is 'L'?

regards,
kavitha.

                      "kamal deep                                                                                                      
                      singh"                   To:       <[email-masked]>, <[email-masked]>                                   
                      <kd.singh@enst-br        cc:       <[email-masked]>, <[email-masked]>,            
                      etagne.fr>                <[email-masked]>                                                                        
                      Sent by:                 Subject:  Re: [rohc] Slope used to compress/decompress RTP Timestamp field              
                      [email-masked]                                                                                                
                      rg                                                                                                               

                      03/27/2004 08:52                                                                                                 
                      PM                                                                                                               

Hi,

I have one question below.

> Actually for robustness, the compressor must make sure that at least two
("FO") packets with TS >field have been received by the decompressor before
it can transit to SO state and send Type-0 >packets. It will ensure that
the
decompressor acquires both slope and offset of the function from >SN to TS.

In U and O mode, how will compressor base its confidence?
By sending L + 1 or 2L packets?

Or should it be left as an implementation choice?

regards,
Kamal

This email may contain confidential or privileged information for the
intended recipient(s). If you are not the intended recipient, please do not
use or disseminate the information, notify the sender and delete it from
your system. Thanks

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "kamal deep singh" <[email-masked]>
Date: Tue, 30 Mar 2004 15:51:49 +0200

Hi Kavitha,

'L' is one of the parameters used in U and O mode of ROHC.

You will find it written in section 5.3.1.1.1 that .

"The compressor normally obtains its confidence about decompressor
   status by sending several packets with the same information according
   to the lower compression state.  If the decompressor receives any of
   these packets, it will be in sync with the compressor.  The number of
   consecutive packets to send for confidence is not defined in this
   document.
"
The number of consequetive packets to send is 'L'

regards,
Kamal

>                       singh"                   To:
<[email-masked]>, <[email-masked]>
>                       <kd.singh@enst-br        cc:
<[email-masked]>, <[email-masked]>,
>                       Sent by:                 Subject:  Re: [rohc] Slope
used to compress/decompress RTP Timestamp field