Subject: RE: [rohc] Question of ROHC

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Wed, 24 Mar 2004 08:33:07 +0100

In the static and dynamic chains, the outer fields obviously preceeds the inner fields,
as that is the order in which they appear in the original header(s). As the static and
dynamic chains are only implicitly defined as chains of fields from the original
header(s), there is not really any other way these can be ordered. When corresponding
fields are present in compressed headers or their extensions, the order and encoding
of the fields are explicitly defined for each packet format, and as you have noted the
inner fields are put before the outer in extension 3. At this point in time, we can of
course discuss why this is the case, but arguing that it should had been the other way
around does not help us much as we can not change the way it is defined (and it
is just a cosmetic issue anyway). I would guess the reason the fields are put in this
order is to have the fields that are most commonly present listed first, and "inner" is
defined as the fields corresponding to the fields of one single IP header (see top of page 86).
 
BR
/L-E

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: den 24 mars 2004 02:43
To: Lars-Erik Jonsson (LU/EAB)
Cc: [email-masked]
Subject: RE: [rohc] Question of ROHC

Hi,L-E 

Thanks for your answer! I agree with u! 

I think in implementer guide, it should be made clearly that whether Outer IP static part preceeds Inner IP static part or not if inner IP exists 

Outer IP/AH/Inner IP/AH/ESP/UDP/RTP 

According to extension 3, Inner IP preceeds Outer IP, so I think in IR packets maybe the following format( Inner IP preceeds Outer IP) is better: 
  +---+---+---+---+---+---+---+---+ 
  |    Inner IP static part???    | 
 |    Outer IP static part???    |static chain 
 |        UDP static part        | 
 |        RTP static part        |variable length 
  +---+---+---+---+---+---+---+---+ 
 |      Inner IP dyn part???     | 
 |      Outer IP dyn part???     |static chain 
 |                               | 
  +---+---+---+---+---+---+---+---+ 

Outer IP static part preceeds Innter IP 

  Extension 3:

     0     1     2     3     4     5     6     7
  +-----+-----+-----+-----+-----+-----+-----+-----+
  |  1     1  |  S  |R-TS | Tsc |  I  | ip  | rtp |            (FLAGS)
  +-----+-----+-----+-----+-----+-----+-----+-----+
  |            Inner IP header flags        | ip2 |  if ip = 1
   ..... ..... ..... ..... ..... ..... ..... .....
  |            Outer IP header flags              |  if ip2 = 1
   ..... ..... ..... ..... ..... ..... ..... .....
  |                      SN                       |  if S = 1
   ..... ..... ..... ..... ..... ..... ..... .....
  /       TS (encoded as in section 4.5.6)        /  1-4 octets,
   ..... ..... ..... ..... ..... ..... ..... .....   if R-TS = 1
  |                                               |
  /            Inner IP header fields             /  variable,
  |                                               |  if ip = 1
   ..... ..... ..... ..... ..... ..... ..... .....
  |                     IP-ID                     |  2 octets, if I = 1
   ..... ..... ..... ..... ..... ..... ..... .....
  |                                               |
  /            Outer IP header fields             /  variable,
  |                                               |  if ip2 = 1
   ..... ..... ..... ..... ..... ..... ..... .....
  |                                               |
  /          RTP header flags and fields          /  variable,
  |                                               |  if rtp = 1
   ..... ..... ..... ..... ..... ..... ..... .....

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: [email-masked]
Date: Wed, 24 Mar 2004 14:48:37 +0530

Hi all,
      Can anyone tell me if there are any open-source implementations
      available for "Deflate" compression algorithm.

thanks and regards
Jyoti

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc