Subject: [rohc] how to tell p to peer decompressor entity?

From: [email-masked]
Date: Mon, 22 Mar 2004 16:42:26 +0800

f(v_ref, k) = [v_ref - p, v_ref + (2^k - 1) - p]

In chapter 4.5.1.Least Significant Bits (LSB) encoding/RFC3095
 
  The interpretation interval can be described as a function f(v_ref, k). 
Let
              f(v_ref, k) = [v_ref - p, v_ref + (2^k - 1) - p]
   where p is an integer.
         <--------------------------interpretation interval (size is 
2^k)--------------------------->
 
|---------------------+--------------------------------------------------------------------|
       v_ref - p             v_ref                                v_ref + 
(2^k-1) - p

Qestion, how does the peer decompressor entity knows which value of p is 
used?
Best Regards
 
Zhou Zongming 周宗明
===========================================================================
COMMIT Incorporated
Add: 18 Shenwang Rd, Xinzhuang Industrial Development Zone, Shanghai China
Post Code: 201108
Tel: +86-21-5442-4885 Ext:3405
FAX: +86-21-5442-4886
Email: [email-masked]
===========================================================================
The information contained in this e-mail and any attachments thereto from 
COMMIT Incorporated is intended to be for the use of the person named 
above and may be private, confidential and privileged. If you are not the 
intended recipient of this transmission, you are hereby notified that any 
disclosure, copying, distribution, printing or use of the contents of this 
communication is strictly prohibited. If you have received this e-mail in 
error, please notify the sender immediately and permanently delete the 
original and any copies of this email and any attachments thereto.

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Mon, 22 Mar 2004 10:05:09 +0100

p is fixed for each packet format, see e.g page 75 of RFC 3095.
 
/L-E

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of [email-masked]
Sent: den 22 mars 2004 09:42
To: [email-masked]
Subject: [rohc] how to tell p to peer decompressor entity?

    
  The interpretation interval can be described as a function f(v_ref, k). Let 
              f(v_ref, k) = [v_ref - p, v_ref + (2^k - 1) - p] 
   where p is an integer. 
         <--------------------------interpretation interval (size is 2^k)---------------------------> 
         |---------------------+--------------------------------------------------------------------| 
       v_ref - p             v_ref                                v_ref + (2^k-1) - p 

Qestion, how does the peer decompressor entity knows which value of p is used? 
Best Regards

Zhou Zongming 周宗明
The information contained in this e-mail and any attachments thereto from COMMIT Incorporated is intended to be for the use of the person named above and may be private, confidential and privileged. If you are not the intended recipient of this transmission, you are hereby notified that any disclosure, copying, distribution, printing or use of the contents of this communication is strictly prohibited. If you have received this e-mail in error, please notify the sender immediately and permanently delete the original and any copies of this email and any attachments thereto. 

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.