Subject: Re: [rohc] SIP and SigComp

From: Carsten Bormann <[email-masked]>
Date: Mon, 1 Mar 2004 21:08:17 +0900

On Feb 25 2004, at 15:35 Uhr, Jaspreet Singh wrote:

> Hi,
>  
> Is there any recommended compression algorithm for compressing SIP 
> using sigcomp ?

Jaspreet,

you are probably aware that the whole point of SigComp is that there is 
no need to agree on compression algorithms to achieve interoperability.
So I read your question as "what are good compression algorithms that 
could be used for compressing SIP with SigComp?".

Research papers that attempt to answer this question are starting to 
appear.
Clearly, important issues that haven't been discussed in the existing 
literature are:

-- balancing decompressor code size with compression efficiency
-- extracting maximum benefit from state management
-- making good use of the static SIP/SDP dictionary (RFC 3485) 

Gruesse, Carsten

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Mon, 1 Mar 2004 12:32:39 -0000

Hi Jaspreet,

The SigComp User Guide has bytecode for five compression
algorithms that can be used for compressing SIP: these
are LZSS, LZW, DEFLATE, LZJH and EPIC. Any of these
algorithms will give a good performance when compressing
SIP messages.

We don't recommend a single "best" algorithm for SIP
because there isn't one: the best algorithm for you
depends on whether you're interested in high compression
radio, low processing and memory requirements, simple
design etc., and whether you're worried about using
IPR-encumbered technology. SigComp lets each implementer
make their own choice of compression algorithm.

The current version of the user guide has just expired
(oops - must remember to update it), but is available from:

http://www.roke.co.uk/networks/epic/draft-ietf-rohc-sigcomp-user-guide-00.tx
t

Regards,

Richard

-----Original Message-----
From: Jaspreet Singh [mailto:[email-masked]]
Sent: Wednesday, February 25, 2004 2:36 PM
To: [email-masked]
Subject: [rohc] SIP and SigComp

Hi,

Is there any recommended compression algorithm for compressing SIP using
sigcomp ? 

Can someone please point me to a web resource which analyses how different
compression algorithms perform when used along with sigcomp for compressing
SIP.

Cheers,
Jaspreet