Subject: RE: [rohc] Examples for Uni-Directional Compression

From: "Richard Price" <[email-masked]>
Date: Fri, 16 Apr 2004 12:02:21 +0100

Hi Jyoti,

It's not the case that you can set the code_len field to 0 and
rely on the UDVM to output the message as-is, because this
behaviour isn't specified in RFC 3320. What you have to do
instead is to send a (small) piece of bytecode that tells the
UDVM to output the message unchanged (i.e. you need to
upload a "null" decompression algorithm to the UDVM).

Here's an example of how to do this. Prepend the following
13 bytes to the front of an uncompressed message, and
the UDVM will output the data directly without modification:

0xf8, 0x00, 0xa1, 0x1c, 0x01, 0x86, 0x09, 0x22,
0x86, 0x01, 0x16, 0xf9, 0x23, <uncompressed data>

The first three bytes are the SigComp header; the other
ten correspond to the following bytecode:

INPUT-BYTES(1, 64, 9)
OUTPUT(64, 1)
JUMP(-7)
END-MESSAGE

This bytecode just tells the UDVM to output the data
unchanged. Moreover, because the uncompressed
message is encapsulated in a SigComp message, you can
send feedback using the SigComp feedback mechanism ;-)

Hope this helps...

Regards,

Richard

>From: [email-masked]
>To: "Richard Price" <[email-masked]>
>CC: [email-masked], [email-masked], [email-masked],   
>[email-masked], [email-masked], [email-masked],   
>[email-masked], [email-masked], [email-masked],   
>[email-masked]
>Subject: RE: [rohc] Examples for Uni-Directional Compression
>Date: Fri, 16 Apr 2004 15:54:56 +0530
>
>
>
>
>
>Hi Richard,
>       From your mail I understand that in downlink direction (which does
>not want to do compression),the sigcomp message can be formed with
>following specifications to achieve higher compression ratio:-
>1.  Returned feedback data containing state information
>2. The 12-bit code_len field which specifies the size of the uploaded UDVM
>bytecode must be set to zero (to specify "null" decompression algorithm)
>
>So incase Decompressor dispatcher receives SigComp message which has
>code_len field set to zero then it must return the message as it to the
>application but it must process the feedback response.
>
>Please confirm if this understanding is correct.
>
>thanks and regards
>Jyoti

_________________________________________________________________
Use MSN Messenger to send music and pics to your friends 
http://www.msn.co.uk/messenger

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: suman <[email-masked]>
Date: Fri, 16 Apr 2004 17:18:39 +0530

Hi,
   This solution works fine only if the application is willing to create a
compartment
even when he actually does not want to send compressed messages.

If the application is adamant and not willing to create a compartment in
case it does
not want to send compressed messages, then there is no way to convey the
feedback
mechanism...

thanks
suman
----- Original Message -----
From: "Richard Price" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Friday, April 16, 2004 4:32 PM
Subject: RE: [rohc] Examples for Uni-Directional Compression