Subject: [rohc] Compressor Requirement as per RFC 3320

From: [email-masked]
Date: Fri, 23 Apr 2004 10:20:29 +0530

Hi all,
I have a doubt in a requirement of compressor/compressor dispatcher
as described in section-5 of RFC 3320. It says :
"The compressor MUST ensure that the message can be decompressed
 using the resources available at the remote endpoint."

Doubt :
-------
RFC 3320 provides feedback mechanism to advertize endpoints's
local capabilities/resources(sigcomp parmeters like decompression memory
size)
to remote end and it is sent as piggy-backed in the sigcomp message.

How a compressor (sender end) will know the
"remote end configuration/resources" [to ensure the successful
decompression using the resources available at the remote
endpoint] as it does not know other end's resource availability before
sending
a message incase it is the session initiating end point.

Since feedback request is sent piggybacked with sigcomp message
so how can endpoint advertize its local configuration/resources
to remote end so that remote end can use this information
effectively to take decision *to ensure successful decompression*.

Please clarify my doubt on this requirement of compressor.

thanks and regards
Jyoti

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Richard Price" <[email-masked]>
Date: Fri, 23 Apr 2004 10:19:18 +0100

Hi Jyoti,

Since standalone feedback messages are normally banned
for security reasons, the very first message in the exchange
must be decompressible using only the minimum resources
guaranteed to be available at the remote endpoint. For
SIP/SigComp, the minimum resources that must be provided
by every endpoint are in <draft-ietf-rohc-sigcomp-sip-01.txt>.

Regards,

Richard

>From: [email-masked]
>To: [email-masked], [email-masked], [email-masked]
>Subject: Compressor Requirement as per RFC 3320
>Date: Fri, 23 Apr 2004 10:20:29 +0530
>
>
>
>
>
>Hi all,

_________________________________________________________________
Express yourself with cool new emoticons http://www.msn.co.uk/specials/myemo