Subject: [rohc] SigComp state management question

From: Stefan Foeckel <[email-masked]>
Date: Wed, 14 Apr 2004 21:35:11 +0200

Hello rohc,

I have a question regarding the state management in sigcomp.

Consider the following situation:

The state handler contains a state item with id X, which is assoiated
to a certain compartment with retention_priority n.

Now, assume the state handler receives a request to create state with
the same id X, for the same compartment, but with a different priority
m.

What is the appropriate course of action ? Should the new state item
added to the compartment (together with the new priority), or is the
already existing state to be updated (with respect to its
retention_priority) ?

Best regards
Stefan

--
Mit freundlichen Grüssen         Phone: +49 30 34637141
Stefan Foeckel                   Fax  : +49 30 34638141
http://www.fokus.fraunhofer.de   ICQ  : 46655019

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Thu, 15 Apr 2004 08:03:12 +0100

Hi Stefan,

This has been discussed previously on the list and the conclusion (update the existing state) is in the implementer's guide available from http://www.ietf.org/internet-drafts/draft-ietf-rohc-sigcomp-impl-guide-02.txt (section 5.2).

Best regards,

Abbie

> -----Original Message-----
> From: Stefan Foeckel [mailto:[email-masked]] 
> Sent: Wednesday, April 14, 2004 8:35 PM
> To: [email-masked]
> Subject: [rohc] SigComp state management question
> 
> 
> Hello rohc,
>