Subject: [rohc] UOR-2 packets with TS_STRIDE and Tsc equal to 1 in Extension 3

From: "Pawel Szymanski" <[email-masked]>
Date: Thu, 1 Apr 2004 16:06:14 +0200

Hi,

I've run into a problem with UOR-2 packet Tsc field equal to 1 Extension 3 and 
with TS_STRIDE. Is it legal to send such packets ?

If Yes, how decompressor should calculate new TS_OFFSET to decompress the 
scaled TS value compressed in the packet ? 
Should it calculate the new TS_OFFSET using the reference timestamp value (i.e. 
the value sent in the last successfully decompressed packet containing TS 
field) ? 

Another option is to calculate the new TS_OFFSET using the tiemstamp value sent 
in the last decompressed packet (which can be diffrent from the reference 
timestamp value) ?

Or should decompressor use the old TS_OFFSET to decompress the received packet ?

Best Regards 

Pawel

----------------------------------------------------
Co przyniesie w tym roku Zając? Chcesz mu pomóc?
Kicnij się na wielkanocne zakupy.wp.pl
http://klik.wp.pl/?adr=http%3A%2F%2Fzakupy.wp.pl%2Fwielkanoc.html&sid=155

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Kavitha KR" <[email-masked]>
Date: Mon, 5 Apr 2004 20:15:37 +0530

Hi Pawel,

>Do you think that section 4.5.3 Page 29, Point 1 means that sending
packets
>containing both scaled TS field and TS_STRIDE is illegal ?

===> Surely I dont think so. Whether the packet under our discussion is
legal,
     is not clearly asserted by the RFC. I do agree.
     I only was indicating that in your example, since there seems to be no
other
     go to communicate both the parameters clearly, (in the current RFC or
imple guide)
     we can as well resort to the "most common" initialization scenario. :
-)

     Well, such subtle points should really go into implementation guide.

Regards,
Kavitha.