Subject: RE: [rohc] Examples for Uni-Directional Compression

From: "Richard Price" <[email-masked]>
Date: Thu, 15 Apr 2004 16:37:08 +0100

Hi Saurabh,

Compression is relatively expensive in terms of memory
and processing power, so it might be worth only
compressing in one direction if there is an asymmetric
link in the network (e.g. a satellite link). You could
compress in the direction where bandwidth is scarce,
and leave the messages uncompressed in the
direction where bandwidth is plentiful.

Regards,

Richard

>From: [email-masked]
>To: [email-masked]
>Subject: [rohc] Examples for Uni-Directional Compression
>Date: Thu, 15 Apr 2004 20:06:08 +0530
>
>
>
>
>
>Hi all,
>      RFC 3320 mentions that unidirectional compression is possible using
>SIGCOMP.
>According to my understanding
>
>       A
>B
>       |        SiGComp Compressed Message       |
>       |---------------------->----------------------------------- |
>       |                             |
>       |                             |
>       |  Un Compressed Message (normal)   |
>       |-----------------------<---------------------------------- |
>       |                             |
>       |                             |
>
>That means that Endpoint B is also SIGCOMP aware .
>My basic doubts is in which pratical scenario Endpoint B will choose to
>send
>normal message in place of the compressed messages.This is will drastically
>effect the compression ratio.
>
>Thanks & Regards
>Saurabh
>
>Saurabh Gupta - HSS Bangalore Ext 7067
>
>
>_______________________________________________
>Rohc mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/rohc

_________________________________________________________________
Use MSN Messenger to send music and pics to your friends 
http://www.msn.co.uk/messenger

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: [email-masked]
Date: Fri, 16 Apr 2004 10:54:45 +0530

Hi Richard,
       I have another doubt in this :- Incase application wants to compress
in one
direction (say uplink) and not in other direction (day downlink) then  how
can
"feedback mechanism" be used to establish the "state" (since the ack for
the state
established is sent in sigcomp message and remote application is not
sending
any sigcomp message).
Further,that means in case the compression is uni-directional and feedback
mechanism
can not be used for establishing state ,So overall compression ratio will
be very less
(because decompression bytecode will be sent everytime).

So, Doubt is that although in practical scenario, compression in one
direction is possible
but which mechanism does SigComp provide to achieve this feature so that
compression
ratio is less.

regards
Jyoti

             "Richard Price"                                               
             <ellyptic@hotmail                                             
             .com>                                                      To 
             Sent by:                  [email-masked],             
             [email-masked]         [email-masked]                       
             rg                                                         cc 
                                                                           
                                                                   Subject 
             04/15/04 09:07 PM         RE: [rohc] Examples for             
                                       Uni-Directional Compression         

                                                                           

Hi Saurabh,

Regards,

Richard