Subject: RE: [rohc] UOR-2 packets with TS_STRIDE and Tsc equal to 1 in Ext ension 3

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Mon, 5 Apr 2004 17:45:52 +0200

The editor appreciates any text proposals that the group can consider
and hopefully reach consensus on. At the moment, we are trying to
figure out what to do with the slope(s) issue, so I guess that will
still be my focus for a while (it is a tricky issue but hopefully we
will soon start to understand each other). Please continue also this
discussion and propose text.

Cheers,
/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Kavitha KR
> Sent: den 5 april 2004 16:46
> To: Pawel Szymanski
> Cc: [email-masked]
> Subject: Re: [rohc] UOR-2 packets with TS_STRIDE and Tsc equal to 1 in
> Extension 3
> 
> 
> 
> Hi Pawel,
> 
> >Do you think that section 4.5.3 Page 29, Point 1 means that sending
> packets
> >containing both scaled TS field and TS_STRIDE is illegal ?
> 
> ===> Surely I dont think so. Whether the packet under our 
> discussion is
> legal,
>      is not clearly asserted by the RFC. I do agree.
>      I only was indicating that in your example, since there 
> seems to be no
> other
>      go to communicate both the parameters clearly, (in the 
> current RFC or
> imple guide)
>      we can as well resort to the "most common" 
> initialization scenario. :
> -)
> 
>      Well, such subtle points should really go into 
> implementation guide.
> 
> Regards,
> Kavitha.
> 
> 
> 
> 
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Wed, 7 Apr 2004 13:31:16 +0200

Agreed, good summary!!

I'll put this to my list of things to fix in the implementers guide.

Rgds,
/L-E

> My suggestion would be to clarify the following in the 
> implementation guide.
> Comments?
> - Text on Extension 3 in section 5.7.5 should read context(TS_STRIDE)
> - When a compressor uses Extension 3 to re-establish a new value for
> TS_STRIDE, it must send unscaled TS and TS_STRIDE for some
> packets until decompressor confidence is obtained. In other words,
> Tsc must be set to 0 (zero) in Extension 3 when TS_STRIDE field is present.
> 
> BR,
> Zhigang