Subject: [rohc] doubt regarding shared compression in rfc 3321

From: suman <[email-masked]>
Date: Mon, 05 Apr 2004 09:18:27 +0530

Section 5.2 of rfc 3321 speaks about Shared Compression as follows.

1. compressor 1 saves the state M which is the uncompressed version of the current message
compressed and sent.

2. At the decompressor 2 in the receiving endpoint, SHA-1 instruction is used to calculate the
state-id for state M.

I am not able to figure out, over which piece of information should the SHA-1 instruction be executed ???

Could anybody clarify my doubt in this regard,

thanks
suman

---

From: "Hans Hannu (LU/EAB)" <[email-masked]>
Date: Mon, 5 Apr 2004 15:40:44 +0200

Hi Suman,

> But i am not able to figure out how this bytecode could be intelligent
> enough to "announce" the shared state..
> How exactly will the bytecode generate the shared state which 
> should be same
> as step 4.
> 

If I remember correctly there was a chapter in the "SigComp User Guide", by Richard Price et al., giving such a bytecode. However, that draft seems to have expired, but perhaps someone else has that information.

BR,
/Hans Hannu

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc