Subject: RE: [rohc] OUTPUT: no message or zero byte message?

From: "Surtees, Abigail" <[email-masked]>
Date: Thu, 3 Mar 2005 10:00:53 -0000

Hi Zacco,

I think (and am hoping someone will correct me if I'm wrong) that the reason
is to allow the two cases to be signalled to the application.  If you were
to apply SigComp (which is *not* just for SIP) to a protocol that allowed a
'null' payload, then you may wish to distinguish between successfully
'decompressing' a null payload and not actually decompressing anything (e.g.
to modify state in only one of these cases).

I hope this helps.

Best regards,

Abbie

> 
> -----Original Message-----
> From: Lajos Zaccomer (IJ/ETH) [mailto:[email-masked]] 
> Sent: Wednesday, February 02, 2005 12:11 PM
> To: [email-masked]
> Cc: Surtees, Abigail
> Subject: OUTPUT: no message or zero byte message?
> 
> 
> Hi,
> 
> Could anyone tell me, what was the reason to include the 
> following passage
> in RFC 3320 (9.4.8 OUTPUT):
> 
>    Since there is technically a difference between outputting a 0-byte
>    decompressed message, and not outputting a decompressed message at
>    all, the OUTPUT instruction needs to distinguish between the two
>    cases.  Thus, if the UDVM terminates before encountering an OUTPUT
>    instruction it is considered not to have outputted a decompressed
>    message.  If it encounters one or more OUTPUT instructions, each of
>    which provides 0 bytes of data to the dispatcher, then it is
>    considered to have outputted a 0-byte decompressed message.
> 
> Thanx:
> Zacco
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lajos Zaccomer \(IJ/ETH\)" <[email-masked]>
Date: Thu, 3 Mar 2005 11:14:02 +0100

Hi Abbie,

It makes sense. I indeed limited my thoughts to SIP.

br/Zacco

> From: Surtees, Abigail [mailto:[email-masked]]
> Sent: Thursday, March 03, 2005 11:01 AM
> To: [email-masked]; Lajos Zaccomer (IJ/ETH)
> Subject: RE: [rohc] OUTPUT: no message or zero byte message?
> 
> 
> Hi Zacco,
> 
> -- 
> Visit our website at www.roke.co.uk
> 
> Roke Manor Research Ltd, Roke Manor, Romsey, Hampshire SO51 0ZN, UK.
> 
> The information contained in this e-mail and any attachments 
> is proprietary to
> Roke Manor Research Ltd and must not be passed to any third 
> party without
> permission. This communication is for information only and 
> shall not create or
> change any contractual relationship.
> 
>