Subject: RE: [rohc] About UDVM registers!

From: "Chintan Shah" <[email-masked]>
Date: Mon, 21 Mar 2005 13:16:21 +0530

Achut,

Byte-copy-Left & Byte-copy-Right are required to achieve the concept of
Circular Buffer within UDVM.

You can refer to implementation guide {Section 4} for more details on
its usage.

Cheers,
Chintan Shah

---------------------------------------------------------------
Chintan Shah
LG Soft India
7th Floor | Embassy Icon | Infantry Rd | Bangalore-17
M: (+91)  94487 60715

"Start by doing what is necessary,
then what is possible, and
suddenly you are doing the impossible"
                                                    -St. Francis of
Assisi
----------------------------------------------------------------
Add me
<https://www.plaxo.com/add_me?u=12885040721&v0=273750&k0=712584191>  to
your address book...

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Achut Kamath
Sent: Monday, March 21, 2005 1:05 PM
To: [email-masked]
Subject: [rohc] About UDVM registers!

Hello All,
  I am new to Sigcomp, and I guess this is a very basic doubt...
I am not able to understand the concept of byte_copy_left and
byte_copy_right. I am not able to follow why these registers are
required for UDVM. Could anyone please tell me what is the idea behind
the usage of these two registers? Why are these required? I guess we can
do memory copy without these registers also!

Thanks in advance !

Best Regards,
Achuth

**********************************************************************************************************************************************************

This email message is for the sole use of the intended recipient(s)and may contain CONFIDENTIAL and PRIVILEGED information.
LG Soft India will not be responsible for any viruses or defects or any forwarded attachments emanating either from within
LG Soft India or outside. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended
recipient, please contact the sender By reply email and destroy all copies of the original message.

**********************************************************************************************************************************************************

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Achut Kamath" <[email-masked]>
Date: Mon, 21 Mar 2005 14:23:17 +0530

Thanks, Chintan!
 
  When copy is requested from some address m to address n, of length l
bytes, how these registers help? Is some byte copied from m to register
and then to n? Why this circular Buffer concept is required in UDVM? I
am sorry if this is very basic, but I am confused.
 
Thanks again!
 
Best Regards,
Achuth

-----Original Message-----
From: Chintan Shah [mailto:[email-masked]] 
Sent: Monday, March 21, 2005 1:16 PM
To: Achut Kamath; [email-masked]
Subject: RE: [rohc] About UDVM registers!
 
Achut,

 
Cheers,
Chintan Shah

"Start by doing what is necessary,
then what is possible, and
suddenly you are doing the impossible"
                                                    -St. Francis of
Assisi
----------------------------------------------------------------
 <https://www.plaxo.com/add_me?u=12885040721&v0=273750&k0=712584191> Add
me to your address book...
 
  _____  

  I am new to Sigcomp, and I guess this is a very basic doubt. 
 
Thanks in advance !
 
Best Regards,
Achuth
************************************************************************
************************************************************************
**********

This email message is for the sole use of the intended recipient(s)and
may contain CONFIDENTIAL and PRIVILEGED information.
LG Soft India will not be responsible for any viruses or defects or any
forwarded attachments emanating either from within 
LG Soft India or outside. Any unauthorized review, use, disclosure or
distribution is prohibited. If you are not the intended 
recipient, please contact the sender By reply email and destroy all
copies of the original message.

************************************************************************
************************************************************************
**********