Subject: [rohc] Hi folks -- Its Me again!

From: "Achuth Kamath" <[email-masked]>
Date: Tue, 22 Mar 2005 11:04:57 +0530

Hi,
  I got some doubt regarding the feedback mechanism of Sigcomp.
In the RFC 3320, the Sigcomp packet format has mention of
returned_feedback_item. So, when some feedback request has come, we can
fill this field and the compressor can send the Sigcomp packet. Now, how
do we request for a feedback? Page 53 of RFC3320 does give the format of
requested_feedback_item, but where exactly do we put this into the
Sigcomp packet.
 
In short, my question is: How does a compressor request for feedback
item? Where does the requested feedback field feature in the Sigcomp
packet?
 
Thanks in Advance!
 
Best Regards,
Achuth
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Achuth Kamath" <[email-masked]>
Date: Tue, 22 Mar 2005 11:47:57 +0530

Thanks, Sasidhar! I understood how the feedback request is done.
 
But this results in two doubts in my mind:
1.	Why the returned_feedback_item is also not treated similar to
requested_feedback_item? Instead of having in the packet structure, we
can have it in some memory location as the requested feedback, and can
be given in END-MESSAGE instruction. What is the reason for this
difference?
2.	If the requested feedback location is given in the bytecode, it
means that the bytecode should be changed each time the location
changes. Now, what if I plan to use the same byte code, say some
standard compression algorithm like DEFLATE suppose, in this case, I
should know where the END-MESSAGE points for the requested feedback
item, right? Does it mean the compressor should always put the requested
feedback item at the same pre-defined place for a given decompression
algorithm?
 
Thanks and Best Regards,
Achuth
 
-----Original Message-----
From: sasidhar [mailto:[email-masked]] 
Sent: Tuesday, March 22, 2005 11:20 AM
To: Achuth Kamath
Subject: Re: [rohc] Hi folks -- Its Me again!
 
Hi,
    Please refer to 9.4.9.  END-MESSAGE of RFC 3320. We need to specify
the requested feedback location in the End-message instruction of the
bytecode.
 
with regards,
sasidhar 
----- Original Message ----- 
From: Achuth <mailto:[email-masked]>  Kamath 
To: [email-masked] 
Sent: Tuesday, March 22, 2005 11:04 AM
Subject: [rohc] Hi folks -- Its Me again!
 
Hi,

Thanks in Advance!
 
Best Regards,
Achuth

  _____