Subject: [rohc] SigComp torture tests, Bytecode state creation

From: Herve Siegrist <[email-masked]>
Date: Mon, 14 Mar 2005 08:47:36 +0100

I am running into some trouble with the "Bytecode state
creation" (section 4.5) test of the SigComp torture tests
and I would like to check what is going on there...

 From the look of the assembly code (and what I get when
running the test), it seems to me that the output of the test
in the second case should be "OK2", and not "OK1" as stated
in the draft.

Same thing for the third test whose output is 0x0000 32
instead of the stated 0x0000 31.

Looks to me that the information saved in the state, and
therefore output by the test, is really OK2, and not OK1,
hence the result I am getting...

Did I miss something and should the output really be OK1,
or is the problem really in the draft?

Thanks,
Herve.

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Mon, 14 Mar 2005 09:36:14 -0000

Hi Herve,

I agree with you - see the mail I've just sent.

Best regards,

Abbie

> -----Original Message-----
> From: Herve Siegrist [mailto:[email-masked]] 
> Sent: Monday, March 14, 2005 7:48 AM
> To: [email-masked]
> Subject: [rohc] SigComp torture tests, Bytecode state creation
> 
>