Subject: [rohc] UO-1 and R-1 in UDP/ESP profiles

From: Kristofer Sandlund <[email-masked]>
Date: Wed, 30 Mar 2005 15:00:55 +0200

Hi all,

I think there's a slight ambiguity in 3095 regarding these packet formats in the 
case where we have only RND IP-IDs in the packet. In that case, the IPID is sent 
in full, but we still have a IP-ID LSB field that's being transmitted.

Clearly, this field should be ignored in this case, but the spec does not 
explicitly say what the compressor and decompressor should do about them. 
Possibly interpretations could be:

1) Compressor sends the LSBs in this field and the decompressor verifies that 
these LSBs are the same as the ones sent as "random".
2) Compressor must set these bits to zero and decompressor verifies that
3) Compressor can set any random value it likes (but preferrably zero) and the 
decompressor must ignore whatever is in this field.

Since a RND IP-ID can mean a IPv6 header, I think we can rule out 1) as a 
reaonable option. And to verify that the bits are zero seems useless, so why 
don't we just add a couple of sentences to the impl. guide to say that 3) is the 
way to do things?

BR,
	Kristofer Sandlund, Effnet AB

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Wed, 30 Mar 2005 15:08:37 +0200

Sounds reasonable, I'll add that to my impl.guide to-do-list.

/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Kristofer Sandlund
> Sent: den 30 mars 2005 15:01
> To: [email-masked]
> Subject: [rohc] UO-1 and R-1 in UDP/ESP profiles
> 
> 
> Hi all,
>

---

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Thu, 31 Mar 2005 14:16:49 +0200

So, I've added the following to the end of the second paragraph of 8.2:

  "When there is no compressed IP-ID, i.e. for IPv6 or when all
   IP Identification information is sent as-is (as indicated by
   RND/RND2 being set to 1), the decompressor ignores IP-ID bits
   within compressed base headers."

/L-E

> Lars-Erik Jonsson (LU/EAB)
> Sent: den 30 mars 2005 15:09
> To: Kristofer Sandlund; [email-masked]
> Subject: RE: [rohc] UO-1 and R-1 in UDP/ESP profiles
> 
> 
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Kristofer Sandlund