Subject: RE: [rohc] Paris <--> rohc ???

From: "Finking, Robert" <[email-masked]>
Date: Tue, 19 Jul 2005 08:42:14 +0100

Hi L-E, all,

Thanks for this. On the ROHC-TCP/FN front what is there to discuss in deciding if we can ship it? This question arises partly out of me being unfamiliar with IETF procedures such as WGLC.

What I'm looking to avoid is either:
1. Turning up at the IETF for no good reason - though it would be great to meet up =)
2. Not turning up and finding out afterwards that key decisions about the FN have been made that I wasn't party to. Whilst in theory all decisions are made on the list, I know from past experience that if people agree something at an IETF they tend to stick.

Thanks in advance

Raffles (secretly hoping there IS a good reason to go, and that I can get funding...)

-----Original Message-----
From: Lars-Erik Jonsson (LU/EAB) [mailto:[email-masked]] 
Sent: Monday, July 18, 2005 6:49 PM
To: West, Mark; [email-masked]
Subject: RE: [rohc] Paris <--> rohc ???

Mark, rohc'ers,

You've made a correct observation, at the last minute we decided
to request a meeting slot for ROHC. Considering what we currently
have in our charter and the current proposals for new work, I see
the following that could potentially benefit from some face2face
discussion bandwidth:

SigComp:
  - Implementer's guide
  - Torture tests
  - User guide
  - Interest in doing work towards DS

ROHC TCP
  - Can we now ship ROHC TCP, i.e. the TCP profile draft + notation?

ROHC RTP
  - Appendix B of the implementer's guide, i.e. "lessons learned"
  - How to make ROHC reordering-tolerant (new requirement, draft exists)

ROHC over MPLS
  - Work is ongoing in AVT, we need to monitor and review this
    from a ROHC point of view (AVT WG drafts)

ROHC over IPsec
  - New work proposal, draft exists

Are there other issues?? Which one(s) do YOU think we should focus on?

BR
/L-E

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of West, Mark
Sent: den 13 juli 2005 19:22
To: [email-masked]
Subject: [rohc] Paris <--> rohc ???

Hi all, 
A colleague was looking through the draft IETF agenda this morning and I 
jokingly asked when the rohc session was.  Imagine my surprise when I 
received the answer, 'Monday afternoon'! 
I hadn't actually planned on going to Paris, but largely because I didn't 
think that there'd be any rohc goings-on to tempt me.  At this stage, I 
can't say whether I would attend or not, but I'm going to need a better 
justification than, 'the draft agenda's got a rohc session on it'... 
... so, does anyone know whether this rohc session is merely the figment 
of an over-active imagination within the secretariat, or whether there's a 
proposal to get together and do serious rohc stuff?  And, if the latter, 
what actually *is* the plan?! 
A bientot, 
Mark. 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 19 Jul 2005 10:27:34 +0200

> Thanks for this. On the ROHC-TCP/FN front what is there to discuss in 
> deciding if we can ship it? This question arises partly out of me 
> being unfamiliar with IETF procedures such as WGLC.

I plan to send out a WGLC for the two documents today.
We don't have CDRs (committed document reviewers) yet for the TCP 
profile, so I plan to CC tcpm and try to find CDRs there.
Completion of the WGLC will depend on actual CDR reviews showing up.

Right now, ROHC is scheduled for Monday afternoon (which might change).
If everything goes well, we will be close to completing the WGLC at 
this time.
Now the hard part is predicting *what* the WGLC input will be, in 
particular from the CDRs.

I can imagine two scenarios:

-- no surprises, which would fit your
> 1. Turning up at the IETF for no good reason - though it would be 

-- input that actually needs to be turned around into new versions of 
the documents, which might lead to
> 2. Not turning up and finding out afterwards that key decisions about 
> the FN have been made that I wasn't party to. Whilst in theory all 
> decisions are made on the list, I know from past experience that if 
> people agree something at an IETF they tend to stick.

... and we all know that issues are best resolved in face-to-face time.

2 is a bit more likely as the documents are complex enough that 
detailed reviews will bring up at least some issues.

Gruesse, Carsten