Subject: RE: [rohc] COPY-LITERAL and COPY-OFFSET torture test

From: "Surtees, Abigail" <[email-masked]>
Date: Tue, 5 Jul 2005 15:45:34 +0100

Hi Cristian,

You are quite right.  The offset value of 1 is not used and this test does require a large amount of memory.  There isn't really anyway for the interpreter to guess the amount of memory needed.  If a large amount of memory is needed then it should be written in the draft as part of the test.

However, I think this test could be done without needing an extra large amount of memory.  I've uploaded an updated version of the draft with a new test at <http://sigcomp.srmr.co.uk/~ahs/draft-ietf-rohc-sigcomp-torture-tests-01.txt> (see my previous email).  I'd appreciate any comments, particularly on the COPY and COPY-LITERAL and COPY-OFFSET tests.

Best regards,

Abbie

Cristian wrote:

hi!

about test "2.7  COPY-LITERAL and COPY-OFFSET" in the draft "SigComp
Torture Tests".
in different memory configurations I get different results.
when interpreting the sigcomp payload spec'ed in the annex 
"A.1.7  COPY-LITERAL and COPY-OFFSET" of the same draft, the
instruction:

LOAD ($offset, 1)

unless the udvm memory is over 0x4042 bytes, causes a memory fault, 
trying to access memory outside the total memory available for the udvm.
am I wrong or is it suppossed to be so?
was the "$" intended (i.e writing through indirection)? the next
instruction:

COPY-OFFSET ($offset, 5, $destination)

does not seem to make use of what the previous LOAD has written.
that of course if my udvm has behaved itself up to the 
LOAD ($offset, 1).
using:

LOAD (offset, 1)

doesn't lead to this kind of problem; the output would be differrent,
though.
and since I'm at it: how can the interpreter "guess" the minimum udvm
memory size needed to run such a bytecode?

bye now!
cristian

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Wed, 6 Jul 2005 19:11:47 +0200

> However, I think this test could be done without needing an extra large amount of memory.  I've uploaded an updated version of the draft with a new test at <http://sigcomp.srmr.co.uk/~ahs/draft-iet…

cristian: hi! I have run the COPY and COPY-LITERAL and COPY-OFFSET tests;
got the same output as you did. no memory problems this time.

I find the comments really helpful.

bye now!
cristian

-- 
 _          | There are many people who use UNIX or Linux  
(_'_        | who IMHO do not understand UNIX.
  (_'rist   |              --David Korn  
GPG public key at wwwkeys.de.pgp.net
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Wed, 6 Jul 2005 22:24:56 +0200

> I find the comments really helpful.

cristian: I mean the comments inside the udvm code examples.