Subject: [rohc] SigComp torture tests draft

From: "Surtees, Abigail" <[email-masked]>
Date: Tue, 5 Jul 2005 15:43:19 +0100

Hi All,

I've been going through the torture tests draft and adding explanation to the tests.  Hopefully, it makes them easier to understand.  The tests that I've updated are 2.1 - 2.7 and 2.15.  What do you think?  Is the extra information helpful?  If so, I'll continue and propose text for the rest of the tests.

The only tests that have changed in terms of bytecode and the actual test being done since version 00 of the draft are:

2.6 and 2.7 - I've simplified and extended the tests.  2.7 now doesn't require any more DMS than any of the other tests.  They include extra buffer wrap checking (because this wasn't explicitly tested before).  Please can someone run these tests and see if they agree with my output and cycle counts?

2.15 and 4.5 as discussed and agreed in earlier emails.

I will submit the new version of the draft before the -0n deadline (which is the 18th July).  If anyone has any further test inputs, please propose them by next Monday 11th July.

The updated draft is available from <http://sigcomp.srmr.co.uk/~ahs/draft-ietf-rohc-sigcomp-torture-tests-01.txt>

All comments appreciated.

Best regards,

Abbie

Abbie Surtees
Senior Engineer
Roke Manor Research Ltd
Old Salisbury Lane
Romsey, SO51 0ZN
Tel:   +44 (0) 1794 833131

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Herve Siegrist <[email-masked]>
Date: Tue, 05 Jul 2005 17:17:57 +0200

Abbie,

I just ran your updated tests 2.6 and 2.7 and got the same output and 
cycles as you did... Seems fine to me.

Herve.