Subject: Re: [rohc] operator "!" in the udvmassembly (draft-ietf-rohc-sigc omp-user-guide-01.txt)

From: Cristian CONSTANTIN <[email-masked]>
Date: Fri, 1 Jul 2005 11:20:15 +0200

On Thu, Jun 30, 2005 at 03:40:13PM +0100, Surtees, Abigail wrote:
> Hi All,
> 
> > > (And yes, it should be some form of op(value) for 
> > consistency with the 
> > > other directives.)
> 
> How about the following to go in the user guide?
> 
> In the BNF of section 3.2:
> 
>    directive        =     padding / data / set
> 
> becomes:
> 
>    directive        =     padding / data / set / readonly
>    readonly         =     "readonly" "(" "0" / "1" ")"
> 
> Addition to '3.2.1 Expressions':
> 
> "   N.B. When using "!" in the assembly language to generate bytecode,
>    care must be to ensure that the address of the zero used at bytecode
>    generation time will still contain zero when the bytecode
>    is run."

cristian: a word is missing. I think it should be 
"care must be taken to ensure" instead of "care must be to ensure".  
> 
> Addition to '3.2.3. Directives':
> 
> "   The directive "readonly (n)" where n is 0 or 1 can be used to
>    indicate that an area of memory could be changed (0) or will not be
>    changed (1) during the execution of the UDVM.  This directive could be
>    used, for example, in conjunction with "!" to ensure that the address
>    of the nearest zero will still contain zero when the bytecode is
>    executed."
> 
> All comments appreciated.
> 
> Best regards,
> 
> Abbie
> 
> > > 
> > > Gruesse, Carsten
> > 
> > -- 
> >  _          | There are many people who use UNIX or Linux  
> > (_'_        | who IMHO do not understand UNIX.
> >   (_'rist   |              --David Korn  
> > GPG public key at wwwkeys.de.pgp.net
> > 

-- 
 _          | There are many people who use UNIX or Linux  
(_'_        | who IMHO do not understand UNIX.
  (_'rist   |              --David Korn  
GPG public key at wwwkeys.de.pgp.net
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Fri, 1 Jul 2005 11:28:03 +0100

Hi Cristian,

Yes, you're right.  Thanks for pointing that out.

Best regards,

Abbie