Subject: RE: Re: [rohc] Re: FW: [tcpm] WG last-call of TCP header compression

From: "Finking, Robert" <[email-masked]>
Date: Thu, 6 Oct 2005 16:08:24 +0100

OK, here's my suggestion. I'll attempt to come up with a plan of action,
based on Joe's comments and the ensuing discussions we've had, whilst
also taking into account the current availability of both myself and my
co-author. Expect some output from me by the end of next week... but
don't be surprised if it turns out to take slightly longer ;-)

I'd like to thank Joe for all the time he's put into this and for his
valuable insights. Please kick me if the next version of the draft
doesn't include him in the acknowledgements!

Regards

Raffles

> -----Original Message-----
> From: Lars-Erik Jonsson [mailto:[email-masked]] 
> Sent: Thursday, September 29, 2005 6:55 AM
> To: [email-masked]
> Cc: Finking, Robert; [email-masked]; [email-masked]
> Subject: Re: Re: [rohc] Re: FW: [tcpm] WG last-call of TCP 
> header compression
> 
> 
> > > I must admit to being slightly disheartened that
> > > somebody with a formal language background is
> > > having difficulty with the notation - it really is
> > > pretty simple considering what it's aiming to 
> > > communicate.
> 
> > That's the issue. Simple can be awkward, and things
> > even 'based on Prolog' are awkward to follow.
> > Elegant to write compact representations, and
> > elegant to run (when actual code), but inaccessible
> > as a way to communicate to another human, which is,
> > after all, what I hope the primary goal of the FN
> > would be.
> 
> Joe,
> 
> On this point I fully agree with you. As the WG knows,
> I have never had any positive feelings about the FN,
> but this has been a controversial issue and the very
> rough consensus has been to keep the FN.
> 
> Getting this clear message from someone who has not
> been part in the ROHC TCP work is really valuable, and
> it tells me we have probably made a mistake when
> fooling ourselves into believing the FN will simplify 
> understanding of ROHC TCP. This is in some way an editorial 
> issue, as we would not change anything technically, but it 
> would imply a significant re-write of the specification. At 
> this point in time, I am not sure we can get the engagement 
> to do the work needed.
> 
> Therefore, I am not sure how to go on from here, i.e.
> whether we should go on as planned and *ignore* this
> feedback, or if we should address the comment and do
> the rather significant work needed to get rid of the
> FN.
> 
> /L-E 
> 
> 
> 
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Ghyslain Pelletier (LU/EAB)" <[email-masked]>
Date: Mon, 10 Oct 2005 16:59:42 +0200

Hi RoHCers,

I've been quiet regarding comments received on ROHC-TCP.
However, I was following discussions with great interest.

Thanks to Joe for his review and comments.

I have updated the ROHC-TCP draft according to my understanding of the agreements that were reached during the discussion on most points. The updated draft is now available in xml format at the ROHC cvs repository:

http://www.dmn.tzi.org/cgi-bin/cvsweb.cgi/fn/

Comments welcome.

/Ghyslain

--
 Ghyslain Pelletier, Dipl. Ing.
 Wireless IP Optimizations
 Ericsson Research, Corporate Unit

 Ericsson AB, Laboratoriegränd 11
 Box 920, S-97128 Luleå, SWEDEN
 Phone : +46 (0)  8 404 29 43
 Mobile: +46 (0) 70 264 83 14
 Ghyslain.Pelletier at ericsson.com
 http://www.ericsson.com

-----------------------------------
 The opinions expressed in this
 message are my personal opinions.
 These opinions are not
 necessarily those of my employer,
 unless stated otherwise.
-----------------------------------