Subject: RE: [rohc] FN I-D WGLC proposed way forward

From: "Finking, Robert" <[email-masked]>
Date: Fri, 21 Oct 2005 15:46:32 +0100

Joe,

If you can provide me with an example that would be great. My own
ability to fabricate protocols for examples is not to IETF tastes (my
original version of the draft was criticised owing to my sandwich
protocol, which communicated lunch box information).

Thanks in advance

Raffles

> -----Original Message-----
> From: Joe Touch [mailto:[email-masked]] 
> Sent: Friday, October 21, 2005 3:29 PM
> To: Ghyslain Pelletier (LU/EAB)
> Cc: Finking, Robert; [email-masked]
> Subject: Re: [rohc] FN I-D WGLC proposed way forward
> 
> 
> 
> 
> Ghyslain Pelletier (LU/EAB) wrote:
> > 2. Add a note that the zero IP-ID is "observed" behavior, 
> and that for 
> > header compression the choice of the behavior to assume is 
> entirely up 
> > to the profile designer - i.e. it can handle non standard 
> behaviour... 
> > but make it clear that Zero IP-IDs are actually illegal from the 
> > IETF's point of view.
> >  
> >  
> > This is in an exemple in the FN, right? I don't think you need say 
> > more in the FN than what the exemple is trying to achieve, 
> i.e. just 
> > have a small note that "the behavior(s) of a field can be 
> whatever the 
> > profile designer chooses, and can be based on observations, and not 
> > only based on the protocol specifications". It should not 
> be guideline 
> > or anything, only to satisfy the curious reader looking at the 
> > exemple.
> >  
> > For the TCP draft, I will motivate this decision a bit more clearly.
> 
> It would be more useful if examples did NOT violate IETF 
> specs. There could be other fields that are always zero in 
> some cases or not in others (RED flags) which might be a 
> better example - in both places.
> 
> Joe
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Joe Touch <[email-masked]>
Date: Fri, 21 Oct 2005 11:08:44 -0700

As per my other post, I'm not sure now that the doc needs another
example of "fields that can be all-zeroes and thus compressed better".

IMO, just omit the IPID=0 case and it would be better (in both docs -
this and the TCP).