Subject: Re: [rohc] Sigcomp Torture Test discrepancy

From: "Sofiur Rahman Siddique (sent by Nabble.com)" <[email-masked]>
Date: Tue, 31 Jan 2006 04:44:37 -0800 (PST)

Hi All,

I am facing problem in the first test itself.

 at (64)
 :a                              pad (2)
 :b                              pad (2)
 at (128)
 JUMP (start)            ; Jump to address 255
 at (255)
 :start
 AND ($start, 21845)     ; 448 & 21845 = 320 = 0x0140
 OR ($a, 42)             ; 0 | 42 = 42 = 0x002a
 NOT ($b)                ; ~0 = 65535 = 0xffff
 LSHIFT ($a, 3)          ; 42 << 3 = 336 = 0x0150
 RSHIFT ($b, 65535)      ; 65535 >> 65535 = 0 = 0x0000

 OUTPUT (64, 4)          ; Output 0x0150 0000

The OUTPUT instruction tries to output 4 bytes from UDVM memory address 64.
The current values are 0x0150 and 0x0000.
These values sets byte_copy_left and byte_copy_right values as 0x0150 and 0x0000 respectively implying byte_copy_left value is greater than byte_copy_right.
My code gives an SEGFAULT (violation of rule 8.4) here.
In most of the torture test cases this is the problem I am facing.
Can anybody give light to me in the byte copy rule.

Regards
Siddique

--
View this message in context: http://www.nabble.com/Sigcomp-Torture-Test-discrepancy-t787961.html#a2679064
Sent from the IETF - Rohc forum at Nabble.com.
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "John Barber" <[email-masked]>
Date: Tue, 31 Jan 2006 13:53:41 -0000

Hi Siddique,
 
Byte copying rules should not affect the OUTPUT instruction in this
case.
 
The byte copying rule is discussed in a bit more detail in
http://www.ietf.org/internet-drafts/draft-ietf-rohc-sigcomp-impl-guide-0
5.txt, section 4. I think if you take a look at that it should make
things clear.
 
Regards, John

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Sofiur Rahman Siddique (sent by Nabble.com)
	Sent: 31 January 2006 12:45
	To: [email-masked]
	Subject: Re: [rohc] Sigcomp Torture Test discrepancy

	Hi All, 

	 at (64) 
	 :a                              pad (2) 
	 :b                              pad (2) 
	 at (128) 

	The OUTPUT instruction tries to output 4 bytes from UDVM memory
address 64. 
	The current values are 0x0150 and 0x0000. 
	These values sets byte_copy_left and byte_copy_right values as
0x0150 and 0x0000 respectively implying byte_copy_left value is greater
than byte_copy_right. 
	My code gives an SEGFAULT (violation of rule 8.4) here. 
	In most of the torture test cases this is the problem I am
facing. 
	Can anybody give light to me in the byte copy rule. 
	
	Regards 
	Siddique 

________________________________

	View this message in context: Re: Sigcomp Torture Test
discrepancy
<http://www.nabble.com/Sigcomp-Torture-Test-discrepancy-t787961.html#a26
79064> 
	Sent from the IETF - Rohc
<http://www.nabble.com/IETF---Rohc-f13077.html>  forum at Nabble.com.