Subject: Re: [rohc] I-D ACTION:draft-ietf-rohc-tcp-14.txt

From: Carl Knutsson <[email-masked]>
Date: Fri, 08 Dec 2006 14:25:59 +0100

I forgot to cc the rohc-list...

-------- Original Message --------
Subject: Re: [rohc] I-D ACTION:draft-ietf-rohc-tcp-14.txt
Date: Fri, 08 Dec 2006 14:17:42 +0100
From: Carl Knutsson <[email-masked]>
To: Kristofer Sandlund (LU/EAB) <[email-masked]>
CC: Ghyslain Pelletier (LU/EAB) <[email-masked]>,  West, Mark
<[email-masked]>, Lars-Erik Jonsson (LU/EAB)
<[email-masked]>,  [email-masked]
References: <[email-masked]>

Ghyslain, Kristofer, L-E, Mark,

I have briefly checked the fn of the tcp-draft (draft-ietf-rohc-tcp-14.txt) and I
couldn't find the definition of the following encoding methods. I fear that a typo
or two have found its way into the draft. Correct me if I am wrong.

Please check the following:

o on page 73, 74, in compressed format tcp_irregular och tcp_dynamic:

  tcp_res_flags =:= tstatic_or_irreg(ecn_used.CVALUE, 4)            [ 0, 4 ];

Typo? Replace with:

  tcp_res_flags =:= static_or_irreg(ecn_used.CVALUE, 4)            [ 0, 4 ];

o On page 73, in Compressed formats tcp_dynamic och tcp_replicate:

  ack_stride =:= static_or_irr16(ack_stride_flag.CVALUE)       [ 0, 16 ];

In earlier drafts there were an encoding method for static_or_irreg16. It could be
replaced by:

  ack_stride =:= static_or_irregular(ack_stride_flag.CVALUE, 16)        [ 0, 16 ];

rgds,
/Calle

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> This draft is a work item of the Robust Header Compression Working Group of the IETF.
> 
> 	Title		: RObust Header Compression (ROHC): A Profile for TCP/IP (ROHC-TCP)
> 	Author(s)	: G. Pelletier, et al.
> 	Filename	: draft-ietf-rohc-tcp-14.txt
> 	Pages		: 94
> 	Date		: 2006-11-26
> 	
> This document specifies a ROHC (Robust Header Compression) profile
>    for compression of TCP/IP packets.  The profile, called ROHC-TCP,
>    provides efficient and robust compression of TCP headers, including
>    frequently used TCP options such as SACK (Selective Acknowledgments)
>    and Timestamps.
>    ROHC-TCP works well when used over links with significant error rates
>    and long round-trip times.  For many bandwidth-limited links where
>    header compression is essential, such characteristics are common.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-rohc-tcp-14.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of 
> the message. 
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-ietf-rohc-tcp-14.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-rohc-tcp-14.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Kristofer Sandlund \(LU/EAB\)" <[email-masked]>
Date: Fri, 8 Dec 2006 15:07:33 +0100

Hi Calle,

thanks for catching these evil typos. I have updated the TCP XML on the
CVS with this change.

Magnus, do you want us to submit a new version of ROHC-TCP now, or
should we wait?

/Kristofer

Carl Knutsson <mailto:[email-masked]> wrote on den 8 december
2006 14:26 :

> CC: Ghyslain Pelletier (LU/EAB)
> <[email-masked]>,  West, Mark
>> directories. This draft is a work item of the Robust Header
>> Compression Working Group of the IETF. 
>> 
>> 	Title		: RObust Header Compression (ROHC): A Profile
for TCP/IP
>> 	(ROHC-TCP) Author(s)	: G. Pelletier, et al.
>>    provides efficient and robust compression of TCP headers,
>>    including frequently used TCP options such as SACK (Selective
>>    Acknowledgments)    and Timestamps. ROHC-TCP works well when used
>>    over links with significant error rates and long round-trip
>>    times.  For many bandwidth-limited links where header compression
>> is essential, such characteristics are common. 
>> 
>> [email-masked] with the word unsubscribe in the body
>> of the message. You can also visit
> https://www1.ietf.org/mailman/listinfo/I-D-announce