Subject: [rohc] Question about SigComp Decompression in TCP

From: "Michelle Y Luis" <[email-masked]>
Date: Wed, 17 Jan 2007 23:11:25 +0100

Hi All,

I have been looking for examples of Sigcomp decompression in TCP, finding RFC4465-SigComp TortureTests  as a very useful piece of information, but I did not find yet a clear answer to the following scenario so I guess someone in this list can tell me. 

Say we receive the following compressed string 

    0xFFFF 1234 5678 FF02 90FF ABCD FFFF

my question is, should the bytes 0xABCD be sent for decompression even though they are not qouted by the 0xFF02 delimiter before?, I mean should the string to be decompressed

    0x1234 5678 90FF ABCD

    or

    0x1234 5678 90FF

Thanks

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 18 Jan 2007 10:04:05 +0100

On Jan 17 2007, at 23:11, Michelle Y Luis wrote:

>
> Hi All,
>
> I have been looking for examples of Sigcomp decompression in TCP,  
> finding RFC4465-SigComp TortureTests  as a very useful piece of  
> information, but I did not find yet a clear answer to the following  
> scenario so I guess someone in this list can tell me.
>
> my question is, should the bytes 0xABCD be sent for decompression  
> even though they are not qouted by the 0xFF02 delimiter before?, I  
> mean should the string to be decompressed
>
>     0x1234 5678 90FF ABCD
>
>     or
>
>     0x1234 5678 90FF

There is no reason to quote the ABCD, so it is handed through  
unchanged.  The result is:

>     1234 5678 FF90 FFAB CD

Gruesse, Carsten