Subject: [rohc] Doubt regarding DMS and UDVM memory size

From: "Gangadharan G, TLS-Chennai" <[email-masked]>
Date: Thu, 15 Feb 2007 16:44:46 +0530

Hi All,

As per RFC 3320, UDVM memory size is calculated from the DMS and Message
size and also based on transport type.

i.e., For UDP, udvm_memory_size = DMS - sigcomp_message_size

      For TCP, udvm_memory_size = DMS / 2

As the DMS value is constant (for particular session/application),
udvm_memory_size varies on each message.

How the bytecode has to handle this variance with the BYTE_COPY_RIGHT
value?

For example, In SIP/SIGCOMP the DMS value is 8192. The udvm_memory_size
will be around 7500 (less than 8192).

                    The BYTE_COPY_RIGHT has been hard-coded as 8192 in
the User guide and in other sample bytecode.

                    Is it correct way?

Do others handle the variance of udvm_memory_size in the BYTE_COPY_RIGHT
or hard-code the BYTE_COPY_RIGHT value?

As mentioned in the RFC 3320, the first two byte of the UDVM memory is
its size. 

                     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

                     |       UDVM_memory_size          | 0 - 1

                     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Can we use this value for the BYTE_COPY_RIGHT?

Also, Is it mandatory for the SIGCOMP library to calculate the
udvm_memory_size as per the above formula?

Also please let me know if I am ignorant of any detail.

Note: Please ignore if any Disclaimer is present.

Thanks,

Gangadharan.

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: cco <[email-masked]>
Date: Thu, 15 Feb 2007 13:39:34 +0100

> How the bytecode has to handle this variance with the BYTE_COPY_RIGHT

cristian: in such a way that all the addresses btw. BYTE_COPY_LEFT and 
BYTE_COPY_RIGHT are valid addresses in the virtual (machine) memory.

> the User guide and in other sample bytecode.

cristian: for the examples given there it works. for any other specific
purposes, it may not be correct.

> As mentioned in the RFC 3320, the first two byte of the UDVM memory is

cristian: it depends on the layout of the virtual machine memory that
you are using. in any case UDVM_memory_size must be computed in
accordance with the formula above.

> udvm_memory_size as per the above formula?

cristian: yes, since the behaviour should be predictable
(i.e. the bytecode sent by the remote endpoint should be able
to compute how much virtual machine memory is left to be used as a 
"decompression buffer")

bye now!
cristian