Subject: [rohc] sigcomp-sip: David Ward's DISCUSS

From: Carsten Bormann <[email-masked]>
Date: Wed, 18 Jul 2007 09:12:57 +0200

ROHCers,

David Ward, RTG AD, has put in a DISCUSS on draft-ietf-rohc-sigcomp- 
sip-07.txt, which reads:

> 3320 section 8.7 (Decompression failures)
>
> "If a decompression failure occurs when decompressing a message then
>   the UDVM informs the dispatcher and takes no further action.  It is
>   the responsibility of the dispatcher to decide how to cope with the
>   decompression failure.  In general a dispatcher SHOULD discard the
>   compressed message (or the compressed stream if the transport is
>   stream-based) and any decompressed data that has been outputted but
>   not yet passed to the application.
> "
>
> and in this draft there is no mention of how SIP should handle  
> decompression failures

 From my point of view (having been involved in this from day 1),  
this is nicely covered by section 8:

> 8.  SIP Retransmissions
>
>    When SIP messages are retransmitted, they need to be re-compressed,
>    taking into account any SigComp states that may have been  
> created or
>    invalidated since the previous transmission.  Implementations MUST
>    NOT cache the result of compressing the message and retransmit  
> such a
>    cached result.
>
>    The reason for this behavior is that it is impossible to know  
> whether
>    the failure causing the retransmission occurred on the message  
> being
>    retransmitted or on the response to that message.  If the response
>    was lost, any state changes effected by the first instance of the
>    retransmitted message would already have taken place.  If these  
> state
>    changes removed a state that the previously-transmitted message
>    relied upon, then retransmission of the same compressed message  
> would
>    lead to a decompression failure.

However, this may be a bit opaque to people new to this set of  
documents.
Also, the discussion of NACK in the draft only relates to SigComp  
state; it could mention that NACK (now being mandatory) is the  
general way to handle decompression failure.

All of this is editorial, I think, but I also think it would be nice  
not to entirely rely on the reader making the connections.
Any opinions?  I could go ahead and draft some text.

Gruesse, Carsten

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson" <[email-masked]>
Date: Wed, 18 Jul 2007 09:50:07 +0200

> not to entirely rely on the reader making the connections.

Agree, on both points!

> Any opinions?  I could go ahead and draft some text.

That would be excellent, please do so!

Thanks,
/L-E

---

From: David Ward <[email-masked]>
Date: Wed, 18 Jul 2007 08:41:47 -0500

X-Mailm></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'>Thanks with regards,<o:p></o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'>Rambabu Gajula<o:p></o:p></span></font></p>

<p class=3DMsoNormal><font size=3D2 face=3DArial><span =
style=3D'font-size:10.0pt;
font-family:Arial'><o:p>&nbsp;</o:p></span></font></p>

</div>

</body>

</html>

------_=_NextPart_001_01C7CE76.6EFBD957--

--===============2004465964==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--===============2004465964==--

---

From: David Ward <[email-masked]>
Date: Wed, 18 Jul 2007 08:41:47 -0500

</div>

</body>

</html>

---

From: David Ward <[email-masked]>
Date: Wed, 18 Jul 2007 08:41:47 -0500

Cartsen, L-E -

    Thanks for agreeing to add the extra text. I'll admit that this isn't my
field of expertise and that I read your draft and 3320 for the first time
very recently. Matching up all the parameters and states of 3320 and what is
in your draft was an "interesting" couple of hours :-) When I read Section 8
on retrans what I was looking for or expecting is to see a sentence "Upon a
decompression failure...." I could assume what would happen from expected
protocol procedures but, a couple of sentences would be great.

Many thanks again for making the mod.

-DWard

an-Version: 2.1.5
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/rohc>,
	<mailto:[email-masked]?subject=unsubscribe>
List-Post: <mailto:[email-masked]>
List-Help: <mailto:[email-masked]?subject=help>
List-Subscribe: <https://www1.ietf.org/mailman/listinfo/rohc>,
	<mailto:[email-masked]?subject=subscribe>
Errors-To: [email-masked]

Cartsen, L-E -

    Thanks for agreeing to add the extra text. I'll admit that this isn't my
field of expertise and that I read your draft and 3320 for the first time
very recently. Matching up all the parameters and states of 3320 and what is
in your draft was an "interesting" couple of hours :-) When I read Section 8
on retrans what I was looking for or expecting is to see a sentence "Upon a
decompression failure...." I could assume what would happen from expected
protocol procedures but, a couple of sentences would be great.

Many thanks again for making the mod.

-DWard

an-Version: 2.1.5
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/rohc>,
	<mailto:[email-masked]?subject=unsubscribe>
List-Post: <mailto:[email-masked]>
List-Help: <mailto:[email-masked]?subject=help>
List-Subscribe: <https://www1.ietf.org/mailman/listinfo/rohc>,
	<mailto:[email-masked]?subject=subscribe>
Errors-To: [email-masked]

Cartsen, L-E -

    Thanks for agreeing to add the extra text. I'll admit that this isn't my
field of expertise and that I read your draft and 3320 for the first time
very recently. Matching up all the parameters and states of 3320 and what is
in your draft was an "interesting" couple of hours :-) When I read Section 8
on retrans what I was looking for or expecting is to see a sentence "Upon a
decompression failure...." I could assume what would happen from expected
protocol procedures but, a couple of sentences would be great.

Many thanks again for making the mod.

-DWard