Subject: [rohc] ROHC implementation

From: "Bhavya SM" <[email-masked]>
Date: Tue, 13 May 2008 11:41:30 +0530

Hi,

I want to know the implementation part.............

To use ROHC (Robust Header Compression) , is it just a library we need to install or we need to implement separatly on SIP Stack according to RFCs.

Or is there any opensource is available?

To implement from the scratch, what is the timeline required?

Please reply to this.....

Regards,
Bhavya

_______________________________________________
Rohc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rohc

---

From: Biplab Sarkar <[email-masked]>
Date: Tue, 13 May 2008 11:51:17 +0530

Hi Bhavya,

There is one open source project for ROHC http://rohc.sourceforge.net/

It might be a bit old and minimal in its implementation.
There are some vendors who deal with ROHC stack which is some what more
up to date with the RFC.
You might have to check up with them or start from scratch.

Thanks
Biplab

On Tue, 2008-05-13 at 11:41 +0530, Bhavya SM wrote:
> To use ROHC (Robust Header Compression) , is it just a library we need
> to install or we need to implement separatly on SIP Stack according to
> RFCs.
>

---

From: Ang Way Chuang <[email-masked]>
Date: Tue, 13 May 2008 14:25:33 +0800

Bhavya SM wrote:
> *Hi,*
> ** 
> *I want to know the implementation part.............*
>  
> *To use ROHC (Robust Header Compression) , is it just a library we need 
> RFCs*.
> *Or is there any opensource is available?*

There is a free implementation at http://rohc.sourceforge.net/. Although 
it is incomplete. It is not a library, although it can be made one.

> ** 
> *To implement from the scratch, what is the timeline required?*

Not easy to implement from scratch.

> ** 
> *Please reply to this.....*
> ** 
> *Regards,*
> *Bhavya*
> 
> 
> ------------------------------------------------------------------------
>