Subject: [rohc] Regarding De compression failure

From: "Vamsikrishna" <[email-masked]>
Date: Wed, 20 Aug 2008 19:17:53 +0530

Hi
    I have a doubt during the Decompression failure scenario.

If  we use ROHC for reliable services and if the decompression is failed for
a packet, is there
any chance of  retransmitting the packet by the compressor?

Is there any built in buffering mechanism at the compressor so that it can
retransmit the packets
if  it recieves an indication of decompression failure?

If the compressor is not able to retransmit the packet is there any chance
for upper layer
retransmission procedure?

Thanks & Regards
Vamsi

The information contained in this electronic message and any attachments to this message are intended for the exclusive use of the addressee(s) and may contain proprietary, confidential or privileged information. If you are not the intended recipient, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately and destroy all copies of this message and any attachments contained in it.

Contact your Administrator for further information.

_______________________________________________
Rohc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rohc

---

From: Sarkar Biplab <[email-masked]>
Date: Thu, 21 Aug 2008 17:14:37 +0530

Hi Vamsi,

The ROHC protocol is aimed for robustness but not for reliability.  So
the reliability aspect is beyond its scope. 

Thanks & Regards
Biplab