Subject: Re: [rohc] Rohc Digest, Vol 54, Issue 4

From: "pradeep shambhu" <[email-masked]>
Date: Fri, 14 Nov 2008 18:02:54 +0530

Changing fields can be made as a static in only one condition, that is if
the bits are increasing in the sequential order. The offset value can be set
& can be considered as a static.
But for the fields of TCP like checksum, urgent pointer, control fields are
always irregular, then how can the fields can be set as a static. ( as
mention in the Rfc - 4996 page.no-79 ) &  Irregular ( Rfc - 4413 page.no 18
).

Pradeep Shambhu,
Kyocera Wireless India, Pvt Ltd.

On Sat, Nov 1, 2008 at 12:30 AM, <[email-masked]> wrote:

> Send Rohc mailing list submissions to
>        [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>        https://www.ietf.org/mailman/listinfo/rohc
> or, via email, send a message with subject or body 'help' to
>        [email-masked]
>
> You can reach the person managing the list at
>        [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Rohc digest..."
>
>
> Today's Topics:
>
>   1. WG Last-Call: ROHCoIPSec (Carl Knutsson)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Fri, 31 Oct 2008 15:56:57 +0100
> From: Carl Knutsson <[email-masked]>
> Subject: [rohc] WG Last-Call: ROHCoIPSec
> To: rohc <[email-masked]>
> Cc: [email-masked], Carsten Bormann <[email-masked]>
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1
>
> ROHCers,
>
> The ROHCoIPSEC profiles draft have been stale for some time now and I
> think we all agree that is time for a WG last-call.
>
> Therefore, we are now issuing a WG last-call for:
>
> draft-ietf-rohc-hcoipsec-09.txt
> draft-ietf-rohc-ikev2-extensions-hcoipsec-07.txt
> draft-ietf-rohc-ipsec-extensions-hcoipsec-03.txt
>
>  (as Proposed Standard)
>
> This is a regular ~two-week WG last-call (as suggested in RFC2418).
> Please send WG last-call comments to the rohc mailing list rohc at
> ietf.org before Tue, 2008-11-14, 17:00 UTC. Yoav Nir and Robert A.
> Stangarone Jr are committed document reviewers (CDR) and have promised
> to send in a review of complete framework before the deadline.
>
> The plan is to submit all drafts together.
>
>
> Best Regards
>
> /Calle (ROHC WG chair)
>
>
> ------------------------------
>
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rohc
>
>
> End of Rohc Digest, Vol 54, Issue 4
> ***********************************
>
_______________________________________________
Rohc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rohc

---

From: Carl Knutsson <[email-masked]>
Date: Fri, 14 Nov 2008 14:39:41 +0100

Pradeep,

pradeep shambhu wrote:
> Changing fields can be made as a static in only one condition, that is
> if the bits are increasing in the sequential order. 
No. Header fields can only be encoded as static, if it hasn't changed
since the last header. Otherwise the format will fail.

> The offset value can be set & can be considered as a static.
I am not sure what you mean here.

> But for the fields of TCP like checksum, urgent pointer, control fields
> are always irregular, then how can the fields can be set as a static. (
> as mention in the Rfc - 4996 page.no-79 ) &  Irregular ( Rfc - 4413
> page.no <http://page.no> 18 ).

The TCP checksum is always sent in the irregular, dynamic or replicate
chain and is encoded with irregular(16). Urgent pointer is encoded using
static_or_irreg, which means it is encoded static or irregular (not
always irregular). Be a bit more specific about the controllfields. I
can't see any problem with the choice static_or_irreg as encoding method
for these fields.

/Calle