Subject: [rohc] CSRC List and CRC

From: [email-masked]
Date: Tue, 28 Jul 2009 17:28:09 +0800

RFC 3095  5.8.2.1.  Reference list in R-mode and U/O-mode

b) 
"In R-mode, the compressor keeps sending compressed lists using the
 same reference until it receives an acknowledgment for a packet 
 containing the newest list."

If other context Information don't change(only CSRC list change) and CSRC 
list adopt Encoding Type 1/2/3,

must the compression packet take CRC?

caiwei 167981
LTE Development Department | LTE开发部

Product Marketing System 
产品市场体系
D3-06, ZTE Corp., No.10 South Tangyan Rd., 
Hi-tech Industrial Development Zone, Xi'an, 
P.R.China, 710065
Tel:+86-29-88724112, 15801916689
Email:[email-masked] 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Klaus Warnke <[email-masked]>
Date: Tue, 28 Jul 2009 12:12:43 +0200

Cai,

if I remember right, every context updating packet in R-Mode must
protected by a CRC. If a packet in R-mode is not protected by a
CRC, it does not change the de-compressor context at all.
So if the the compressor wants to update the CSRC list permanent, it
have to choose a CRC protected packet format. For a non permanent
change, the CSRC changes for some packets and then go back, a non CRC
protected packet should chosen. The updating properties in UO-1* packets
are clarified in RFC4815 6.2.

br
Klaus Warnke

[email-masked] wrote:
>
> RFC 3095 * 5.8.2.1. Reference list in R-mode and U/O-mode*
>
> b)
> If other context Information don't change(only CSRC list change) and
> CSRC list adopt Encoding Type 1/2/3,
>
> *caiwei 167981*
> 	*Product Marketing System *
> *产品市场体系*
> ------------------------------------------------------------------------
>
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rohc
>