Subject: [rohc] About Outer IP-ID field

From: wukai_927 <[email-masked]>
Date: Tue, 28 Jul 2009 23:20:01 +0800 (CST)

hi ：
    I am having some difficulty about Outer IP-ID field。I need some help.
    http://www.ietf.org/mail-archive/web/rohc/current/msg02222.html
>See page 75, "IP-ID":
>"IP-ID fields in compressed base headers carry the compressed IP-ID
>of the innermost IPv4 header whose corresponding RND flag is not 1."
>This means for two IP headers (IP-ID field means the field in compressed >headers):
>IPv6/IPv6/UDP/RTP : No IP-ID field in compressed headers.
>IPv6/IPv4(RND=1)/UDP/RTP : No IP-ID field in compressed headers.
>IPv6/IPv4(RND=0)/UDP/RTP : The IP-ID field corresponds to the inner >header.
>IPv4(RND=1)/IPv6/UDP/RTP : No IP-ID field in compressed headers.
>IPv4(RND=0)/IPv6/UDP/RTP : The IP-ID field corresponds to the outer >header.
>IPv4(RND=1)/IPv4(RND=1)/UDP/RTP: No IP-ID field in compressed headers.
>IPv4(RND=1)/IPv4(RND=0)/UDP/RTP: The IP-ID field corresponds to the >inner header.
>IPv4(RND=0)/IPv4(RND=0)/UDP/RTP: The IP-ID field corresponds to the >inner header.
>                                 This last case would only work if the >outer IP-ID
>                                 is totally sequential N, N+1, >N+2...etc.
>                                 (previous config should be used >instead)
>Crystal clear from RFC3095...=)
   About Outer IP-ID field,it had clearly interpretation above。
   About last config :IPv4(RND=0)/IPv4(RND=0)/UDP/RTP: The IP-ID field corresponds to the inner header.
     This last case would only work if the outer IP-ID is totally sequential N, N+1, >N+2...etc.
      (previous config should be used instead,I.E: use config IPv4 (RND=1)/IPv4 (RND=0)/UDP/RTP:  The IP-ID field corresponds to the inner header.is it right?
   My question is how to use the IP-ID in Extension 3 Outer IP header fields?when to use the IP-ID in Extension 3 Outer IP header fields?
 
 Outer IP header fields
       ..... ..... ..... ..... ..... ..... ..... .....
      |      Type of Service/Traffic Class            |  if TOS2 = 1
       ..... ..... ..... ..... ..... ..... ..... .....
      |         Time to Live/Hop Limit                |  if TTL2 = 1
       ..... ..... ..... ..... ..... ..... ..... .....
      |         Protocol/Next Header                  |  if PR2 = 1
       ..... ..... ..... ..... ..... ..... ..... .....
      /         IP extension header(s)                /  variable,
       ..... ..... ..... ..... ..... ..... ..... .....    if IPX2 = 1
      |                  IP-ID                        |  2 octets,
       ..... ..... ..... ..... ..... ..... ..... .....    if I2 = 1

br
wukai

---

From: Klaus Warnke <[email-masked]>
Date: Wed, 29 Jul 2009 11:00:35 +0200

Wukai,

 > My question is how to use the IP-ID in Extension 3 Outer IP header
 > fields?when to use the IP-ID in Extension 3 Outer IP header fields?

First, I think, that the sentence "carry the compressed IP-ID of the
innermost IPv4 header" applies to the IP-ID field in the base headers,
like UO-1-ID, not to the extension 3. In UO-1-ID there is no ip/ip2
flag that indicates for which IP header the IP-ID is, as in
extension-3. The problem here is, that if the outer IP-ID does not
jump +1 nbo/not nbo, you can not use the IP-ID field in UO-1-ID to
transmit such small change to the de-compressor, as for the inner
IP-ID. You must use an large extension-3, where you can tranmit the
IP-ID for inner and outer separate, because the IP-ID field in UO-1-ID
is reserved for the inner IP-ID.

br
Klaus Warnke
> >IPv6/IPv4(RND=0)/UDP/RTP : The IP-ID field corresponds to the inner 
> >header.
> >IPv4(RND=0)/IPv6/UDP/RTP : The IP-ID field corresponds to the outer 
> >header.
> >IPv4(RND=1)/IPv4(RND=0)/UDP/RTP: The IP-ID field corresponds to the 
> >inner header.
> >IPv4(RND=0)/IPv4(RND=0)/UDP/RTP: The IP-ID field corresponds to the 
> >inner header.
> (previous config should be used instead,I.E: use config IPv4 
> (RND=1)/IPv4 (RND=0)/UDP/RTP: The IP-ID field corresponds to the inner 
> header.is it right?
> My question is how to use the IP-ID in Extension 3 Outer IP header 
> fields?when to use the IP-ID in Extension 3 Outer IP header fields?
>
> Outer IP header fields
> ------------------------------------------------------------------------
>
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rohc