Subject: [rohc] Question regarding SIGCOMP

From: kishore sowdi <[email-masked]>
Date: Wed, 23 May 2012 14:16:15 +0800 (SGT)

Hi ,

I am using SIGCOMP to compress/decompress SIP application.

SIP Client is uploading UVDM bytecode in all messages it sends to server.
Below is the message exchange between SIP Client and Server,

Client                                                                                 Server
1) REG (Client sends bytecode) ---->

                                                                                      (2) <----  401(Server sends byte code)                                            
 
3) REG  (Client sends bytecode) ---->    
 
                                                                                      (4) <----- 200 OK (Server sends byte code)  

5) SUBSCRIBE (Client sends bytecode)----->

                                                                                      (6) <----- 200 OK (Server sends partial state identifier )

---> At (6), server tries to access state, by giving partial state identifiers, which it gave in state create at step (4) as per "UDVM Execution trace".... 
---> when client receives (6), it is failing to decompress it saying state not found....
---> (6) gets re-transmitted many times.....

However at (4), server has sent only one STATE-CREATE instruction in bytecode ... 
But, packet sniffer(wireshark) shows in "UDVM Execution Trace" having 3 state create requests... 

My question is , why there are no 3 STATE-CREATE instructions in bytecode at (4) ??...
I am confused because "UDVM Execution Trace" having 3 state create requests... and there are no corresponding STATE-CREATE instructions at (4)..

Since Client has not received 3 STATE-CREATE's in bytecode at (4), it has not created those states and suddenly at (6), when server refers to that state giving "partial state id", client fails to match it to the state.

Please help in identifying the issue...

Regards,
Kishore

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 23 May 2012 10:15:04 +0200

Kishore,

your diagram does not really show the important parts:
-- which states are being created
-- which states are being referenced

It is a bit hard to make out from that what is going on.

Grüße, Carsten

---

From: kishore sowdi <[email-masked]>
Date: Wed, 23 May 2012 16:50:00 +0800 (SGT)

Hi Carsten,
 
With reference to my earlier diagram, I am describing state create and state access made by server.
 
In message (4), I see 3 state creates made by server
[-]UDVM execution trace
 no_of_state_create 3
 ### Creating state ###
 Partial state identifier: AEDBAB80652A
 ### Creating state ###
 Partial state identifier: AAA2B32CE212
 ### Creating state ###
 Partial state identifier: 
 
 In message (6), I see state access(referenced) using partial state id made by server.
 [-]Signaling Compression
  Returned_feedback item: 03
  Partial state identifier: AEDBAB80652A
  Remaining SigComp message bytes: 280
  ### Accessing state ###
  Partial state identifier: AEDBAB80652A
 
In message (4), 
- I can see 3 state creates as part of "UDVM Execution trace" as decipted by Wireshark (Network Protocol Analyzer) .
- Why did not server send these three state create requests using STATE-CREATE as part of UDVM byte code?
 
In message (6),
- State having AEDBAB80652A id is referenced (state access) by server.
- My SIP Client says, state with such an identifier not found and as a result SIP Client fails to decompress the message.
 
I feel, during (4), If state create requests were made eplicitly using STATE-CREATE, then my SIP Client would have created those states.
and during (6), decompression would be successful.
 
Regards,
Kishore

From: Carsten Bormann <[email-masked]>
To: kishore sowdi <[email-masked]> 
Cc: "[email-masked]" <[email-masked]> 
Sent: Wednesday, 23 May 2012 1:45 PM
Subject: Re: [rohc] Question regarding SIGCOMP

Kishore,

Grüße, Carsten

_______________________________________________
Rohc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rohc

----- Forwarded Message -----
From: kishore sowdi <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Wednesday, 23 May 2012 11:46 AM
Subject: Question regarding SIGCOMP

Hi ,

Client                                                                                 Server

 

Regards,
Kishore

---

From: kishore sowdi <[email-masked]>
Date: Tue, 29 May 2012 18:11:15 +0800 (SGT)

Hi List,
 
One more observation this issue:
 
After decompressing message (4).. 200 OK For REGISTER, SIP Client creates state having state identifier (SHA1 result) and stores it.
 
But at (6).. 200 OK to SUBSCRIBE, Server references a partial state identifier, which does not match with state identifier which is generated as mentioned above.
 
Should they match ? .
 
At (4), Server asks to create state using Partial Id, what does partial id signify here during state create ??
[-]UDVM execution trace
 no_of_state_create 3
 ### Creating state ###
 
Regards,
Kishore

From: kishore sowdi <[email-masked]>
To: Carsten Bormann <[email-masked]> 
Cc: "[email-masked]" <[email-masked]> 
Sent: Wednesday, 23 May 2012 2:20 PM
Subject: Re: [rohc] Question regarding SIGCOMP

Hi Carsten,

 

In message (4), 

In message (6),

Regards,
Kishore

Kishore,

Grüße, Carsten

----- Forwarded Message -----
From: kishore sowdi <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Wednesday, 23 May 2012 11:46 AM
Subject: Question regarding SIGCOMP

Hi ,

Client                                                                                 Server

 

Regards,
Kishore