Subject: [Roll] Routing Over Low power and Lossy networks (roll) WG Virtual Meeting: 2020-09-30

From: IESG Secretary <[email-masked]>
Date: Fri, 11 Sep 2020 09:14:53 -0700

The Routing Over Low power and Lossy networks (roll) WG will hold
a virtual interim meeting on 2020-09-30 from 10:45 to 12:45 UTC.

Agenda:
To Be Determined

Information about remote participation:
ROLL Interim Meeting 30-09-2020 Hosted by ROLL WG  Wednesday, Sep 30, 2020 6:20 am | 2 hours 50 minutes | (UTC-04:00) Eastern Time (US & Canada) Meeting number: 171 102 5381 Password: ypMdeMeC345 https://ietf.webex.com/ietf/j.php?MTID=m266a5c57822f8ca4275e1f4ac6416f12  Join by video system Dial [email-masked] You can also dial 173.243.2.68 and enter your meeting number.  Join by phone 1-650-479-3208 Call-in toll number (US/Canada) Access code: 171 102 5381

https://github.com/roll-wg/ROLL-Interim-Meeting

---

From: Ines Robles <[email-masked]>
Date: Sun, 13 Sep 2020 23:37:05 +0300

Dear all,

Thank you very much for filling the doodle. We got the next roll interim
meeting on 30th September with a duration of two hours.

Please let us know by *18th September* if you want to present a topic
during the next roll interim meeting indicating:

- Topic to Present.
- Presenter
- Time needed.

Some discussions points from last interim meeting [
https://www.youtube.com/watch?v=_kMr6RM_ao4]:

Mopex: Discussion on 1 bit or 2 bits to distinguish Extended control option
(12:00min-14:00min)
Capabilities: Signaling, bits to say which the total number of capabilities
(15:40 min -16:23min),  roll querying all nodes, querying for available
memory on nodes (23:00 min -31:00 min )
DIS modification/use cases draft: Electrical meter reboot use case (1:15 hs
- 1:17hs )
Eliding-dio-information: review needed, ready for WG Adoption Call?

Material:
Etherpad: https://codimd.ietf.org/notes-ietf-interim-2020-roll-05-roll
icalendar (UTC):
https://datatracker.ietf.org/meeting/interim-2020-roll-05/session/28351.ics
jabber: xmpp:[email-masked]?join
Webex:
https://ietf.webex.com/ietf/j.php?MTID=m266a5c57822f8ca4275e1f4ac6416f12
Meeting number: 171 102 5381 Password: ypMdeMeC345

Please note that we aim to record the meeting.

Material of the previous interim meetings:
https://github.com/roll-wg/ROLL-Interim-Meeting

Thank you very much,

Ines and Dominique

---------- Forwarded message ---------
From: IESG Secretary <[email-masked]>
Date: Fri, Sep 11, 2020 at 7:17 PM
Subject: [Roll] Routing Over Low power and Lossy networks (roll) WG Virtual
Meeting: 2020-09-30
To: IETF-Announce <[email-masked]>
Cc: <[email-masked]>

Agenda:
To Be Determined

Information about remote participation:
ROLL Interim Meeting 30-09-2020 Hosted by ROLL WG  Wednesday, Sep 30, 2020
6:20 am | 2 hours 50 minutes | (UTC-04:00) Eastern Time (US & Canada)
Meeting number: 171 102 5381 Password: ypMdeMeC345
https://ietf.webex.com/ietf/j.php?MTID=m266a5c57822f8ca4275e1f4ac6416f12
Join by video system Dial [email-masked] You can also dial
173.243.2.68 and enter your meeting number.  Join by phone 1-650-479-3208
Call-in toll number (US/Canada) Access code: 171 102 5381

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Michael Richardson <[email-masked]>
Date: Sun, 13 Sep 2020 17:12:53 -0400

> - Time needed.

I think that we need to discuss how we get to RPLv2, what it is, how many
documents, and how much energy we have to get there.

Call this a partial rechartering discussion if you like.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Georgios PAPADOPOULOS <[email-masked]>
Date: Mon, 14 Sep 2020 10:20:29 +0200

Hello all,

Regarding the RPLv2, do you think it would be possible to have at the end of the day everything in one single document?
In stead of going over multiple documents, and multiple RFCs tomorrow, imho, it would be more efficient to have one single RFC for the RPLv2 like the RFC 6550 for RPL.

What do you think?
Giorgos

> On 13 Sep 2020, at 23:12, Michael Richardson <[email-masked]> wrote:
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Mon, 14 Sep 2020 04:39:24 -0400

Georgios PAPADOPOULOS <[email-masked]> wrote:
    > Regarding the RPLv2, do you think it would be possible to have at the
    > end of the day everything in one single document?

Yes, eventually, we'd do rfc6550bis, and we'd merge in all the documents,
throw out the pieces that we didn't implement, and maybe advance to Internet Standard.

    > In stead of going over multiple documents, and multiple RFCs tomorrow,
    > imho, it would be more efficient to have one single RFC for the RPLv2
    > like the RFC 6550 for RPL.

    > What do you think?

It's just too soon.
We actually need to sort out the things we want to do.
Editing the huge rfc6550 won't be productive at this point.

---

From: Rahul Jadhav <[email-masked]>
Date: Mon, 14 Sep 2020 10:37:58 +0000

Will now be the right time to check consensus with the WG on what behaviour may have to be mandated as part of RPLv2?

Following are some of the points which immediately comes to my mind:

1. Use of revised Option Type (0x23) in RPI ... (Obsolete use of 0x63 RPI Option Type value).
2. Mandating the use of 6LoRH (RFC 8138) ... (Allows compression of SRH (non-storing) and RPI (storing mode)). This is something that was discussed in context to turnon-8138 T-bit draft recently.
3. Use of MOPex (This is how we know the instance is RPLv2)
4. Support for Ext Control Options. (Allows Backward compatibility for new extns... part for same mopex draft)
5. Support for Capabilities. (Enables backward compatibility, allows incremental feature support)

There are some points from RPL Observations draft [2] which could be clarified as part of this work item. Not sure if those points could go in as part of this draft? For e.g., Path Control Bits handling issue in 6550 [1] ... 2) Mandating handling (not sending) of multiple targets in DAO [3]

WG could provide feedback on the following aspects:
1. Do you feel one of the points above need not be mandated?
2. Do you feel there is some other point which needs to be addressed?

[1] https://tools.ietf.org/html/draft-ietf-roll-rpl-observations-04#section-10
[2] RPL Observations: https://tools.ietf.org/html/draft-ietf-roll-rpl-observations-04
[3] https://tools.ietf.org/html/draft-ietf-roll-rpl-observations-04#section-7

________________________________
From: Roll <[email-masked]> on behalf of Michael Richardson <[email-masked]>
Sent: 14 September 2020 02:09 PM
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] roll WG Virtual Meeting: 2020-09-30 - Call for Agenda Items-

It's just too soon.

---

From: Ines Robles <[email-masked]>
Date: Wed, 16 Sep 2020 08:45:39 +0300

Dear all,

So far we have in the agenda:

- WG Status: wg documents and related-ID status
- ROLL in IETF 109? (Please fill the survey:
https://www.surveymonkey.com/r/5KDZ8HH )
- RPLv2 Topics

Some additional topics  would you like to discuss? Please send us your
request by 18t Sept.

Thank you,

Ines and Dominique.

On Sun, Sep 13, 2020 at 11:37 PM Ines Robles <[email-masked]>
wrote:

> Mopex: Discussion on 1 bit or 2 bits to distinguish Extended control
> option (12:00min-14:00min)
> Capabilities: Signaling, bits to say which the total number of
> capabilities (15:40 min -16:23min),  roll querying all nodes, querying for
> available memory on nodes (23:00 min -31:00 min )
> DIS modification/use cases draft: Electrical meter reboot use case (1:15
> hs - 1:17hs )
> Subject: [Roll] Routing Over Low power and Lossy networks (roll) WG
> Virtual Meeting: 2020-09-30

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 16 Sep 2020 03:46:12 -0700

Inés:

Hola!  Cómo vas?

Esta reunión es a las 1045 GMT, cierto?  Pregunto porque en el calendario
aparece a las 1045 ET (US East), que es 4 horas después.

https://datatracker.ietf.org/meeting/upcoming.ics

Sería bueno que lo revisés y le digás al Secetariat si es necesario
corregir.

Saludos!

Alvaro.

On September 16, 2020 at 1:46:25 AM, Ines Robles (
mariainesrobles=[email-masked]) wrote:

Dear all,

Thank you,

Ines and Dominique.

---

From: Ines Robles <[email-masked]>
Date: Sat, 26 Sep 2020 00:09:19 +0300

Dear all,

Please find below the link to the agenda for the interim meeting on 30th
September.

https://www.ietf.org/proceedings/interim-2020-roll-05/agenda/agenda-interim-2020-roll-05-roll-01-01.txt

Dear Presenters, please upload your slides in:
https://datatracker.ietf.org/meeting/interim-2020-roll-05/session/roll  or
send it to us by Tuesday 29th September.

Thank you and best regards,

Ines and Dominique.

On Wed, Sep 16, 2020 at 8:45 AM Ines Robles <[email-masked]>
wrote:

> On Sun, Sep 13, 2020 at 11:37 PM Ines Robles <
> [email-masked]> wrote:
>
>> Dear all,
>>
>> ROLL Interim Meeting 30-09-2020 Hosted by ROLL WG  Wednesday, Sep 30,
>> 2020 6:20 am | 2 hours 50 minutes | (UTC-04:00) Eastern Time (US & Canada)

---

From: Ines Robles <[email-masked]>
Date: Wed, 30 Sep 2020 00:56:44 +0300

Dear all,

Please find below the link to an updated agenda for today's meeting:

https://www.ietf.org/proceedings/interim-2020-roll-05/agenda/agenda-interim-2020-roll-05-roll-01-02.txt

Complete set of slides:

https://www.ietf.org/proceedings/interim-2020-roll-05/slides/slides-interim-2020-roll-05-sessa-completeset-roll-interim-20200930-00

Webex:

Ines and Dominique

On Sat, Sep 26, 2020 at 12:09 AM Ines Robles <[email-masked]>
wrote:

> https://datatracker.ietf.org/meeting/interim-2020-roll-05/session/roll
> or send it to us by Tuesday 29th September.
>
> On Wed, Sep 16, 2020 at 8:45 AM Ines Robles <

---

From: Ines Robles <[email-masked]>
Date: Wed, 30 Sep 2020 11:39:53 +0300

Dear all,

Please find an updated version of the complete slide set for the today
meeting:

https://www.ietf.org/proceedings/interim-2020-roll-05/slides/slides-interim-2020-roll-05-sessa-completeset-roll-interim-20200930-02

Thank you,

Ines and Dominique.

On Wed, Sep 30, 2020 at 12:56 AM Ines Robles <[email-masked]>
wrote:

> On Sat, Sep 26, 2020 at 12:09 AM Ines Robles <
>>>> Thank you very much for filling the doodle. We got the next roll
>>>> interim meeting on 30th September with a duration of two hours.
>>>>
>>>> DIS modification/use cases draft: Electrical meter reboot use case
>>>> (1:15 hs - 1:17hs )

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 30 Sep 2020 09:15:21 +0000

Hello Ines

For some reason the slide with the pdao was scrambled when going pdf.
Could you please check ?

Pascal

Le 30 sept. 2020 à 10:41, Ines Robles <mariainesrobles=[email-masked]> a écrit :

Dear all,

Please find an updated version of the complete slide set for the today meeting:

Thank you,

Ines and Dominique.

On Wed, Sep 30, 2020 at 12:56 AM Ines Robles <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Complete set of slides:

jabber: xmpp:[email-masked]?join<http://xmpp:[email-masked]?join>

Webex: https://ietf.webex.com/ietf/j.php?MTID=m266a5c57822f8ca4275e1f4ac6416f12    Meeting number: 171 102 5381 Password: ypMdeMeC345

Ines and Dominique

On Sat, Sep 26, 2020 at 12:09 AM Ines Robles <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Please find below the link to the agenda for the interim meeting on 30th September.

Dear Presenters, please upload your slides in: https://datatracker.ietf.org/meeting/interim-2020-roll-05/session/roll  or send it to us by Tuesday 29th September.

Ines and Dominique.

On Wed, Sep 16, 2020 at 8:45 AM Ines Robles <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

- WG Status: wg documents and related-ID status
- ROLL in IETF 109? (Please fill the survey: https://www.surveymonkey.com/r/5KDZ8HH )
- RPLv2 Topics

Some additional topics  would you like to discuss? Please send us your request by 18t Sept.

Thank you,

Ines and Dominique.

On Sun, Sep 13, 2020 at 11:37 PM Ines Robles <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Thank you very much for filling the doodle. We got the next roll interim meeting on 30th September with a duration of two hours.

Please let us know by 18th September if you want to present a topic during the next roll interim meeting indicating:

- Topic to Present.
- Presenter
- Time needed.

Some discussions points from last interim meeting [https://www.youtube.com/watch?v=_kMr6RM_ao4]:

Mopex: Discussion on 1 bit or 2 bits to distinguish Extended control option (12:00min-14:00min)
Capabilities: Signaling, bits to say which the total number of capabilities (15:40 min -16:23min),  roll querying all nodes, querying for available memory on nodes (23:00 min -31:00 min )
DIS modification/use cases draft: Electrical meter reboot use case (1:15 hs - 1:17hs )
Eliding-dio-information: review needed, ready for WG Adoption Call?

Material:
Etherpad: https://codimd.ietf.org/notes-ietf-interim-2020-roll-05-roll
icalendar (UTC): https://datatracker.ietf.org/meeting/interim-2020-roll-05/session/28351.ics
jabber: xmpp:[email-masked]?join<http://xmpp:[email-masked]?join>
Webex: https://ietf.webex.com/ietf/j.php?MTID=m266a5c57822f8ca4275e1f4ac6416f12    Meeting number: 171 102 5381 Password: ypMdeMeC345

Material of the previous interim meetings: https://github.com/roll-wg/ROLL-Interim-Meeting

Thank you very much,

Ines and Dominique

---------- Forwarded message ---------
From: IESG Secretary <[email-masked]<mailto:[email-masked]>>
Date: Fri, Sep 11, 2020 at 7:17 PM
Subject: [Roll] Routing Over Low power and Lossy networks (roll) WG Virtual Meeting: 2020-09-30
To: IETF-Announce <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>

Agenda:
To Be Determined

Information about remote participation:
ROLL Interim Meeting 30-09-2020 Hosted by ROLL WG  Wednesday, Sep 30, 2020 6:20 am | 2 hours 50 minutes | (UTC-04:00) Eastern Time (US & Canada) Meeting number: 171 102 5381 Password: ypMdeMeC345 https://ietf.webex.com/ietf/j.php?MTID=m266a5c57822f8ca4275e1f4ac6416f12  Join by video system Dial [email-masked]<mailto:[email-masked]> You can also dial 173.243.2.68 and enter your meeting number.  Join by phone 1-650-479-3208 Call-in toll number (US/Canada) Access code: 171 102 5381

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Ines Robles <[email-masked]>
Date: Wed, 30 Sep 2020 12:36:42 +0300

Hi Pascal,

The issue is fixed now, please find the new slide set:
https://www.ietf.org/proceedings/interim-2020-roll-05/slides/slides-interim-2020-roll-05-sessa-completeset-roll-interim-20200930-03

Ines

On Wed, Sep 30, 2020 at 12:15 PM Pascal Thubert (pthubert) <pthubert=
[email-masked]> wrote:

> Le 30 sept. 2020 à 10:41, Ines Robles <mariainesrobles=
> [email-masked]> a écrit :
>
> 
> Dear all,
>
> On Wed, Sep 30, 2020 at 12:56 AM Ines Robles <