Subject: [Roll] Path Control Bits handling issue in 6550

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 14 Sep 2020 11:32:31 +0000

Hello Rahul

Yes, I believe that the points in observations need to be addressed.
I started this for the Path Control Bits handling issue in 6550.

Take care,

Pascal

From: Roll <[email-masked]> On Behalf Of Rahul Jadhav
Sent: lundi 14 septembre 2020 12:38
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] roll WG Virtual Meeting: 2020-09-30 - Call for Agenda Items-

Will now be the right time to check consensus with the WG on what behaviour may have to be mandated as part of RPLv2?

Following are some of the points which immediately comes to my mind:

1. Use of revised Option Type (0x23) in RPI ... (Obsolete use of 0x63 RPI Option Type value).
2. Mandating the use of 6LoRH (RFC 8138) ... (Allows compression of SRH (non-storing) and RPI (storing mode)). This is something that was discussed in context to turnon-8138 T-bit draft recently.
3. Use of MOPex (This is how we know the instance is RPLv2)
4. Support for Ext Control Options. (Allows Backward compatibility for new extns... part for same mopex draft)
5. Support for Capabilities. (Enables backward compatibility, allows incremental feature support)

There are some points from RPL Observations draft [2] which could be clarified as part of this work item. Not sure if those points could go in as part of this draft? For e.g., Path Control Bits handling issue in 6550 [1] ... 2) Mandating handling (not sending) of multiple targets in DAO [3]

WG could provide feedback on the following aspects:
1. Do you feel one of the points above need not be mandated?
2. Do you feel there is some other point which needs to be addressed?

[1] https://tools.ietf.org/html/draft-ietf-roll-rpl-observations-04#section-10
[2] RPL Observations: https://tools.ietf.org/html/draft-ietf-roll-rpl-observations-04
[3] https://tools.ietf.org/html/draft-ietf-roll-rpl-observations-04#section-7

---

From: Michael Richardson <[email-masked]>
Date: Mon, 14 Sep 2020 10:59:45 -0400

> I started this for the Path Control Bits handling issue in 6550.

can you explain what you mean bby Path Control Bits?
Is "T" one of those bits?

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Rahul Jadhav <[email-masked]>
Date: Mon, 14 Sep 2020 21:28:55 +0530

> Is "T" one of those bits?

https://tools.ietf.org/html/rfc6550#section-9.9 explains Path Control.
The DIO(Config Option) in the control plane carries PCS bits... Also the
DAO(TIO) carries Path control related information.

The strange part is very few really understand Path Control ... No open
source implements it. But it occupies a good amount of real estate in 6550.

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 14 Sep 2020 16:30:02 +0000

Hello Michael

This is a late addition (that we owe to Roger Alexander) to control the fan out of the DAO when the reverse subDAG (the DODAG that contains all the paths from this node to the root in the main DODAG) grows fat, each node copying multiple parents. This addition controls the number of copies that can be made, total. It’s cool and not rocket science but useless in an implementation that only builds trees of preferred parents – and missed the point of RPL which is to build and route over DODAGs, not trees.

Take care,

Pascal

From: Roll <[email-masked]> On Behalf Of Rahul Jadhav
Sent: lundi 14 septembre 2020 17:59
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] Path Control Bits handling issue in 6550

https://tools.ietf.org/html/rfc6550#section-9.9 explains Path Control.
The DIO(Config Option) in the control plane carries PCS bits... Also the DAO(TIO) carries Path control related information.

The strange part is very few really understand Path Control ... No open source implements it. But it occupies a good amount of real estate in 6550.

--
Michael Richardson <[email-masked]<mailto:[email-masked]>>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Michael Richardson <[email-masked]>
Date: Tue, 15 Sep 2020 03:12:30 -0400

> DAO(TIO) carries Path control related information.

Oh, yes.
I remember that I never thought very much about that part.

    > source implements it. But it occupies a good amount of real estate in 6550.

I'll need to re-read it again and think about it.