Subject: [Roll] a comment about unaware-leaves IANA section

From: Rahul Jadhav <[email-masked]>
Date: Tue, 23 Mar 2021 15:40:45 +0530

Hi Pascal, Authors,

Section 12.5 and Section 12.6 of the document
<https://www.rfc-editor.org/authors/rfc9010.html#name-new-subregistry-for-rpl-non>
specifies the RPL Status values. I believe section 12.5 is applicable only
when the 'E' bit of the status is set to 0 and Section 12.6 is applicable
only when the 'E' bit is set to 1. I came across this while reviewing it in
context to NPDAO compatibility.
Do you think this could be explicitly stated in the document while it is in
AUTH48 state?

Regards,
Rahul

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 23 Mar 2021 16:05:04 +0000

Very True, good point Rahul. I’ll mention to the RFC editor.
Take care,
Pascal

From: Roll <[email-masked]> On Behalf Of Rahul Jadhav
Sent: mardi 23 mars 2021 11:11
To: Pascal Thubert <[email-masked]>; Routing Over Low power and Lossy networks <[email-masked]>
Subject: [Roll] a comment about unaware-leaves IANA section

Hi Pascal, Authors,

Section 12.5 and Section 12.6 of the document<https://www.rfc-editor.org/authors/rfc9010.html#name-new-subregistry-for-rpl-non> specifies the RPL Status values. I believe section 12.5 is applicable only when the 'E' bit of the status is set to 0 and Section 12.6 is applicable only when the 'E' bit is set to 1. I came across this while reviewing it in context to NPDAO compatibility.
Do you think this could be explicitly stated in the document while it is in AUTH48 state?

Regards,
Rahul