Subject: Duplicate objects in RPSL DB

From: Tony Tauber <[email-masked]>
Date: Mon, 18 Oct 1999 13:18:28 -0400 (EDT)

Greetings,

We've got a tool here at GTE Internetworking that manages
our route object submissions and updates to our as-macro
object (soon to be as-set, I know).

I've got one of our developers looking at making it RPSL
compatible and he's mentioned, as I also noticed, that
there are duplicate entries with different source: lines
returned from whois-rpsl.radb.net.

The tool typically queries the DB and then decides whether
a new or updated object needs to be submitted.
The developer wondered how to handle the duplicates.  
In the case of the route-objects we're considering just 
parsing the one with the most recent changed: field, though 
that might not be the best approach as we only update the RADB, 
while others might update other registries.

In the case of the as-set macros, he noticed that the two entries
returned differ significantly.  I also noticed that neither was
current, one being more than a month old, the other nearly three
months old.  Is there not supposed to be a regular mirroring going
on between RIPE-181 and RPSL, or is that coming later?

What's going on?  What do you recommend going forward?

Thanks,

Tony Tauber
GTE Network Engineering

---

From: Gerald Andrew Winters <[email-masked]>
Date: Mon, 18 Oct 1999 14:57:51 -0400 (EDT)

Hello Tony,

You mention different source lines.  There is no linkeage
between the DB's and there very well could be duplicate
objects from seperate registries.  In the general case this 
is a by-product of having multiple registries and of not 
having rps-auth implemented yet.

Can you send me a sample query that yields duplicate
objects?  I would like to investigate this further
since the rpsl DB is new and it is possible the software
is doing something wrong.

Thanks for your feedback.

--jerry

---

From: Gerald Andrew Winters <[email-masked]>
Date: Mon, 18 Oct 1999 14:57:51 -0400 (EDT)

Hello Tony,

--jerry

---

From: Tony Tauber <[email-masked]>
Date: Mon, 18 Oct 1999 16:16:02 -0400 (EDT)

> Thanks for your feedback.

I know duplicate entries are seen from time to time.
I'm talking about duplicates for every object showing
up when querying the new vs. the old DB.

Try querying for the following objects:

199.94.208
as-bbntransit

at the two different servers:

whois.radb.net
whois-rpsl.radb.net

Thanks,

Tony

---

From: Bruce Campbell <[email-masked]>
Date: Tue, 19 Oct 1999 11:55:54 +1000 (EST)

On Mon, 18 Oct 1999, Tony Tauber wrote:

ttaube> there are duplicate entries with different source: lines
ttaube> returned from whois-rpsl.radb.net.
ttaube> 
ttaube> The tool typically queries the DB and then decides whether
ttaube> a new or updated object needs to be submitted.
ttaube> The developer wondered how to handle the duplicates.  

ttaube> that might not be the best approach as we only update the RADB, 

If you are just updating one database source, can I suggest using the '-s'
flag (aka standard RIPE NCC whois client), ie:

	$ whois -h whois-rpsl.radb.net -s RADB object-identifier

This should only return the matching object in the 'RADB' database, rather
than the 'RADB-CONV' and other databases.

Regards,

-- 
  Bruce Campbell <[email-masked]>                +61-7-3367-0490
                      Systems Administrator     Regional Internet Registry
    Asia Pacific Network Information Centre    For the Asia Pacific Region

---

From: Gerald Andrew Winters <[email-masked]>
Date: Mon, 18 Oct 1999 17:29:36 -0400 (EDT)

Tony,

Here is what I see:

route:         199.92.0.0/14
descr:         NETBLK-NEARNET-CBLK1
origin:        AS1
remarks:       just for you, Steve!
mnt-by:        BBNPLANET
changed:       [email-masked] 19980203
source:        RADB-CONV

route:         199.92.0.0/14
descr:         NETBLK-NEARNET-CBLK1
origin:        AS1
remarks:       just for you, Steve!
remarks:       This object is automatically converted from the RIPE181 registry
mnt-by:        BBNPLANET
changed:       [email-masked] 19980203
changed:       [email-masked] 19990726
source:        RADB

We agree this can be confusing and by 11/1 the RADB-CONV
db will disappear.  The RADB db is the current rpsl
db and the RADB-CONV db is the whois.radb.net ripe181
db autoconverted to rpsl.  The idea is to help the community
so you can see your objects converted to rpsl.

If you want to filter out the radb-conv db use the "-s"
whois option to specify your db source list:

% whois -h whois-rpsl.radb.net -sradb,ripe,ans,mci,canet 199.94.208
route:         199.92.0.0/14
descr:         NETBLK-NEARNET-CBLK1
origin:        AS1
remarks:       just for you, Steve!
remarks:       This object is automatically converted from the RIPE181 registry
mnt-by:        BBNPLANET
changed:       [email-masked] 19980203
changed:       [email-masked] 19990726
source:        RADB

If you are using irrd directly, use the "!s..." option to
do the same thing.

--jerry