Subject: [Rps] Re: Proposed changes to aut-num policy syntax in RPSLng

From: "Larry J. Blunk" <[email-masked]>
Date: 25 Feb 2004 15:47:04 -0500

I have not yet received any comments on these changes. I've gone ahead
and produced a new Internet Draft based on the text below.  It's
currently available at
http://www.radb.net/rpslng-03.html
and
http://www.radb.net/rpslng-03.txt

  The IETF Secretariat is not accepting new drafts until March 1.

 -Larry

On Fri, 2004-02-20 at 16:15, Larry J. Blunk wrote:
>     Andrei Robachevsky has proposed the following changes
> to the syntax for policy expressions in RPSLng based on
> feedback from the list and a desire to simplify the syntax for
> the case where v4/v6 and/or unicast/multicast policy are converged.
> 
> 1)  the absence of safi in an expression means that both
>     unicast and multicast are defined.  I.e.,
> 
>   afi ipv4 == afi ipv4.unicast,ipv4.multicast
> 
> 2)  The afi specification will be optional in the mp-*
>    attributes in the aut-num class.  If no afi is
>    specified, the policy shall be expanded to include
>    all afi and safi types, namely --
> 
>   afi ipv4.unicast,ipv4.multicast,ipv6.unicast,ipv6.multicast
> 
> 3)  introduce a pseudo afi with the value of "any".  I.e., 
> 
>   afi any.unicast == afi ipv4.unicast,ipv6.unicast
>   afi any == afi ipv4.unicast,ipv6.unicast,ipv4.multicast,ipv6.multicast
> 
> 
>     Looking forward to your feedback.
> 
>  Regards,
>    Larry
> 
> 
> 

_______________________________________________
Rps mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rps

---

From: "Larry J. Blunk" <[email-masked]>
Date: 25 Feb 2004 15:47:04 -0500

-Larry