Subject: [RPSEC] IPSEC and RIPng

From: "Vikas Jain" <[email-masked]>
Date: Mon, 18 Oct 2004 14:57:50 +0800

Hi,

Has there been any work on how RIPng can be secured by IPSEC (i.e. using
IPSEC for authenticating RIPng messages)? RFC 2080 mentions that RIPng
uses AH and ESP to authenticate messages. Is there any commercial
implementation that implements IPSEC with RIPng?

Please direct me to the right mailing list if this is not the correct
mailing list.

Thanks,

Vikas

_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

---

From: [email-masked]
Date: Mon, 18 Oct 2004 03:03:08 -0500

Vikas,

If you haven't already, please look at 
draft draft-ietf-ospf-ospfv3-auth-04.txt that talks about how
to secure OSPFv3 using IPsec.  Securing RIPng using IPsec would
be quite similar.  I do not know of any work in progress about
about RIPng and IPsec.

I have to admit that I haven't implemented RIPng security using
IPsec though.  I have implemented the above mentioned draft for
providing security to OSPFv3.

Regards
Mukesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Vikas Jain
Sent: Sunday, October 17, 2004 11:58 PM
To: [email-masked]
Subject: [RPSEC] IPSEC and RIPng

Hi,

Has there been any work on how RIPng can be secured by IPSEC (i.e. using IPSEC for authenticating RIPng messages)? RFC 2080 mentions that RIPng uses AH and ESP to authenticate messages. Is there any commercial implementation that implements IPSEC with RIPng?

Please direct me to the right mailing list if this is not the correct mailing list.

Thanks,
Vikas>

---

From: [email-masked]
Date: Mon, 18 Oct 2004 02:51:34 -0500

Vikas,

Regards
Mukesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Vikas Jain
Sent: Sunday, October 17, 2004 11:58 PM
To: [email-masked]
Subject: [RPSEC] IPSEC and RIPng

Hi,

Thanks,
Vikas>