Subject: Re: [rrg] [lisp] Economic issues of long-path / stretched routing

From: [email-masked]
Date: Mon, 26 Jan 2009 04:46:16 EST

In einer eMail vom 26.01.2009 04:07:41 Westeuropäische Normalzeit schreibt  
[email-masked]:

The  sub-optimal routing will only be for the LISP map-request.
The reply and  all encapsulated data traffic is between RLOCs
The ALT is merely there to  provide the correct mapping.

Prior arguing with long-path, stretch etc. I have another informative  
question (maybe I missed something too during the discussion): Why LISP 1.5 ?  Why 
not LISP 2 ? or directly:
Why doesn't the ITR intercept and enhance the DNS lookup as to also request  
the eRLOC address in addition to the dest IP address? It can also intercept 
the  respective response and store (EID, eRLOC).
 
I also ask this because wrt my TARA solution I would do the alike: The  
difference is only that the eRLOC information, to be retrieved from  DNS, are just 
the geographical coordinates of the ETR (as by experimental  RFC 1712).
So far I cannot see why there is a  (compelling ?) reason fro the ALT  
hierarchy at all.  
 
Thanks for answers to my question,
Heiner

_______________________________________________
rrg mailing list
[email-masked]
http://www.irtf.org/mailman/listinfo/rrg

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 26 Jan 2009 08:24:36 -0800

> Prior arguing with long-path, stretch etc. I have another  
> informative question (maybe I missed something too during the  
> discussion): Why LISP 1.5 ? Why not LISP 2 ? or directly:
> Why doesn't the ITR intercept and enhance the DNS lookup as to also  
> request the eRLOC address in addition to the dest IP address? It can  
> also intercept the respective response and store (EID, eRLOC).

1) Because not all communication uses DNS.
2) Because DNS queries go out one xTR and replies can come in through  
another xTR.
3) Because you don't want a architectural circular dependency between  
directory and routing.

Do you want more reasons?

Dino