Subject: [rrg] Common understanding

From: Toni Stoev <[email-masked]>
Date: Sat, 4 Jul 2009 21:44:22 +0300

Dear fellow (re)searchers,

Some of the opinions expressed on the list, with positions that I share, include the concept of protocol layering.
There is an alternative to that concept. It is the role-based architecture (RBA). It gives much freedom with consistency.
I would like to communicate here, knowing that at least some of you know what role-based architecture is.
Please, anyone interested, find the documentation of RBA and read it.
Or maybe you already know RBA.
Either case, please, let me know.

Toni

---

From: Lixia Zhang <[email-masked]>
Date: Tue, 7 Jul 2009 04:28:32 -0700

On Jul 4, 2009, at 11:44 AM, Toni Stoev wrote:

> Some of the opinions expressed on the list, with positions that I  
> share, include the concept of protocol layering.
> There is an alternative to that concept. It is the role-based  
> architecture (RBA). It gives much freedom with consistency.

Hi Toni,

Thanks for the msg, RBA can indeed be an interesting topic.
On the other hand, my understanding of the goal of this RG at this  
time is to address routing scalability issue without requiring the  
whole Internet moving to an entirely different architecture.

Lixia

---

From: Toni Stoev <[email-masked]>
Date: Wed, 8 Jul 2009 06:06:47 +0300

> whole Internet moving to an entirely different architecture.

Hi Lixia,

Surely this research group is not chartered to change the packet header processing model of the Internet.
But folks are using here protocol layering concepts as routing solution arguments. Meanwhile there modestly exists a role-based approach.
Are we stuck with the layering approach, or are we free to choose roling.
Let us free ourselves of this unclarity and face the real routing choices.

Besides routing, there is actually the need for a significantly different architecture. The RBA is a fundament for such a change. A few more (r)evolution aspiring concepts are needed for the change.

So, Lixia, thanks for knowing RBA.

Toni

---

From: Lixia Zhang <[email-masked]>
Date: Wed, 8 Jul 2009 00:56:09 -0700

On Jul 7, 2009, at 8:06 PM, Toni Stoev wrote:

> But folks are using here protocol layering concepts as routing  
> solution arguments. Meanwhile there modestly exists a role-based  
> approach.
> Besides routing, there is actually the need for a significantly  
> different architecture. The RBA is a fundament for such a change. A  
> few more (r)evolution aspiring concepts are needed for the change.

IAB set up a mailing list a few years back specifically for  
architecture-related discussion:
   [email-masked]
   https://www.ietf.org/mailman/listinfo/architecture-discuss

FYI,
Lixia

---

From: Toni Stoev <[email-masked]>
Date: Wed, 8 Jul 2009 23:24:14 +0300

>    https://www.ietf.org/mailman/listinfo/architecture-discuss

Thank you very much, Lixia.